Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#8799 - Catalyst-utlis required by mesa, mplayer and xine-lib?

Attached to Project: Arch Linux
Opened by ndlarsen (ndlarsen) - Friday, 30 November 2007, 07:50 GMT
Last edited by Roman Kyrylych (Romashka) - Friday, 30 November 2007, 12:14 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version 2007.08-2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

pacman -R catalyst-utils
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: catalyst-utils is required by mesa
:: catalyst-utils is required by mplayer
:: catalyst-utils is required by xine-lib

pacman -S libgl
resolving dependencies... done.
looking for inter-conflicts...
:: libgl conflicts with catalyst-utils. Remove catalyst-utils? [Y/n]
done.
error: failed to prepare transaction (could not satisfy dependencies)
:: catalyst-utils requires mesa
:: catalyst-utils requires mplayer
:: catalyst-utils requires xine-lib

pacman -Q catalyst-utils mesa mplayer xine-lib
catalyst-utils 7.11-1
mesa 7.0.1-1
mplayer 1.0rc2-1
xine-lib 1.1.8-1

Now, this strikes me as a little odd, perhaps something was build with catalyst-utils installed rather than libgl? Correct me if I am wrong.
This task depends upon

Closed by  Roman Kyrylych (Romashka)
Friday, 30 November 2007, 12:14 GMT
Reason for closing:  Not a bug
Comment by Roman Kyrylych (Romashka) - Friday, 30 November 2007, 12:14 GMT
Everything is fine.
catalyst-utils provides libgl which is required by mesa, mplayer and xinelib.

$ pacman -Si catalyst-utils | grep Provides
Provides : libgl
$ pacman -Si xine-lib | grep Depends
Depends On : libgl libxvmc esd flac>=1.1.4 libvorbis sdl libmng
$ pacman -Si mesa | grep Depends
Depends On : libgl glproto gcc libxt
$ pacman -Si mplayer | grep Depends -A1
Depends On : libxxf86dga libxv libmad libungif cdparanoia gtk2 sdl
lame libtheora xvidcore libgl smbclient aalib


Same with nvidia-utils here:

# pacman -R nvidia-utils
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: nvidia-utils is required by gstreamer0.10-bad
:: nvidia-utils is required by mesa
:: nvidia-utils is required by nvidia
:: nvidia-utils is required by compiz-core
:: nvidia-utils is required by gnome-screensaver

# pacman -S libgl
resolving dependencies... done.
looking for inter-conflicts...
:: libgl conflicts with nvidia-utils. Remove nvidia-utils? [Y/n]
done.
error: failed to prepare transaction (could not satisfy dependencies)
:: nvidia-utils requires gstreamer0.10-bad
:: nvidia-utils requires mesa
:: nvidia-utils requires nvidia
:: nvidia-utils requires compiz-core
:: nvidia-utils requires gnome-screensaver

Pacman is doing the right thing during -R because libgl-providing package cannot be removed.
It does the wrong thing on -S libgl though, it's a known bug that is fixed in 3.1:  FS#6057  (described as #2 here http://bugs.archlinux.org/task/6057#comment15370)

Loading...