Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#8783 - gpgme dependencies

Attached to Project: Arch Linux
Opened by Greg (dolby) - Wednesday, 28 November 2007, 15:24 GMT
Last edited by Roman Kyrylych (Romashka) - Wednesday, 30 January 2008, 18:48 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Roman Kyrylych (Romashka)
Architecture All
Severity Low
Priority Normal
Reported Version 2007.08-2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: GPGME in extra depends on both gnupg & gnupg2. AFAIK those 2 do the exact same thing. Does anyone know of a reason it should continue depending on both? I do not. I might be wrong here but googling for an answer didnt help much. besides maybe this:gentoo-dev@lists.gentoo.org/msg22384.html"> http://www.mail-archive.com/gentoo-dev@lists.gentoo.org/msg22384.html.
Also AFAIK most Arch packages i have come across depend or makedepend only on gnupg.
This task depends upon

Closed by  Roman Kyrylych (Romashka)
Wednesday, 30 January 2008, 18:48 GMT
Reason for closing:  Not a bug
Comment by Greg (dolby) - Saturday, 08 December 2007, 09:15 GMT
i investigated this a bit further and seems gpgme supports 2 tools. one is gnupg and the other is gpgsm (part of gnupg2). that would explain the dependency on both but the package is built without pointing to any of the two.
attached the PKGBUILD i currently use
   PKGBUILD (0.6 KiB)
Comment by Greg (dolby) - Tuesday, 15 January 2008, 14:11 GMT
While browsing here i found a closed bug report which might have been the reason that gnupg2 was added as a dependency of gpgme. http://bugs.archlinux.org/task/5370
what i wonder though is if simply adding a dependncy to gpgme is the correct way to deal with this. if its only a kmail problem why not adding it as dependency only to kmail itself? or a similar approach.
gpgme does not need both..
Comment by Roman Kyrylych (Romashka) - Wednesday, 30 January 2008, 18:47 GMT
From that bugreport it looks like gpgme needs to be compiled with gpgme2 for S/MIME signing/encryption support.
Also, gnupg and gnupg have a very different set of tools, see pacman -Ql gnupg gnupg2 | grep bin
I don't see a reason/benefit to change anything.

Loading...