AUR web interface

**This is the bug tracker for the AUR web interface.**

Use this tracker to report bugs or make feature requests regarding the behaviour or implementation of the AUR software.
Please read the Reporting Bug Guidelines before filing a new task.
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

- Please report bugs related to Arch Linux official packages here: http://bugs.archlinux.org/index.php?project=1
- Please report bugs for [community] packages here: http://bugs.archlinux.org/index.php?project=5
- For any packages in the AUR contact the maintainer or leave a comment on the package's detail page.

Source Code:
https://projects.archlinux.org/aurweb.git/
Tasklist

FS#8672 - Can't submit new package to AUR

Attached to Project: AUR web interface
Opened by Alexander Drozdov (adrozdov) - Saturday, 17 November 2007, 04:49 GMT
Last edited by Loui Chang (louipc) - Wednesday, 03 September 2008, 22:41 GMT
Task Type Bug Report
Category Backend
Status Closed
Assigned To Simo Leone (neotuli)
Loui Chang (louipc)
Architecture All
Severity High
Priority Normal
Reported Version 1.2.9
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 18
Private No

Details

Submit new package but it fail: 'can't create direcrory /home/aur/qca2'
I look to http://aur.archlinux.org/packages/qca2/ but directory is present and my archive is present also but it is not unpacked.
This task depends upon

Closed by  Loui Chang (louipc)
Wednesday, 03 September 2008, 22:41 GMT
Reason for closing:  Duplicate
Additional comments about closing:  This is probably a duplicate of  FS#11187 
11187 has more relevant detail so discussion should continue on that thread.
Comment by Alexander Drozdov (adrozdov) - Saturday, 17 November 2007, 04:57 GMT
I try to submit psi-qt4 and it also fail.
Comment by Darwin Bautista (djclue917) - Saturday, 17 November 2007, 07:38 GMT
Same here. I think this is confirmed already.
Comment by Darwin Bautista (djclue917) - Saturday, 17 November 2007, 13:28 GMT
Just for the record, updating a package also results in the error reported above.
Comment by eliott (cactus) - Saturday, 17 November 2007, 17:12 GMT
My fault.
Should be working now. Sorry about that.
Comment by roy (royrocks) - Wednesday, 30 January 2008, 13:44 GMT
  • Field changed: Percent Complete (100% → 0%)
same here.
Comment by Paul Mattal (paul) - Wednesday, 30 January 2008, 13:47 GMT
Can you attach some example files here that you are unable to upload?
Comment by roy (royrocks) - Thursday, 31 January 2008, 11:58 GMT
...
Comment by roy (royrocks) - Tuesday, 19 February 2008, 12:43 GMT
Just delete the isight-firmware-tools folder and close this bug!
There should be a src-folder check...
Comment by Kristaps Esterlins (esters_) - Sunday, 16 March 2008, 20:03 GMT
This happens also to me - http://bbs.archlinux.org/viewtopic.php?id=45521

The file i'm trying to upload -
Comment by Jason Tarbet (nochternus) - Monday, 24 March 2008, 16:57 GMT
I am getting this error as of this morning while trying to attempt an update on my zaptel package. The only change made was an update to a .rules file.
Comment by Jason Tarbet (nochternus) - Monday, 24 March 2008, 16:57 GMT
forgot to mention that the directory name was /home/aur/unsupported/zaptel
Comment by Christoper Daley (luciferin) - Monday, 07 April 2008, 18:32 GMT
I get the same error while trying to upload projectm-qt package. The directory does not exist yet but I get "You are not allowed to overwrite the projectm-qt package." I think it's because I uploaded a package that depended on projectm-qt before it existed.
Comment by ArchPetr (ArchPetr) - Friday, 11 April 2008, 13:22 GMT
Hello, i confirm the bug: You are not allowed to overwrite the...

I received this error from aurup bash utility and from aur web client too.
Comment by Paweł Stankowski (Ambi) - Sunday, 13 April 2008, 10:47 GMT
The same with lib32-dbus package
Comment by Mathieu Clabaut (mathieu.clabaut) - Thursday, 24 April 2008, 16:24 GMT
The same with perl-css
Comment by Mathieu Clabaut (mathieu.clabaut) - Thursday, 24 April 2008, 16:26 GMT
In addition, the error message is : "You are not allowed to overwrite the perl-css package."
Comment by Mathieu Clabaut (mathieu.clabaut) - Thursday, 24 April 2008, 16:40 GMT
The same with perl-devel-stacktrace
Comment by Loui Chang (louipc) - Tuesday, 20 May 2008, 20:23 GMT
I had another hunch on what might be causing this bug and I tested
on my local instance of AUR.

What seems to be the problem is that if you upload a package that
depends on another non-existing package it will lock you out from
uploading the dependency.

I think the assumption here was that if you put a dependency and it
didn't exist in AUR that it had to exist in the official repos. That's
a silly assumption of course because things do change.

Gee there are a lot of bugs I've seen caused by too many assumptions.

There might be more to the bug because I have seen some other weird
behaviour, but this is one case I can confirm from a test.

This definitely requires a code patch and possibly some database modification.
A one-off fix would be to modify the relevant database entries to make
the dependency look like a normal AUR package.

Comment by Alexander Jenisch (eNTi) - Wednesday, 21 May 2008, 06:42 GMT
my 2 cents (so to say)...
Comment by Alexander Jenisch (eNTi) - Wednesday, 21 May 2008, 06:44 GMT
they're both requirements to speechd (speech-dispatcher), witch is an optional requirement for mumble. i could upload the speechd package.
Comment by Anders Bergh (anders) - Thursday, 22 May 2008, 13:40 GMT
coxpcall, required for copas :(
Comment by Peter Mykytyn (vedenemo) - Monday, 26 May 2008, 14:22 GMT
I'm trying to submit "rpm" also fails with "You are not allowed to overwrite the rpm package."
thx.
Comment by Loui Chang (louipc) - Sunday, 01 June 2008, 20:03 GMT
Here are the proper mysql commands to fix this on a one off basis:

USE AUR;
UPDATE Packages SET DummyPkg = 0 WHERE Name = "pkgname";
UPDATE Packages SET LocationID = 2 WHERE Name = "pkgname";

The package should then be visible as an orphan from the web interface.
Adopt it and upload your tarball.
Comment by Jean-Marc AMBROSINO (mightyjaym) - Wednesday, 04 June 2008, 11:51 GMT
Same problem with lib32-liboil and lib32-orbit2.
Comment by Ionut Biru (wonder) - Wednesday, 04 June 2008, 11:55 GMT
same problem for fontconfig-ubuntu and libxft-ubuntu
Comment by Loui Chang (louipc) - Thursday, 05 June 2008, 16:42 GMT Comment by Jonathan Liu (net147) - Tuesday, 22 July 2008, 12:12 GMT
I still can't submit zaptel package to AUR. It fails with the message "You are not allowed to overwrite the zaptel package." When I search the AUR for the zaptel package it does not show in the results.
Comment by Paul Mattal (paul) - Tuesday, 22 July 2008, 12:12 GMT
Is this because the committed changes are not rolled out yet?
Comment by Ionut Biru (wonder) - Tuesday, 22 July 2008, 12:33 GMT
that bug is resolved in 1.5.2 but aur.archlinux.org has version 1.5.1
Comment by Loui Chang (louipc) - Tuesday, 22 July 2008, 21:42 GMT
Yes. We just need a developer to update the web site.
The only concern for the upgrade would be making sure that the
Pear modules are properly installed and found by pkgsubmit.php.

I hope Simo will take care of it soon.
Comment by Paul Mattal (paul) - Tuesday, 22 July 2008, 21:48 GMT Comment by Loui Chang (louipc) - Tuesday, 22 July 2008, 23:12 GMT
Damn that guy is sweating.
Comment by Jonathan Liu (net147) - Wednesday, 30 July 2008, 23:54 GMT
Still not fixed yet. Now I get the message "Could not create directory /home/aur/unsupported/zaptel."
Comment by Callan Barrett (wizzomafizzo) - Thursday, 31 July 2008, 12:44 GMT
What was it saying before? And can you upload the PKGBUILD you're using?
Comment by Jonathan Liu (net147) - Thursday, 31 July 2008, 12:47 GMT
If you read the comment I made before my last comment, it previously said "You are not allowed to overwrite the zaptel package."
After update to 1.5.2, it not says "Could not create directory /home/aur/unsupported/zaptel."

The package i'm trying to submit is attached.
Comment by Vitaliy Berdinskikh (skipper13) - Saturday, 23 August 2008, 15:52 GMT Comment by Xavier (shining) - Monday, 25 August 2008, 14:18 GMT
Why is this still open?
As far as I can tell, the only thing similar between this bug and 11187 is the message displayed to the user, and the workaround (delete the directory on AUR filesystem).
Loui, is that correct?

What about the following list :
http://wiki.archlinux.org/index.php/AUR_CleanUp_Day#Remove_from_Filesystem_.28AUR_Bugs.29

How badly outdated is it?
Comment by Sven (Echtor2oo3) - Wednesday, 27 August 2008, 17:00 GMT
Same here ( http://aur.archlinux.org/packages.php?ID=19368 )
Here is the packet:
Comment by Dmitrij (DsTr) - Tuesday, 02 September 2008, 14:31 GMT Comment by Loui Chang (louipc) - Wednesday, 03 September 2008, 22:39 GMT
Xavier, sorry for the late response.
I think this bug (8672) and 11187 are actually the same and I just managed
to find a separate bug which was preventing uploads of dependencies.
Removing directories would not have remedied the bug that was solved.

I'll close this and continue the line of investigation via 11187 since there
are more relevant details about the bug there.

I believe that the list of bad directories at
http://wiki.archlinux.org/index.php/AUR_CleanUp_Day is still pretty relevant.

I think we can automate removal of all files of packages that aren't in the
database. Since users can no longer delete packages, so there's no chance of
malicious adoption then deletion of packages.

Loading...