Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#8663 - dosbox needs libgl, which conflicts with nvidia-utils

Attached to Project: Arch Linux
Opened by Francois Charette (Firmicus) - Friday, 16 November 2007, 14:54 GMT
Last edited by Thomas Bächler (brain0) - Friday, 16 November 2007, 15:10 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To James Rayner (iphitus)
Thomas Bächler (brain0)
Architecture i686
Severity Medium
Priority Normal
Reported Version 2007.08-2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
dosbox depends on libgl, but on my system I needed nvidia-utils, which conflicts with libgl.
This means I can no longer use dosbox.

Additional info:
* package version(s)
0.72-2
This task depends upon

Closed by  Thomas Bächler (brain0)
Friday, 16 November 2007, 15:10 GMT
Reason for closing:  Not a bug
Additional comments about closing:  nvidia-utils provides libgl. if anything, this may be a pacman bug, but without an actual error message, there is nothing we can do.
Comment by Francois Charette (Firmicus) - Friday, 16 November 2007, 15:00 GMT
I forgot to mention that the libGL.so library provided by nvidia-utils is incompatible with the current build of dosbox. So it needs to be recompiled.

Also, nvidia-utils should probably have
provides=('libgl')
in its PKGBUILD !
Comment by Francois Charette (Firmicus) - Friday, 16 November 2007, 15:00 GMT
I forgot to mention that the libGL.so library provided by nvidia-utils is incompatible with the current build of dosbox. So it needs to be recompiled.

Also, nvidia-utils should probably have
provides=('libgl')
in its PKGBUILD

Loading...