Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#8662 - No access with digikam to Canon Powershot A40 camera

Attached to Project: Arch Linux
Opened by Dieter Rethmeyer (Dieter) - Friday, 16 November 2007, 13:15 GMT
Last edited by Greg (dolby) - Thursday, 24 July 2008, 05:51 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jason Chu (jason)
Architecture i686
Severity Low
Priority Normal
Reported Version 2007.08-2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I connect my camera Canon Powershot A40 via USB cable to the PC and try to download the images from the camera. The camera is automatically detected, but images cannot be downloaded "no connection to camera".

Perhaps this is the same problem as described here (libgphoto2 problem):
http://www.nabble.com/libgphoto2-2.4.0-package-for-testing-t4432432.html

Problem started about end of October / start of November 2007. Can't remember which packages have been updated before the problem occured.
This task depends upon

Closed by  Greg (dolby)
Thursday, 24 July 2008, 05:51 GMT
Reason for closing:  Fixed
Comment by Mikko Vepsäläinen (mikko_v) - Sunday, 18 November 2007, 15:14 GMT
I can confirm this for a Canon Powershot A95 camera. A new USB device is detected, but Digikam cannot connect to camera. This seems to be permissions problem, I am in the "camera" group but the permissions of the created device node
(e.g. /dev/bus/usb/003/009) are 660 root:root.

I tracked this down to udev rules, the camera is listed in /etc/udev/rules.d/54-gphoto.rules, but in the beginning of this file there is the line
SUBSYSTEM!="usb_device", GOTO="libgphoto2_rules_end"
At least on my computer the subsystem for the camera (as shown by udevinfo) is "usb", not "usb_device", so all the camera rules are ignored. Changing in the above file "usb_device" to "usb" gets the permissions correct and the camera is working again.

I don't know if this is a kernel problem or a libgphoto2 one, i.e. which is the correct value of the subsystem. I am using libgphoto2-2.4.0-2 and udev-116-2 from Arch repositories and a self-compiled vanilla 2.6.23.1 kernel. The problem appeared after libgphoto update (2.3.1-3 -> 2.4.0-2) about a week ago.
Comment by Dieter Rethmeyer (Dieter) - Monday, 26 November 2007, 18:51 GMT
Sorry, but I still get "cannot connect to camera" with actual libgphoto2 2.4.0-4
In about 10% of tries the camera can be accessed, but 90% fail.

With libgphoto2 2.3.1.3 there hadn't been a problem.

Or is the fix in a later version than 2.4.0-4?
Comment by Dieter Rethmeyer (Dieter) - Saturday, 15 March 2008, 11:25 GMT
It's not a digikam issue, it's libgphoto2.

Can the maintainer of libgphoto2 please look at the patches applied by debian? It seems to me that some are necessary to get a Canon camera to work with version 2.4.0 of libgphoto2. Thanks!

Debian changelog: http://packages.debian.org/changelogs/pool/main/libg/libgphoto2/current/changelog
Comment by mef (mefiX) - Tuesday, 15 April 2008, 10:10 GMT
I can confirm this behaviour with my Canon Powershot A520 camera.
Unfortunately, in my case it seems that the permissions are correct, i have root:camera with 660 on /dev/bus/usb/003/006.
My /etc/udev/rules.d/54-gphoto.rules has both entries =="usb" AND =="usb_device"
version 2.4.0-5
Comment by Glenn Matthys (RedShift) - Tuesday, 17 June 2008, 08:36 GMT
Is this fixed with version 2.4.1? If not, please post a bugreport upstream at http://sourceforge.net/tracker/?group_id=8874&atid=108874
Comment by Dieter Rethmeyer (Dieter) - Thursday, 19 June 2008, 19:50 GMT
I just tested with actual arch package libgphoto2 2.4.0-6 (and the other package updates):
Now it works for me, I can access my Canon camera again.
Comment by Dieter Rethmeyer (Dieter) - Thursday, 19 June 2008, 19:53 GMT
I assume bugs  FS#8750  and  FS#10685  are related to this one.

- and one remark: I can't find an arch package 2.4.1, not even in testing repository.
Comment by Greg (dolby) - Wednesday, 23 July 2008, 19:18 GMT
Now we have libgphoto2 2.4.2 can you try with that?
Comment by Dieter Rethmeyer (Dieter) - Thursday, 24 July 2008, 05:38 GMT
Access to Canon A40 is ok now -
but now I can't access my Fuji Coolpix 5600 (USB PTP class camera in digikam).

Loading...