Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#8578 - [catalyst-8.01] [fglrx:firegl_lock] *ERROR* Process 7826 is using illegal context 0x00000004

Attached to Project: Arch Linux
Opened by Revo (revo) - Thursday, 08 November 2007, 18:34 GMT
Last edited by Travis Willard (Cerebral) - Thursday, 01 May 2008, 17:52 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Travis Willard (Cerebral)
Architecture All
Severity Medium
Priority Normal
Reported Version 2007.08-2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
After xorg-server and fglrx update the video driver is not working correctly. Using mplayer to watch movies with GL driver mplayer uses ~90% CPU and over 10% of memory. After running glxgears the dmesg output is: [fglrx:firegl_lock] *ERROR* Process 7826 is using illegal context 0x00000004

I seems that instead of the video card chipset the system chipset is used.

Additional info:
* package version(s)
fglrx 8.42.3-1
xorg-server 1.4-5

* config and/or log files etc.
Attatched: output of atigetsysteminfo.sh

Steps to reproduce:
It appears every time I run glxgears or mplayer.
This task depends upon

Closed by  Travis Willard (Cerebral)
Thursday, 01 May 2008, 17:52 GMT
Reason for closing:  Won't fix
Additional comments about closing:  I'm tired of tracking upstream bugs in our bugtracker.
Comment by Revo (revo) - Thursday, 08 November 2007, 18:39 GMT
Sorry, forgot the file...
Comment by Travis Willard (Cerebral) - Friday, 09 November 2007, 12:51 GMT
Try disabling AIGLX - unfortunately, the 8.42.3 drivers are the only ones supporting xorg-server1.4, and they kinda suck.

In xorg.conf:

Section "Extensions"
Option "Composite" "Disable"
EndSection

Section "ServerFlags"
Option "AIGLX" "off"
EndSection

Also, if you find corruption of the screen under the mouse or in the bottom right corner, try adding this to your fglrx device section:

Option "XAANoOffscreenPixmaps" "true"
Comment by Revo (revo) - Friday, 09 November 2007, 17:58 GMT
Already tried this workaround, but unfortunately it doesn't work :(
Comment by Travis Willard (Cerebral) - Monday, 19 November 2007, 14:20 GMT
I'll see if I can find any fixes - although I doubt I will be able to do anything except hope that 8.43 gets this fixed.
Comment by Travis Willard (Cerebral) - Friday, 23 November 2007, 04:16 GMT
Most likely still a problem in catalyst-7.11
Comment by Revo (revo) - Friday, 23 November 2007, 21:06 GMT
Yes, after the upgrade to catalyst-7.11 the problem remains :(
Comment by João Rodrigues (gothicknight) - Tuesday, 27 November 2007, 15:36 GMT
You shouldn't use GL output when using fglrx as they get flickering all the time and use cpu as if there's no tomorrow, maybe try the XV output extension?

I've tried several times change to gl2 output but I've cross with the same problem all the time and reverted do xv output.

Also there's some info regarding memory leaks in OpenGL applications that might be the source of your memory problem ;)
Comment by Revo (revo) - Tuesday, 27 November 2007, 18:33 GMT
Actually I'm using X11 output extension at the moment, but there is a a big problem with it: I can't make the video screen larger (I can resize it, but the actual video screen size doesn't change, it only adds a one-color frame).
With XV mplayer say's: cannot initialize vo...
Comment by Travis Willard (Cerebral) - Friday, 21 December 2007, 01:58 GMT
new version - catalyst 7.12

please verify bug still exists
Comment by Travis Willard (Cerebral) - Sunday, 27 January 2008, 15:46 GMT
new version - catalyst 8.01

please verify bug still exists
Comment by Revo (revo) - Sunday, 27 January 2008, 17:08 GMT
Yes, the bug still exists :(
Comment by Travis Willard (Cerebral) - Monday, 18 February 2008, 23:24 GMT
any luck with 8.02?
Comment by Revo (revo) - Tuesday, 19 February 2008, 15:48 GMT
still no luck, the problem remains the same.

Loading...