Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#8545 - Abiword crashes at its startyp in Archlinux Core Dump

Attached to Project: Arch Linux
Opened by pibarnas (pibarnas) - Wednesday, 07 November 2007, 07:39 GMT
Last edited by Aaron Griffin (phrakture) - Tuesday, 18 December 2007, 04:19 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Aaron Griffin (phrakture)
Architecture All
Severity Medium
Priority Normal
Reported Version 2007.08-2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Abiword crashes at its startyp in Archlinux core dump.


Additional info:
* package version(s)

2.4.6-2

* config and/or log files etc.


Steps to reproduce:

Just open it on a terminal. In a second, its splash screen appears and go, but the program doesn't show up with just a message in the terminal: aborted

I've tried a lot to understand this bug, but I couldn't so I can't solve it. The dependencies are ok and so are its plugins.
This task depends upon

Closed by  Aaron Griffin (phrakture)
Tuesday, 18 December 2007, 04:19 GMT
Reason for closing:  Fixed
Comment by Fredrik (vEX) - Saturday, 15 December 2007, 13:21 GMT
Starts fine for me (x86-64 and up-to-date system as of this post).

$ pacman -Q abiword
abiword 2.4.6-2
$ abiword
$
Comment by Roman Kyrylych (Romashka) - Saturday, 15 December 2007, 13:26 GMT
could you try with configs removed?
Comment by Greg (dolby) - Sunday, 16 December 2007, 10:50 GMT
works perfectly fine on i686 too
Comment by Aaron Griffin (phrakture) - Monday, 17 December 2007, 06:23 GMT
Status? Does it still happen?

It works fine here
Comment by Fredrik (vEX) - Monday, 17 December 2007, 13:21 GMT
Sorry for the late reply, it seems like my mail host is having problems, just got the notification mail today(!).

$ rm -rf ~/.AbiSuite
$ abiword
$

No problem at all, it works fine.
Comment by pibarnas (pibarnas) - Monday, 17 December 2007, 18:04 GMT
(14:27:43┬Ěpibarnas@hal9000)
[~]$ rm -rf .AbiSuite/

(14:55:39┬Ěpibarnas@hal9000)
[~]$ abiword
Fontconfig error: "local.conf", line 6: junk after document element
Fontconfig error: "local.conf", line 6: junk after document element
Abortado

Later, with the appropriate local.conf:

(14:58:58┬Ěpibarnas@hal9000)
[~]$ abiword
Abortado

Abortado=aborted

Too weird!
Comment by Fredrik (vEX) - Monday, 17 December 2007, 18:56 GMT
That's really weird!

abiword --help reveals that there's a --verbose flag, does it print out any information if you start it with the flag ("abiword --verbose=2")? Though I'm unsure if it's working the way I think it does, because it doesn't print out any information when I use AbiWord. Might just print warning/errors though.

Loading...