Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#8485 - gimp save as only works once

Attached to Project: Arch Linux
Opened by robin wood (dninja) - Friday, 02 November 2007, 11:02 GMT
Last edited by Jan de Groot (JGC) - Sunday, 09 November 2008, 10:35 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Tobias Kieslich (tobias)
Architecture All
Severity Medium
Priority Normal
Reported Version 2007.08-2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

If I do a save as in gimp it works ok, if I then do another save as on the same image the save box comes up blank. The box is the right size just doesn't have anything in it. If I close the image and re-open it save as works ok.

Additional info:
* package version(s)
gimp-2.4.1-1 - gimp-2.4.5-1

* config and/or log files etc.
don't know which would help, happy to post any on request

Steps to reproduce:
happens every time.
open image
save as new image
save as new image - gives blanks dialog

UPDATE 2008-05-26: Likely related to this upstream bug: http://bugzilla.gnome.org/show_bug.cgi?id=483502
This task depends upon

Closed by  Jan de Groot (JGC)
Sunday, 09 November 2008, 10:35 GMT
Reason for closing:  Fixed
Additional comments about closing:  Assuming fixed. See last comments.
Comment by Cesar Alcalde (noalwin) - Friday, 02 November 2007, 14:06 GMT
I couldn't reproduce it
Comment by Branko Vukelic (foxbunny) - Monday, 05 November 2007, 12:35 GMT
It works fine here, too.
Comment by Branko Vukelic (foxbunny) - Monday, 05 November 2007, 12:36 GMT
What format did you save into? Could you upload your image so we can try to reproduce it?
Comment by robin wood (dninja) - Monday, 05 November 2007, 15:22 GMT
I've just tried to reproduce it and now I can't.

The file at the time was a number of png files created in gimp. I was creating them, rotating them then resaving.

It is probably worth closing but if it happens again I'll send some files in.
Comment by Jan de Groot (JGC) - Monday, 12 November 2007, 09:14 GMT
See the related/duplicate task for an example image.
Comment by Tobias Kieslich (tobias) - Tuesday, 13 November 2007, 04:56 GMT
ok, to clearify, I downloaded 0.png, opened in gimp (via OPEN Dialog, click in th filemanager), "Save as" -> 0a.png, and then "Save as" -> 0b.png
that worked flawlessly for me
Comment by robin wood (dninja) - Tuesday, 13 November 2007, 09:02 GMT
Try doing a rotate 90 degrees clockwise between saves.

I can still reproduce this every time.

I've attached a screenshot of the dialog box.

Something I've noticed is the first save pops up the options box for png, the second time that box doesn't appear. Maybe it is locked on trying to draw that and so not getting round to drawing the save as box.
Comment by Tobias Kieslich (tobias) - Wednesday, 21 November 2007, 22:34 GMT
does that still happen on gimp-2.4.2 ?
Comment by robin wood (dninja) - Thursday, 22 November 2007, 09:14 GMT
Ye, I've just done an update to extra/gimp 2.4.2-1 and it is still happening.

I'm happy to try anything you suggest to get this sorted.
Comment by Tobias Kieslich (tobias) - Thursday, 22 November 2007, 23:53 GMT
works absolutely fine here, can you produce that with other files, try to save as a xcf file
Comment by robin wood (dninja) - Friday, 23 November 2007, 09:25 GMT
I tried png first to make sure it was still broken then tried xcf, bmp and jpg, all worked ok. I tried png again after successfully saving in other formats and multiple saves worked ok. It seems to just be if I do the exact steps.
Comment by Tobias Kieslich (tobias) - Friday, 23 November 2007, 18:25 GMT
okay, I'm fishing here and it seems to be a very specific issue, that no one else can reproduce. Not saying your fault, but it will take some effort to help you and I don;t consider this to be a generic bug anymore. But here we go.
cd ~
tar czf mygimpsettings.tar.gz .gimp-2.4
rm -rf -.gimp-2.4
I assume you know what that does. Do that, then you can try your problem with the factory settings. Does it work?
Comment by robin wood (dninja) - Friday, 23 November 2007, 18:30 GMT
I've just tried removing both .gimp-2.4 and .gimp-2.2 then testing and it still fails.

I realise that this is a local issue, I know how to work around it (and to be honest will probably not be in the situation to need this again anyway) so if you want to close it feel free.
Comment by Tobias Kieslich (tobias) - Friday, 23 November 2007, 21:45 GMT
okay it would be still nice to find the issue to report it elsewhere. When you klick "Save As" the second time, does the png settings dialogue come up or not?
Also, which gtk theme on which gtk engine are you running? Can you use a different theme (one that uses a different engine) for another test?
Comment by robin wood (dninja) - Friday, 23 November 2007, 22:49 GMT
No, the png dialog doesn't come up but testing it with jpg which also opens a dialog that does open the second time.

How do I tell which gtk stuff I'm running? I've not set anything special or changed anything so I guess it is probably whatever is default.
Comment by Tobias Kieslich (tobias) - Friday, 23 November 2007, 23:34 GMT
what environment are you running? KDE Gnome Xfce4 ...?
Comment by robin wood (dninja) - Friday, 23 November 2007, 23:48 GMT
fluxbox
Comment by Tobias Kieslich (tobias) - Saturday, 24 November 2007, 00:55 GMT
sudo pacman -S gtk-theme-switch2 helps you to figure that out and changes to another theme. Also pacman -S gtk-xfce-engine, this is what I use and here it works.
So first check what your's use, and the select another one and try with that.
Comment by robin wood (dninja) - Sunday, 25 November 2007, 23:36 GMT
I'm away for a week but will try it when I get back and let you know the result
Comment by Matthias Dienstbier (fs4000) - Sunday, 02 December 2007, 22:38 GMT
I have exactly the same problem. It appears when using composite extension of X. Disabling the composite manager and restarting X solves the problem.
(But it doesn't look as well as before ;-)
Comment by Tobias Kieslich (tobias) - Monday, 03 December 2007, 01:38 GMT
Oh here we go, which window manager do you use?
Comment by robin wood (dninja) - Monday, 03 December 2007, 09:43 GMT
ok, I installed the theme switcher and I was using Default. I installed the other package and tried a few different ones but still the same result.

Matthias, how did you disable the extension? I'll give this a try and see if it works for me as well.
Comment by Matthias Dienstbier (fs4000) - Monday, 03 December 2007, 19:43 GMT
I'm using KDE, KWin, kompmgr (the KDE composite manager, like beryl) and gtk-qt-engine to improve the appearance of gtk-programs (I chose clearlooks as theme).
Here is a instruction how to use the feature in KDE: http://docs.kde.org/stable/en/kdebase/kompmgr/index.html
I added a screenshot. For some reason the problem didn't happen with the screenshot, but creating a new and empty image and saving it multiple times fails.
Comment by Greg (dolby) - Monday, 17 December 2007, 09:02 GMT
is this still an issue with gimp 2.4.3?
Comment by robin wood (dninja) - Monday, 17 December 2007, 09:53 GMT
Ye, just tested it. I opened a png, saved it as a jpg, made a change and did a save as, got a blank save as dialog box.
Comment by Tobias Kieslich (tobias) - Monday, 17 December 2007, 17:17 GMT
okay I can confirm that this happens with the composite manager now that I tried compiz-fusion. However, there is no gimp error output. can anybody try this WITH COMPOSITE ENABLED on another distro please. I can't think of anything Arch specific here that would trigger that. It also would help:

- what flags are set in xorg.conf
- which hardware for graphics.

here is mine
- Section "Device"
Identifier "card-DFP"
Driver "nvidia"
#Driver "nv"
Option "RenderAccel" "True"
Option "AllowGLXWithComposite" "True"
Option "NvAGP" "1"
Option "NoLogo" "0"
Option "CursorShadow" "on"
Option "ConnectedMonitor" "DFP-0"
Option "IgnoreDisplayDevices" "TV-0,CRT-0"
Option "TripleBuffer" "true"
EndSection
Section "Screen"
Identifier "screen-DFP"
Device "card-DFP"
Monitor "wide-LCD"
DefaultDepth 24
SubSection "Display"
Modes "1680x1050" "1280x800" "1024x768" "800x600" "640x480"
Depth 24
EndSubSection
Option "AddARGBGLXVisuals" "True"
Option "DisableGLXRootClipping" "True"
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

Section "ServerFlags"
Option "AIGLX" "true"
EndSection

- Nvidia (newest, not the legacy)
Comment by robin wood (dninja) - Monday, 17 December 2007, 17:24 GMT
Hey, I'm not imagining it!!!! :-)

I'm on a dual head nvidia card running the nvidia-96xx drivers

01:00.0 VGA compatible controller: nVidia Corporation NV44A [GeForce 6200] (rev a1)

Section "Device"
Identifier "TimeLCD"
Driver "nvidia"
BusID "PCI:1:0:0"
Screen 0
Option "NoLogo" "true"
EndSection

Section "Device"
Identifier "BenqLCD"
Driver "nvidia"
BusID "PCI:1:0:0"
Screen 1
Option "NoLogo" "true"
EndSection

Section "Screen"
Identifier "TimeScreen"
Device "TimeLCD"
Monitor "TimeMonitor"
DefaultDepth 24
Option "RenderAccel" "true"
SubSection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "Screen"
Identifier "BenqScreen"
Device "BenqLCD"
Monitor "BenqMonitor"
DefaultDepth 24
Option "RenderAccel" "true"
#Option "TwinView"
SubSection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "ServerFlags"
Option "Xinerama" "true"
EndSection

I don't have an extensions section

If you need anything else let me know.
Comment by Tobias Kieslich (tobias) - Monday, 17 December 2007, 21:12 GMT
Okay, I switched my poor Laptop over to compiz with intel915m hardware, Gimp works smoothley there. So my money is on Nvidia hardware atm. We need more cases, ATI with the several drivers.
Comment by adrian chromenko (adrianc) - Monday, 31 December 2007, 06:22 GMT
happens to me as well, happened since the first 2.4 release
Comment by Tobias Kieslich (tobias) - Monday, 31 December 2007, 06:45 GMT
okay, but do you use composite, what does your xorg.conf looks like and which graphics chip do you use???
Comment by adrian chromenko (adrianc) - Monday, 31 December 2007, 06:55 GMT
i dont use composite, im using a ATI All-in-Wonder 9600, my xorg.conf is here:

Section "ServerLayout"
Identifier "Simple Layout"
Screen 0 "aticonfig-Screen[0]" 0 0
InputDevice "Mouse1" "CorePointer"
InputDevice "Keyboard1" "CoreKeyboard"
EndSection

Section "Files"
FontPath "/usr/share/fonts/misc"
FontPath "/usr/share/fonts/100dpi:unscaled"
FontPath "/usr/share/fonts/75dpi:unscaled"
FontPath "/usr/share/fonts/TTF"
FontPath "/usr/share/fonts/Type1"
EndSection

Section "Module"

Load "dbe" # Double buffer extension
SubSection "extmod"
Option "omit xfree86-dga" # don't initialise the DGA extension
EndSubSection
Load "freetype"
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "kbd"
Option "AutoRepeat" "500 30"
Option "XkbRules" "xorg"
Option "XkbModel" "pc101"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"

Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "Auto" # Auto detect
Option "Device" "/dev/input/mice"
# Mouse-speed setting for PS/2 mouse.
Option "ZAxisMapping" "4 5 6 7"
# Emulate3Buttons is an option for 2-button mice
EndSection

Section "Monitor"

Identifier "acer"
HorizSync 30.0 - 83.0
VertRefresh 56.0 - 63.0
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[0]"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection

Section "Device"

Identifier "Standard VGA"
Driver "vga"
VendorName "Unknown"
BoardName "Unknown"
EndSection

Section "Device"

#VideoRam 131072
# Insert Clocks lines here if appropriate
Identifier "radeon card"
Driver "radeon"
EndSection

Section "Device"
Identifier "aticonfig-Device[0]"
Driver "fglrx"
EndSection

Section "Screen"
Identifier "Screen 1"
Device "radeon card"
Monitor "acer"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 8
Modes "1680x1050" "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
Modes "1680x1050" "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1680x1050" "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]"
Device "aticonfig-Device[0]"
Monitor "aticonfig-Monitor[0]"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection
Comment by Matthias Dienstbier (fs4000) - Monday, 31 December 2007, 16:12 GMT
I didn't have the problem without Composite at first, then I enabled Composite and the KDE Composite Manager and it wasn't possible to save some (not all) pictures twice. When I disable it again, the problem's gone, but I noticed that the extension is activated by default since some time (I think it's the nvidia driver). Perhaps we should try that:

Section "Extensions"
Option "Composite" "Disable"
EndSection
Comment by robin wood (dninja) - Tuesday, 01 January 2008, 12:15 GMT
The change to the X config fixes it for me!
Comment by robin wood (dninja) - Wednesday, 02 January 2008, 16:05 GMT
spoke too soon, it was working but has now stopped again. The fix is still in xorg.conf
Comment by Tobias Kieslich (tobias) - Wednesday, 09 January 2008, 06:51 GMT
okay, I did some more intense testing on the issue. I could also produce some other issues with the gimp such as the gaussian blur plugin crashing:
the following thing are just a collection of issues:
- the composite manager was not the issue, I could reproduce crashes without it activated!!!
- the theme in the gimp preferences must have been set to small (that reproduceable triggered the gaussian Blur to crash, but only if the next issue was set too)
- crashes happened with both, gtk-themes based on the clearlooks engine as well as the murraine engine

the last thing triggers most of the crashes for me. Looking at the code of both engines shows me that they are using cairo methods to accelerate drawing. Using an engine like gtk-xfce-engine, which incorporates no cairo calls works fine and no crashes happened, even with composite AND compiz active. This solution was reproducable on an intel915 and a Nvidia powered machine.

So for all the people who can reproduce the crashes, I like to hear some confirmation. Please install and select gtk-xfce-engine(no, that does not pull all of xfce4 in, it's a single package you have to download, so don't whine) and try to reproduce the crashes. Also pleace check if your theme is set to "small" in gimps preferences and do some more testing on that one.

Most likely, the issue is upstream or/and in our gtk2 package or the gtk-engines. For now, all I can give are work arounds, no finite solutions.
Comment by robin wood (dninja) - Wednesday, 09 January 2008, 11:05 GMT
I've already got gtk-xfce-engine installed but in doing some reading round I found that the

Option "RenderAccel" "true"

line I had in my Screen section in xorg.conf should have been in the Device section. I've just moved it, restarted X and the problem seems to have stopped.

I got this answer from here:
http://docs.kde.org/stable/en/kdebase/kompmgr/problems.html

It could just be co-incidence, I'll keep testing it and see.
Comment by Nathan Crandall (cactus.ed) - Saturday, 12 January 2008, 11:36 GMT
Yea, Gimp has caused problems for me also. October->November it was constantly crashing, but an update seems to have fixed that. I also experienced the blank "save as" box described above about a month ago. It happened constantly and was frustrating as hell. IIRC Opening Gimp from the command line produced a couple errors -- can't locate file x. I can't remember exactly what package I had to install, but I have not seen the blank "save as" box for a couple weeks.
Comment by zxyxz (zzzxy) - Thursday, 24 January 2008, 04:28 GMT
I've been having the same problem constantly.

I'm running Ubuntu 7.10
I have Intel integrated video.
I'm using the Mist theme.

I can get the problem sometimes by simply creating a new blank image then saving it twice, however that does not always trigger it.

I can reproduce it every time by doing this:
1) Open an XCF file with multiple layers
2) Change the visibility of a layer
3) Crop to a selection
4) Change the visibility of layers
5) Save as a BMP
6) Change the visibility of layers
7) Save as a BMP

Then I get a blank save window.

The window still works, I just can't see anything. I can type in a new name, nothing will show in the name box, then click on the invisible save box and the Export File window will appear and I can save the picture.
Comment by zxyxz (zzzxy) - Thursday, 24 January 2008, 23:39 GMT
I've done a bit more testing and I can now reproduce it 100% of the time.

1) create a new blank image
2) make the image smaller, using any method (making it larger will not trigger the error)
3) use "Save as" to save the image
4) use "Save as" again, this time the window will appear blank

I'm using Gimp 2.4.2
Comment by Tobias Kieslich (tobias) - Monday, 11 February 2008, 23:07 GMT
okay, can you try to use the gtk-xfce-engine instead of any other engine please. For me this is a gtk-engine issue.
Comment by zxyxz (zzzxy) - Sunday, 24 February 2008, 16:45 GMT
I installed the XFCE GTK engine as you requested and now the problem has disappeared.

Inexplicably I can no longer reproduce the bug even when not using an XFCE theme.

Before I installed the XFCE engine I had found another way to trigger this bug that may help you troubleshoot it:

1) Open any file using the RAW file type option
2) In the RAW importer select a small image size so that the entire file will not be loaded (loading the whole file will not trigger the bug)
3) Use "Open" again, this time the window will appear blank.
Comment by robin wood (dninja) - Sunday, 24 February 2008, 16:55 GMT
I just tried the new way to trigger the bug and it did trigger it, the weird thing is that the save bug cleared up ages ago so maybe this is a different bug just appearing in the same way.
Comment by Tobias Kieslich (tobias) - Wednesday, 12 March 2008, 03:55 GMT
I'm very tempted to close this one since it was always possible to fix for me when I choose a simpler or different gtk engine.
Comment by robin wood (dninja) - Wednesday, 12 March 2008, 08:07 GMT
I started the bug and I'm happy to close it as it is all working ok for me now.

(hows that for selfish!)
Comment by Charles-Henri d'Adhémar (chicha) - Friday, 09 May 2008, 13:06 GMT
Gimp 2.4.5 is out. Is the problem still valid ?
Can't this problem be considered as an upstream bug ? (the history is quite long and I may have missed something ;-) )
Comment by Matthias Dienstbier (fs4000) - Friday, 09 May 2008, 13:24 GMT
Yes, the problem is still valid.
Comment by robin wood (dninja) - Friday, 09 May 2008, 14:05 GMT
I hadn't seen this problem for a while but out of the blue it happened yesterday.

I haven't changed anything in terms of video or window managers etc except for normal pacman upgrades.
Comment by Tobias Kieslich (tobias) - Friday, 09 May 2008, 17:25 GMT
the only time it happened for me is when I used compositor AND a gtk theme that incorporates cairo calls (thaose are many theses days including the famous and widely used clearlooks). However, I use gtk-xfce-engine now (I returned to it after trouble with other programs too) and all my trouble is gone. I strictly consider that upstream. I can only suggest to use simple gtk-engines whe you wanna use gimp with out hassles.
Comment by robin wood (dninja) - Friday, 09 May 2008, 17:37 GMT
Not being a gnome user, how do I check which gtk engine I'm using and how do I change it?

I have gtk-xfce-engine installed but have no idea if it actually being used by anything.
Comment by Tobias Kieslich (tobias) - Friday, 09 May 2008, 18:15 GMT
sudo pacman -S gtk-theme-switch2 allows you to select gtk2 themes
Comment by Danny Arnold (despairblue) - Monday, 12 May 2008, 14:00 GMT
I tried all the aformentioned methods, but I just couldn't reproduce it. I'm using compiz-fusion, darklooks and proprietary nvidia-drivers.
Comment by Thayer Williams (thayer) - Monday, 26 May 2008, 21:52 GMT
I still see this behaviour with gimp-2.4.5-1. ATI fgrlx graphics card here...I'm going to test this on another PC running nvidia and will post the results.

Other stuff that might matter: openbox-session, with and without xcompmgr.
Comment by Thayer Williams (thayer) - Monday, 26 May 2008, 22:22 GMT
Looks like it's affecting other distros too: http://bugzilla.gnome.org/show_bug.cgi?id=483502
Comment by robin wood (dninja) - Monday, 26 May 2008, 22:57 GMT
I've sent them a link to this thread. Maybe we will get an answer
Comment by Thayer Williams (thayer) - Monday, 26 May 2008, 23:21 GMT
It has been commented in bugzilla that this might be fixed already in the dev snapshot. I just installed v2.5 and will see if I encounter any problems. I hope this isn't related to the gtk-engine stuff because I'd hate to abandon rezlooks over GIMP.
Comment by Branko Vukelic (foxbunny) - Thursday, 19 June 2008, 17:59 GMT
I confirm this bug with the current version of GIMP 2.4.6 on awesome compiled with GTK, and Intel graphics.
Comment by Tobias Kieslich (tobias) - Sunday, 09 November 2008, 03:40 GMT
Is this gone, no one has complained in along time
Comment by Thayer Williams (thayer) - Sunday, 09 November 2008, 09:07 GMT
I believe this is resolved. I have not experienced any problems with GIMP for a while now.

Loading...