Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#8469 - Secret Maryo Chonicles 64bit

Attached to Project: Arch Linux
Opened by John Antoniou (kakashigr) - Wednesday, 31 October 2007, 14:07 GMT
Last edited by Eric Belanger (Snowman) - Saturday, 08 December 2007, 03:37 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Eric Belanger (Snowman)
Jürgen Hötzel (juergen)
Andreas Radke (AndyRTR)
Architecture x86_64
Severity Low
Priority Normal
Reported Version 2007.08-2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
I installed secret maryo chronicles (pacman -S smc smc-music), but when I try to run the game it crashes.
Here is the console ouput:
bash-3.2$ smc
Couldn't open preferences file : /home/archangel/.smc/config.xml
CEGUI Exception occurred : Imageset::xmlHandler::startElement - An unexpected error occurred while creating a Texture object from file 'SMCLook256.png'

I googled a bit and found out that cegui needs to be compiled with SILLYImageCodec as the default image codec. I fetched silly ogre and some other required stuff from AUR and I tried to compile cegui, but, at the end of the build, it exits with no error code (Strange).
Can you fix that please?

Additional info:
* package version 1.2.1

Steps to reproduce:
just fetch pacman -S smc smc-music and try to run smc. I don't know if it works in 32bit arch.
This task depends upon

Closed by  Eric Belanger (Snowman)
Saturday, 08 December 2007, 03:37 GMT
Reason for closing:  Fixed
Comment by Jürgen Hötzel (juergen) - Thursday, 01 November 2007, 19:40 GMT
Couldn't reproduce on 32 bit.
Comment by Andreas Radke (AndyRTR) - Friday, 02 November 2007, 19:42 GMT
can reproduce it but i'm not the maintainer. won't spend any time on a game pkg.
Comment by John Antoniou (kakashigr) - Friday, 02 November 2007, 19:56 GMT
Well the "problem" seems to be with cegui's config parameters, not smc itself. I might be wrong thought..

Jürgen, can you try to alter cegui's config and recompile? Apparently it needs SILLYImageCodec as default in order to load png files. I tried on my computer but the build always fails and it doesn't even give me errors (?).
Comment by Eric Belanger (Snowman) - Wednesday, 05 December 2007, 20:40 GMT
I get that problem on x86_64. I'll look into it.
Comment by Eric Belanger (Snowman) - Wednesday, 05 December 2007, 23:58 GMT
I got it to work. It's a question of enabling the silly codec in cegui and making it the default. I'm attaching the PKGBUILD files. We could do the changes for i686 too as smc still works with the silly codec.

Jürgen: As you're cegui's maintainer, what's your opinion on this? I could do the changes if you want.
Comment by Jürgen Hötzel (juergen) - Thursday, 06 December 2007, 07:30 GMT
Hi Eric,

I dont know about side effects/performance issues of this options. what about:

[ "${CARCH}" = "x86_64" ] && EXTRAOPTS=--with-default-image-codec=SILLYImageCodec

I would appreciate if you do the update: Thanks.

Jürgen
Comment by Eric Belanger (Snowman) - Thursday, 06 December 2007, 19:58 GMT
OK, I'll just do the changes for x86_64.

BTW, that option also adds a dependency on silly.

Loading...