Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#8459 - pacman-optimize fails without explanation if diffutils is not installed

Attached to Project: Pacman
Opened by teedog (teedog) - Tuesday, 30 October 2007, 17:49 GMT
Last edited by Aaron Griffin (phrakture) - Wednesday, 31 October 2007, 16:43 GMT
Task Type Bug Report
Category Scripts & Tools
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version 3.0.6
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Summary and Info:
diffutils is not installed in a default Arch installation (following the installation guide). If one runs pacman-optimize, the process fails without any explanation. Installing diffutils solves the issue. Perhaps pacman-optimize should be made to output a helpful message if executed without diffutils installed?

:: Md5sum'ing the old database [DONE]
:: Tar'ing up /var/lib/pacman [DONE]
:: Making and md5sum'ing the new db [DONE]
:: Checking integrity [FAIL]
:: ERROR: integrity check FAILED, reverting to old database

Steps to Reproduce:
- default installation using the official guide
- run pacman-optimize
- note error:
:: Checking integrity [FAIL]
:: ERROR: integrity check FAILED, reverting to old database
- install diffutils
- run pacman-optimize again
- success
This task depends upon

Closed by  Aaron Griffin (phrakture)
Wednesday, 31 October 2007, 16:43 GMT
Reason for closing:  Not a bug
Additional comments about closing:  See last comment
Comment by Xavier (shining) - Wednesday, 31 October 2007, 09:07 GMT
Hm sorry, this has already been reported and fixed :  bug 8190 

pacman-optimize in the git repo checks if diff is installed or not at runtime :

> /usr/local/bin/pacman-optimize
==> ERROR: diff tool was not found, please install diffutils.

So that looks fine.

It has been reported a second time :  bug 8269  , which explains why some people don't have diffutils installed.
It's part of the new base-devel group which is not installed by default.

Loading...