Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#8438 - [bootchart 0.9-3] bootchart-render fails with error message "/var/log/bootchart.tgz not found"

Attached to Project: Arch Linux
Opened by Sebastian (sepo) - Saturday, 27 October 2007, 17:17 GMT
Last edited by Aaron Griffin (phrakture) - Wednesday, 11 February 2009, 20:23 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Aaron Griffin (phrakture)
Architecture All
Severity Low
Priority Normal
Reported Version 2007.08-2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
This occurs because /sbin/bootchartd does not stop after the system is initialized, because it can not detect the process that triggers the termination (for archlinux this is agetty). It failes to detect the process, because it does not ignore comments in /etc/inittab (e.g. the line "#id:5:initdefault:" which has been added recently).

I already filled a bug report at the bootchart SF website and provided a patch:
http://sourceforge.net/tracker/index.php?func=detail&aid=1821273&group_id=124505&atid=699720

Additional info:
bootchart 0.9-3

Steps to reproduce:
* append "init=/sbin/bootchartd" to your grub kernel command line
* reboot
* try to render the bootchart with the command "bootchart-render"
This task depends upon

Closed by  Aaron Griffin (phrakture)
Wednesday, 11 February 2009, 20:23 GMT
Reason for closing:  Fixed
Comment by Alessio Bolognino (mOLOk) - Monday, 29 September 2008, 05:07 GMT
Bump.t
The bug is still here, bootchartd has a stupid regex (line 124 of /sbin/bootchartd) that reads the comment and fails to detect initdefault.
Note that it fails with /etc/inittab shipped by Arch.
Comment by Aaron Griffin (phrakture) - Monday, 29 September 2008, 16:19 GMT
Sorry for the delay. I will look into this later today
Comment by Aaron Griffin (phrakture) - Monday, 06 October 2008, 00:38 GMT
Please check 0.9-4 when it hits the repos
Comment by Greg (dolby) - Monday, 02 February 2009, 02:54 GMT
Is this fixed?

Loading...