Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#8392 - Initscripts SIGTERM problem

Attached to Project: Arch Linux
Opened by Jaideep Das (jaideep_jdof) - Tuesday, 23 October 2007, 18:16 GMT
Last edited by Aaron Griffin (phrakture) - Friday, 14 March 2008, 18:13 GMT
Task Type Bug Report
Category System
Status Closed
Assigned To Aaron Griffin (phrakture)
Thomas Bächler (brain0)
Architecture All
Severity High
Priority Normal
Reported Version 2007.08-2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Summary and Info:

since i update my system to new kernel and initscripts i am facing a strange problem. When i shutdown the process gets stuck at SIGTERM with status BUSY. And then I have to hold down the power button of my laptop to shutdown.
The versions of initscript and kernel are:

initscripts-2007.7.11-2
kernel-26-2.6.2.3.1-4
Steps to Reproduce:

Update with pacman -Syu and then reboot.
This task depends upon

Closed by  Aaron Griffin (phrakture)
Friday, 14 March 2008, 18:13 GMT
Reason for closing:  Not a bug
Comment by Aaron Griffin (phrakture) - Tuesday, 23 October 2007, 18:50 GMT
Thomas, I have a sinking suspicion that this is related to the new way you kill of daemons.

Jaideep, could you please give use the DAEMONS line from your rc.conf please?
Comment by Thomas Bächler (brain0) - Tuesday, 23 October 2007, 20:01 GMT
I doubt that it is related, but I will look into it. Don't expect any answers soon, I have much work ahead of me.
Comment by Thomas Bächler (brain0) - Tuesday, 23 October 2007, 21:21 GMT
I just had an idea. The problem could be related to this, so I need the DAEMONS list indeed: http://archlinux.org/pipermail/arch-dev-public/2007-October/002459.html
Comment by Aaron Griffin (phrakture) - Tuesday, 23 October 2007, 21:25 GMT
That's what I meant 8)
Sorry if I didn't explain it well enough, heh.
Comment by Jaideep Das (jaideep_jdof) - Wednesday, 24 October 2007, 06:33 GMT
These are my daemons:

DAEMONS=(syslog-ng network iptables !netfs @crond @ntpd @cups dbus hal @alsa bluetooth avupdater avguard cpufreq slim)
Comment by Jaideep Das (jaideep_jdof) - Wednesday, 24 October 2007, 06:36 GMT
avupdater and avguard are the daemons for antvir antivirus for updating and on-access guard respectively.
Comment by Jaideep Das (jaideep_jdof) - Wednesday, 24 October 2007, 06:45 GMT
If i stop the avguard and avupdater daemon before shutdown, the shutdown process works fine.
Comment by Thomas Bächler (brain0) - Wednesday, 24 October 2007, 06:51 GMT
The avguard and avupdater don't seem to set add_daemon (which only touches a file with the same name in /var/run/daemons/). As those aren't official arch packages, you should add this:

In the beginning:
. /etc/rc.conf
. /etc/rc.d/functions

At daemon start:
add_daemon avguard (resp. avupdater)
At daemon shutdown:
rm_daemon avguard (resp. avupdater)

Closing this, as no official arch daemons script causes it.
Comment by Aaron Griffin (phrakture) - Wednesday, 24 October 2007, 06:51 GMT
Can you check to see if those scripts use the "add_daemon" script command? If not the scripts may need to be updated.

Thomas, any idea why it would hang? I was under the assumption this scripts would send sigterm, wait a bit, then send sigkill to everything remaining... is this not the case?
Comment by Jaideep Das (jaideep_jdof) - Wednesday, 24 October 2007, 16:16 GMT
  • Field changed: Percent Complete (100% → 0%)
This problem wasn't there before the update. This means the problem is not with the daemons but with the shutdown script. And the solution provided isn't clear to me.
Comment by Aaron Griffin (phrakture) - Wednesday, 24 October 2007, 16:17 GMT
I agree here. While the daemons SHOULD be fixed, yes, I feel that we shouldn't assume all daemons will follow this all the time.

We have also not made a public announcement to the TUs or anything of the sort like this, so no one ever KNOWS to make these changes
Comment by Roman Kyrylych (Romashka) - Wednesday, 24 October 2007, 16:20 GMT Comment by Aaron Griffin (phrakture) - Wednesday, 24 October 2007, 17:29 GMT
Ah Touche!

Still, with something as variable as installable scripts like that that aren't always under our control, we should be more fault tolerant here.
Comment by Aaron Griffin (phrakture) - Friday, 08 February 2008, 18:45 GMT
Is this still an issue?

Loading...