Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#8358 - [courier-mta] broken after last update

Attached to Project: Arch Linux
Opened by Gerhard Brauer (GerBra) - Saturday, 20 October 2007, 08:18 GMT
Last edited by Tobias Kieslich (tobias) - Monday, 07 January 2008, 22:17 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Tobias Kieslich (tobias)
Architecture All
Severity High
Priority Normal
Reported Version 2007.08-2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
After update the new package still overwrite some configuration settings and make courier
unusable.
Afftected file is /etc/courier/esmtpauthclient which stores auth data ex. for extern
mail relaying.

Additional info:
* package version(s)
courier-mta (0.55.1-1 -> 0.55.1-2) updated


Solution:
Backup esmtpauthclient also like the other config files.
Also it would be IMHO a better way not only backup user configs somewhere but also restore these
backuped files after update.
This task depends upon

Closed by  Tobias Kieslich (tobias)
Monday, 07 January 2008, 22:17 GMT
Reason for closing:  Fixed
Additional comments about closing:  I stay with the homemade simple backup, since courier needs special ways
Comment by Tobias Kieslich (tobias) - Friday, 26 October 2007, 17:14 GMT
if I would restore the users backups, I would overwrite couriers new files which is not the desired behavior.
Comment by Gerhard Brauer (GerBra) - Sunday, 28 October 2007, 09:59 GMT
Hello!
(First: sorry for my bad english)

I don't agree with that ;-)
During this update for example not restoring the old configuration (it was aliases and smtpaccess in _backup,
and the not saved esmtpauthclient) result in a *definitely* broken mta (courier restart itself in intervals).

If you restore these user settings there is *mostly* a chance that courier works after that.
For this update ex. there are IMHO no significantly changes from backup to new files.
Or maybe better: Put *new* configs in a manner like .PACNEW in /etc/courier - or when this is not possible
(ex. on dirs in which courier parse ALL files) maybe a structute like /etc/courier/_newetc, where all
new or default configs from update goes.
And so don't update any config in the actually running courier but put the admins eyes on that - as you
do already during .INSTALL.
If the updated (not restarted courier) doesn't work with the currerent, admin-changed, config the admin
surely will notice that and do his work.

But above is more a general discussion. For this current bugreport it's important that we backup *all*
config files which a user maybe could have changed.
Comment by Tobias Kieslich (tobias) - Monday, 29 October 2007, 04:10 GMT
the problem with courier is the handling of the config files. Take aliases as an example (hosteddomains works similar and so do others)
The user can decide if s/he wants all configuration in one file such as /etc/courier/aliases or if it should be broken up into subfiles (/etc/courier/aliases/*) In the latter case courier concatenates al files in this directory (and possible subdirectories IIRC) into one file before it reads it as configuration. This leaves us with two problems:
1. what do we backup? files or directories
2. we can't use .pacnew .pacold and what so ever files, because courier would read them as part of the directory and gets confused with the content.
esmtpauthclient might be a candidtate for backups=(), but firstly I have to investigate how courier smart reading functions effect that.
Comment by Tobias Kieslich (tobias) - Friday, 16 November 2007, 21:40 GMT
okay I added esmtpauthclient to the backup array in cvs and that gets updated with the next build. However, automatic restauration of the manually backuped files can't be provided as this can destroy the freshly installed changes. The issue is with the way that courier handles that configs is that it very much with pacmans approach for backups. Not saying either one is wrong. But courier's automagic makes it impossible for pacman to handle that. So, all I want is that the user does not loose changes and this is provided.

Loading...