Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#8355 - Prevent startx from creating .serverauth.XXX files in $HOME

Attached to Project: Arch Linux
Opened by M. H. (DerGuteMoritz) - Friday, 19 October 2007, 21:47 GMT
Last edited by Greg (dolby) - Wednesday, 14 May 2008, 13:53 GMT
Task Type Feature Request
Category Packages: Extra
Status Closed
Assigned To Alexander Baldeck (kth5)
Architecture All
Severity Low
Priority Normal
Reported Version 2007.08-2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
When X is started with startx and not shut down properly (e.g. directly halting the machine from within the X session), everytime a .serverauth.XXX file is left in the user's $HOME. Cf.
http://www.shallowsky.com/blog/linux/serverauth.html

Additional info:
* xorg-server: 1.4-4


Steps to reproduce:
startx && reboot && ls $HOME/.serverauth*
This task depends upon

Closed by  Greg (dolby)
Wednesday, 14 May 2008, 13:53 GMT
Reason for closing:  Upstream
Comment by Corrado Primier (bardo) - Wednesday, 09 January 2008, 11:52 GMT
For the record: this "bug" pertains to the xorg-xinit package, which owns /usr/bin/startx. Attaching a patch for the correction in startx.

For more informations see the Ubuntu bug report: https://launchpad.net/ubuntu/+source/xinit/+bug/35758
Comment by Gavin Bisesi (Daenyth) - Friday, 25 April 2008, 03:32 GMT
I would *love* a resolution on this. What's the status?
Comment by Greg (dolby) - Sunday, 04 May 2008, 17:50 GMT
i dont see the reason this is so important so we should add YET ANOTHER patch to the xorg packages. Why dont you address this to the xorg developers instead?

Loading...