Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#8289 - Panic and oops with 2.6.23 with drm

Attached to Project: Arch Linux
Opened by Thomas Bächler (brain0) - Thursday, 11 October 2007, 18:04 GMT
Last edited by Tobias Powalowski (tpowa) - Monday, 15 October 2007, 20:50 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Tobias Powalowski (tpowa)
Alexander Baldeck (kth5)
Thomas Bächler (brain0)
Architecture x86_64
Severity Critical
Priority Normal
Reported Version 2007.08-2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I use 2.6.23-2 from testing and when I tried to launch google earth, the kernel paniced. When I tried to reproduce, it oopsed, this is the oops trace:

Oct 11 19:53:04 artin Unable to handle kernel paging request at 0000000000200200 RIP:
Oct 11 19:53:04 artin [<ffffffff8029142e>] __kmalloc+0x6e/0xb0
Oct 11 19:53:04 artin PGD 25ea2067 PUD 25ea0067 PMD 0
Oct 11 19:53:04 artin Oops: 0000 [1] PREEMPT SMP
Oct 11 19:53:04 artin CPU 1
Oct 11 19:53:04 artin Modules linked in: i915 drm michael_mic arc4 rfcomm ecb hidp hid ieee80211_crypt_tkip l2cap ieee80211_crypt_ccmp cpufreq_ondemand joydev ohci1394 ieee1394 pcmcia hci_usb bluetooth firewire_ohci firewire_core crc_itu_t sdhci mmc_core yenta_socket rsrc_nonstatic pcmcia_core tsdev ipw3945 ieee80211 ieee80211_crypt rtc_cmos rtc_core rtc_lib i2c_i801 i2c_core serio_raw psmouse ehci_hcd uhci_hcd intel_agp sg thermal evdev fan button battery ac coretemp video output fuse tun acpi_cpufreq freq_table processor snd_seq_oss snd_seq_midi_event snd_seq snd_seq_device snd_pcm_oss snd_mixer_oss snd_hda_intel snd_pcm snd_timer snd_page_alloc snd_hwdep snd soundcore 8139too mii usbcore ext3 jbd mbcache sha256 aes_x86_64 dm_crypt dm_mod sd_mod sr_mod cdrom ata_piix libata
Oct 11 19:53:04 artin Pid: 7870, comm: X Not tainted 2.6.23-ARCH #1
Oct 11 19:53:04 artin RIP: 0010:[<ffffffff8029142e>] [<ffffffff8029142e>] __kmalloc+0x6e/0xb0
Oct 11 19:53:04 artin RSP: 0018:ffff810025ef7df8 EFLAGS: 00010006
Oct 11 19:53:04 artin RAX: 0000000000000000 RBX: ffffffff805c1e18 RCX: ffffffff88324e4b
Oct 11 19:53:04 artin RDX: ffff810001ce45d0 RSI: 00000000000080d0 RDI: 0000000000000003
Oct 11 19:53:04 artin RBP: 00000000000080d0 R08: 0000000000000001 R09: 0000000000818580
Oct 11 19:53:04 artin R10: 0000000000000000 R11: 0000000000003202 R12: 0000000000200200
Oct 11 19:53:04 artin R13: 0000000000000282 R14: ffff810037cd092c R15: 0000000000000202
Oct 11 19:53:04 artin FS: 00002b1a198525c0(0000) GS:ffff81003f6d1100(0000) knlGS:0000000000000000
Oct 11 19:53:04 artin CS: 0010 DS: 0000 ES: 0000 CR0: 0000000080050033
Oct 11 19:53:04 artin CR2: 0000000000200200 CR3: 0000000027a85000 CR4: 00000000000006e0
Oct 11 19:53:04 artin DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
Oct 11 19:53:04 artin DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
Oct 11 19:53:04 artin Process X (pid: 7870, threadinfo ffff810025ef6000, task ffff810027938000)
Oct 11 19:53:04 artin Stack: 0000000000000202 ffff810028425000 ffff810037cd0800 ffff810037cd0938
Oct 11 19:53:04 artin 0000000000000001 ffffffff88324e4b ffff810025ef7e68 00007fff92cb0580
Oct 11 19:53:04 artin 2000000000000002 ffff810000000e1f ffff8100000060a1 ffffffff88324c60
Oct 11 19:53:04 artin Call Trace:
Oct 11 19:53:04 artin [<ffffffff88324e4b>] :i915:i915_vblank_swap+0x1eb/0x3e0
Oct 11 19:53:04 artin [<ffffffff88324c60>] :i915:i915_vblank_swap+0x0/0x3e0
Oct 11 19:53:04 artin [<ffffffff8830fe0a>] :drm:drm_ioctl+0xda/0x250
Oct 11 19:53:04 artin [<ffffffff804abdcc>] thread_return+0x442/0x606
Oct 11 19:53:04 artin [<ffffffff802a267d>] do_ioctl+0x7d/0xa0
Oct 11 19:53:04 artin [<ffffffff802a28c0>] vfs_ioctl+0x220/0x2c0
Oct 11 19:53:04 artin [<ffffffff80294d95>] vfs_read+0x155/0x170
Oct 11 19:53:04 artin [<ffffffff802a29f5>] sys_ioctl+0x95/0xb0
Oct 11 19:53:04 artin [<ffffffff8020c43e>] system_call+0x7e/0x83
Oct 11 19:53:04 artin
Oct 11 19:53:04 artin
Oct 11 19:53:04 artin Code: 49 8b 04 c4 48 89 42 10 41 55 9d 66 85 ed 79 13 4d 85 e4 74
Oct 11 19:53:04 artin RIP [<ffffffff8029142e>] __kmalloc+0x6e/0xb0
Oct 11 19:53:04 artin RSP <ffff810025ef7df8>
Oct 11 19:53:04 artin CR2: 0000000000200200
Oct 11 19:53:04 artin [drm:drm_release] *ERROR* Device busy: 1 0

I have an Intel 945GM.
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Monday, 15 October 2007, 20:50 GMT
Reason for closing:  Fixed
Comment by Pierre Schmitz (Pierre) - Thursday, 11 October 2007, 18:28 GMT
Google-Earth works for me. I use [testing]-i686. Anyway, dmesg shows me a lot of "[drm:i915_vblank_swap] *ERROR* Invalid pipe 1" erros when starting google-earth and it takes some time tostart up.

[pierre@satellite ~]$ pacman -Q kernel26 xf86-video-intel google-earth
kernel26 2.6.23-2
xf86-video-intel 2.1.1-2
google-earth 4.1.7076.4458-1

[pierre@satellite ~]$ lspci | grep -i vga
00:02.0 VGA compatible controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 02)

[pierre@satellite ~]$ lsmod | grep i915
i915 22656 2
drm 71572 3 i915
Comment by Alexander Baldeck (kth5) - Thursday, 11 October 2007, 18:31 GMT
Can you provide us with the output of `lspci -vvv` please? There's been 2 changes to the i915 drm subsystem in 2.6.23 only. If this is a kernel issue, it should be fairly easy to resolve.
Comment by Thomas Bächler (brain0) - Thursday, 11 October 2007, 18:37 GMT
I think it worked with my self-baked 2.6.23-rc6 which I was running for quite a while now, so it could only be the latter change, but I have to verify that.

I cut out the relevant part of lspci -vvv, tell me if you need more:

00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03) (prog-if 00 [VGA])
Subsystem: Lenovo Unknown device 2062
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
Latency: 0
Interrupt: pin A routed to IRQ 16
Region 0: Memory at d0200000 (32-bit, non-prefetchable) [size=512K]
Region 1: I/O ports at 1800 [size=8]
Region 2: Memory at c0000000 (32-bit, prefetchable) [size=256M]
Region 3: Memory at d0300000 (32-bit, non-prefetchable) [size=256K]
Capabilities: [90] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable-
Address: 00000000 Data: 0000
Capabilities: [d0] Power Management version 2
Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
Status: D0 PME-Enable- DSel=0 DScale=0 PME-

00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
Subsystem: Lenovo Unknown device 2062
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
Latency: 0
Region 0: Memory at d0280000 (32-bit, non-prefetchable) [size=512K]
Capabilities: [d0] Power Management version 2
Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
Status: D0 PME-Enable- DSel=0 DScale=0 PME-
Comment by Thomas Bächler (brain0) - Sunday, 14 October 2007, 10:10 GMT
It isn't the commit I thought it was, I reverted it and the kernel still paniced.
Comment by Thomas Bächler (brain0) - Sunday, 14 October 2007, 13:07 GMT
http://lkml.org/lkml/2007/10/14/55 fixes the problem. It will hopefully be included in 2.6.23.2.

Loading...