Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#8252 - X crashes on JavaScript-Website

Attached to Project: Arch Linux
Opened by Witold Czaplewski (Witi) - Monday, 08 October 2007, 05:42 GMT
Last edited by Alexander Baldeck (kth5) - Friday, 19 October 2007, 13:17 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Alexander Baldeck (kth5)
Architecture x86_64
Severity Critical
Priority Normal
Reported Version 2007.08.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

x64_64 Testing, Firefox 2.0.0.7, xorg-server 1.4-3
(First reported in german arch forum: http://forum.archlinux.de/?page=Postings;thread=6957)

Steps to reproduce:
Visit following website: http://research.sun.com/projects/lively/ and goto "Enter Lively Kernel" (http://research.sun.com/projects/lively/index.xhtml)

Xorg.0.log:
Backtrace:
0: X(xf86SigHandler+0x6a) [0x49513a]
1: /lib/libc.so.6 [0x2ba35b8d47b0]
2: /usr/lib/libpixman-1.so.0 [0x2ba35b1f2bd3]
3: /usr/lib/libpixman-1.so.0 [0x2ba35b1f88a4]
4: /usr/lib/libpixman-1.so.0(pixman_composite_rect_general+0x36e) [0x2ba35b1f6b2e]
5: /usr/lib/libpixman-1.so.0 [0x2ba35b1feff3]
6: /usr/lib/libpixman-1.so.0(pixman_image_composite+0x70f) [0x2ba35b1fe3ef]
7: /usr/lib/xorg/modules//libfb.so(fbComposite+0x1b8) [0x2ba35dae05e8]
8: /usr/lib/xorg/modules/drivers//nvidia_drv.so(_nv000848X+0x413) [0x2ba35d4ef0b3]

Fatal server error:
Caught signal 11. Server aborting
This task depends upon

Closed by  Alexander Baldeck (kth5)
Friday, 19 October 2007, 13:17 GMT
Reason for closing:  Fixed
Comment by Andrea Cimitan (Cimi) - Monday, 08 October 2007, 07:02 GMT
This is not related only with javascript. It is a strange bug that occurs many times.

I have a crash after startx invocation and gnome-session.

Nvidia drivers (96.43.01):
Backtrace:
0: X(xf86SigHandler+0x7e) [0x80d9d9e]
1: [0xb7f18420]
2: /usr/lib/libpixman-1.so.0(pixman_image_composite+0x584) [0xb7e5a464]
3: /usr/lib/xorg/modules//libfb.so(fbComposite+0x1ad) [0xb6ff069d]
4: /usr/lib/xorg/modules/drivers//nvidia_drv.so(_nv000806X+0x4b8) [0xb70b81d8]

And using nv driver (removing xorg.conf and having automatic xrandr adjustments):
Backtrace:
0: X(xf86SigHandler+0x7e) [0x80d9d9e]
1: [0xb7f64420]
2: /usr/lib/libpixman-1.so.0(pixman_image_composite+0x584) [0xb7ea8464]
3: /usr/lib/xorg/modules//libfb.so(fbComposite+0x1ad) [0xb61d769d]
4: /usr/lib/xorg/modules//libxaa.so(XAAComposite+0x224) [0xb61a1f94]
5: /usr/lib/xorg/modules//libxaa.so [0xb61bd4e6]
6: X [0x816d8bd]
7: X(CompositePicture+0x150) [0x8154bb0]
8: X [0x815ab8f]
9: X [0x8157a45]
10: X [0x814b22e]
11: X(Dispatch+0x2bf) [0x808c76f]
12: X(main+0x48b) [0x8073d9b]
13: /lib/libc.so.6(__libc_start_main+0xe0) [0xb7d39f90]
14: X(FontFileCompleteXLFD+0x209) [0x8073111]
Comment by Andrea Cimitan (Cimi) - Monday, 08 October 2007, 07:03 GMT Comment by Pierre Schmitz (Pierre) - Monday, 08 October 2007, 08:51 GMT
Yes, I can reproduce this with nvidia, nv and even vesa driver. It does not happen when using i686 or xorg from [extra.
Comment by Damir Perisa (damir.perisa) - Monday, 08 October 2007, 10:51 GMT
 bug 8250  is probably something similar
Comment by Damir Perisa (damir.perisa) - Monday, 08 October 2007, 17:08 GMT
firefox in testing is linked against gtk2 2.12, right?
Comment by Jan de Groot (JGC) - Monday, 08 October 2007, 17:40 GMT
gtk 2.12 has nothing to do with X crashes. This is all about bugs in libpixman, the new standalone lib used by Xorg-server 1.4. The AMD64 bug is caused by using a signed 32bit integer as pointer, which is invalid for 64bit architectures. An unofficial patch for that one are available in the freedesktop.org bugreport that is referenced in one of the many duplicates we have by now.
Comment by Damir Perisa (damir.perisa) - Monday, 08 October 2007, 18:12 GMT
ah thanx! so pixman 0.9.5-2 is the troublemaker?
... do we have a collective bug for all them? i cannot find it
http://bugs.archlinux.org/index.php?string=pixman

Comment by Alexander Baldeck (kth5) - Wednesday, 10 October 2007, 17:13 GMT
I have added a fix described in X.org  FS#12398  and uploaded pixman-0.9.5-3 to testing.
Comment by Pierre Schmitz (Pierre) - Wednesday, 10 October 2007, 21:21 GMT
Nice, works for me now.
Comment by Andrea Cimitan (Cimi) - Wednesday, 10 October 2007, 21:23 GMT
not for me obviusly... as it is another bug (but pixman-related)
Comment by Alexander Baldeck (kth5) - Wednesday, 10 October 2007, 21:52 GMT
Andrea, are you sure you upgraded to -3 yet?
Comment by Jan de Groot (JGC) - Wednesday, 10 October 2007, 21:54 GMT
There's actually two bugs in pixman, you fixed the one that teases amd64 a lot.
Comment by Damir Perisa (damir.perisa) - Wednesday, 10 October 2007, 22:45 GMT
 bug 8250  got fixed by pixman -3
Comment by Eric (vanadium50) - Thursday, 11 October 2007, 19:19 GMT
 bug 8188  also seems fixed by pixman-0.9.5-3

8188 also has these same backtrace offsets:
0: X(xf86SigHandler+0x6a)
4: /usr/lib/libpixman-1.so.0(pixman_composite_rect_general+0x36e)
6: /usr/lib/libpixman-1.so.0(pixman_image_composite+0x70f)
7: /usr/lib/xorg/modules//libfb.so(fbComposite+0x1b8)
Comment by Witold Czaplewski (Witi) - Thursday, 11 October 2007, 20:01 GMT
yep is fixed here, too
Comment by Andrea Cimitan (Cimi) - Sunday, 14 October 2007, 23:58 GMT
pixman bugs continue here: http://bugs.archlinux.org/task/8294
very annoying... I can't use one of my PCs cause of this (yes I'm tired I don't want to downgrade to extra :) )

Loading...