Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#8236 - perl (and other perl pkgs) should not provide superfluous *.pod files

Attached to Project: Arch Linux
Opened by Francois Charette (Firmicus) - Saturday, 06 October 2007, 19:01 GMT
Last edited by Aaron Griffin (phrakture) - Wednesday, 05 August 2009, 03:08 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Aaron Griffin (phrakture)
Architecture All
Severity Low
Priority Normal
Reported Version 2007.08.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

In general *.pod files don't need to be included in the perl package nor in any other perl/CPAN-related pkg. Right now "perl" provides 158 such files, which are all superfluous since we have the corresponding manpages. A similar situation occurs with the following pkgs (sorry I am too lazy to open a different task for each of them!) :

glib-perl
gtk2-perl
perl-archive-zip
perl-bit-vector
perl-carp-clan
perl-date-calc
perl-date-manip
perl-dbd-mysql
perl-dbi
perl-event
perl-file-mimeinfo
perl-libwww
perl-mime-lite
perl-mime-types
perl-module-build
perl-pod-simple
perl-template-toolkit
perl-tk
perl-version
perl-xml-simple

Same thing with the .packlist file, which is currently included in "perl" and in "subversion".

The solution is simple. Add these two lines at the end of the PKGBUILD:

find $startdir/pkg -name '*.pod' -delete
find $startdir/pkg -name .packlist -delete

(NB: cf. http://wiki.archlinux.org/index.php/Perl_Package_Guidelines)
Closed by  Aaron Griffin (phrakture)
Wednesday, 05 August 2009, 03:08 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed. Also pacman-3.3.0 provides flag to clear these files.
Comment by Greg (dolby) - Saturday, 17 May 2008, 21:12 GMT
Unless there are other packages too, as far as i can see the only two packages left to close this and  FS#8374  is perl itself and subversion.
Comment by Gavin Bisesi (Daenyth) - Thursday, 11 December 2008, 18:20 GMT
Status?
Comment by Aaron Griffin (phrakture) - Thursday, 11 December 2008, 20:53 GMT
Close in favor of  FS#12399  ?
Comment by Gavin Bisesi (Daenyth) - Friday, 12 December 2008, 13:52 GMT
I'd rather not, as I commented there.
Comment by Gavin Bisesi (Daenyth) - Saturday, 21 March 2009, 14:30 GMT
Should we close this now, or wait until  FS#12399  is included in the next release?
Comment by Roman Kyrylych (Romashka) - Sunday, 14 June 2009, 22:42 GMT
 FS#12399  is closed now. Should this one be closed too?

Loading...