Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#8214 - acl,user_xattr breaks fakeroot in coreutils 6.9

Attached to Project: Arch Linux
Opened by Thomas Bächler (brain0) - Thursday, 04 October 2007, 18:34 GMT
Last edited by Thomas Bächler (brain0) - Friday, 18 January 2008, 07:09 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Aaron Griffin (phrakture)
Thomas Bächler (brain0)
Andreas Radke (AndyRTR)
Dan McGee (toofishes)
Architecture All
Severity Critical
Priority High
Reported Version 2007.08.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

The problem was first described here:
http://archlinux.org/pipermail/arch-dev-public/2007-July/001152.html

When a partition is mounted with acl,user_xattr (maybe already with one of them, needs to be checked, the options are always enabled on tmpfs), cp -a fails to set permissions properly inside a fakeroot environment. This breaks makepkg.

This is due to missing wrapper functions in fakeroot and changes in recent coreutils versions. A fix would be to implement the missing wrappers in fakeroot.
This task depends upon

Closed by  Thomas Bächler (brain0)
Friday, 18 January 2008, 07:09 GMT
Reason for closing:  Fixed
Comment by Aaron Griffin (phrakture) - Thursday, 04 October 2007, 20:21 GMT
Yeah this is really a fakeroot issue, but it directly affects makepkg packages (hence the assignment to us)
Comment by Riri (chicha) - Thursday, 06 December 2007, 17:03 GMT

According to Arch's mailing list : http://archlinux.org/pipermail/arch-dev-public/2007-July/001172.html
and to Debian's bug report : http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=361306
It seems only the 'acl' option is responsible for this problem.

I would like to activate the 'user_xattr' option on my /var partition where ABS is located (at /var/abs) to be able to use beagle at its best.

Can anyone here confirm this problem is not linked to 'user_xattr', please ?
Thank you very much !
Comment by Andrew Fyfe (space-m0nkey) - Sunday, 09 December 2007, 20:19 GMT
This is an acl issue, user_xattr doesn't effect it.
Comment by Riri (chicha) - Sunday, 09 December 2007, 20:43 GMT
Thank you very much for this confirmation !
Comment by Thomas Bächler (brain0) - Friday, 04 January 2008, 13:17 GMT
fakeroot 1.8.10-2 fixes this bug. The acl_set_{fd,file} functions now return -1 and set errno=ENOTSUP while inside fakeroot. cp then uses chmod or fchmod instead of acl to set the mode.
Please confirm.
Comment by Xavier (shining) - Friday, 18 January 2008, 07:04 GMT
I can confirm the problem you reported in arch-dev-public ML is fixed.

The problem I can still reproduce is the one described in Debian's bug report.
But the first comment there is valid :
"However, if you touch the file, chmod it, and cp it all under the same
fakeroot invocation, it behaves as expected."

So this problem might not be important after all.
Comment by Thomas Bächler (brain0) - Friday, 18 January 2008, 07:09 GMT
The original problem in the debian report is stupid. We always call a whole script from fakeroot, and all chmod and cp invocations from inside the script are fine. The problem only occurs if you call chmod from the fakeroot commandline. I don't know when this usage would make sense.

I am closing this now.

Loading...