Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#8209 - Attempting to print in OpenOffice causes crash after evolution upgrade

Attached to Project: Arch Linux
Opened by Howard Johnson (hjohnson) - Wednesday, 03 October 2007, 16:26 GMT
Last edited by Andreas Radke (AndyRTR) - Tuesday, 23 October 2007, 17:24 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Architecture i686
Severity Critical
Priority Normal
Reported Version 2007.08.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description: After upgrading evolution to 2.12.0 from testing, OpenOffice (2.3.0) now crashes when attempting to print. The following is the backtrace from OO:
*** glibc detected *** /opt/openoffice/program/soffice.bin: munmap_chunk(): invalid pointer: 0x082b7f60 ***
======= Backtrace: =========
/lib/libc.so.6[0xb6ba2c06]
/usr/lib/libglib-2.0.so.0(g_free+0x31)[0xb650c9f1]
/opt/openoffice/program/libvclplug_gtk680li.so[0xb4f53504]
/opt/openoffice/program/libvcl680li.so(_ZN11SalGraphics22GetNativeControlRegionEmmRK6RegionmRK16ImplControlValueR16SalControlHandleRKN3rtl8OUStringERS0_SC_PK12OutputDevice+0x144)[0xb7dfb074]
/opt/openoffice/program/libvcl680li.so(_ZN6Window22GetNativeControlRegionEmmRK6RegionmRK16ImplControlValueN3rtl8OUStringERS0_S8_+0x103)[0xb7eba743]
/opt/openoffice/program/libvcl680li.so(_ZN7ListBox6ResizeEv+0x173)[0xb7f02d33]
/opt/openoffice/program/libvcl680li.so[0xb7ea20f4]
/opt/openoffice/program/libvcl680li.so(_ZN6Window4ShowEht+0xc7)[0xb7ea38b7]
/opt/openoffice/program/libvcl680li.so(_ZN7ListBoxC1EP6WindowRK5ResId+0xe1)[0xb7f015a1]
/opt/openoffice/program/libsvt680li.so(_ZN11PrintDialogC1EP6Window+0x176)[0xb78fd616]
/opt/openoffice/program/libsc680li.so(_ZN14ScTabViewShell17CreatePrintDialogEP6Window+0x84)[0xaed4d234]
/opt/openoffice/program/libsfx680li.so[0xb1cdd360]
/opt/openoffice/program/libsfx680li.so[0xb1d0f658]
/opt/openoffice/program/libsfx680li.so[0xb1d0fde8]
/opt/openoffice/program/libsfx680li.so[0xb1d40236]
/opt/openoffice/program/libsfx680li.so[0xb1d401d9]
/opt/openoffice/program/libvcl680li.so[0xb7eb582c]
/opt/openoffice/program/libvclplug_gen680li.so(_ZN10SalDisplay21DispatchInternalEventEv+0xbc)[0xb4af8cec]
/opt/openoffice/program/libvclplug_gtk680li.so[0xb4f33d21]
/usr/lib/libglib-2.0.so.0[0xb6503671]
/usr/lib/libglib-2.0.so.0(g_main_context_dispatch+0x176)[0xb6505226]
/usr/lib/libglib-2.0.so.0[0xb65085b2]
/usr/lib/libglib-2.0.so.0(g_main_context_iteration+0x6e)[0xb6508b6e]
/opt/openoffice/program/libvclplug_gtk680li.so[0xb4f35fd1]
/opt/openoffice/program/libvclplug_gen680li.so(_ZN14X11SalInstance5YieldEbb+0x37)[0xb4b00547]
/opt/openoffice/program/libvcl680li.so(_ZN11Application5YieldEb+0x59)[0xb7cb7059]
/opt/openoffice/program/libvcl680li.so(_ZN11Application7ExecuteEv+0x3c)[0xb7cb717c]
/opt/openoffice/program/soffice.bin(_ZN7desktop7Desktop4MainEv+0x1360)[0x806c340]
/opt/openoffice/program/libvcl680li.so[0xb7cbcbb6]
/opt/openoffice/program/libvcl680li.so(_Z6SVMainv+0x35)[0xb7cbccb5]
/opt/openoffice/program/soffice.bin(main+0xcf)[0x805e1df]
/lib/libc.so.6(__libc_start_main+0xe0)[0xb6b52f90]
/opt/openoffice/program/soffice.bin(_ZN6Window15SetPosSizePixelEllllt+0x351)[0x805e0a1]
======= Memory map: ========
08048000-08099000 r-xp 00000000 08:11 570018 /opt/openoffice/program/soffice.bin
08099000-0809a000 rwxp 00050000 08:11 570018 /opt/openoffice/program/soffice.bin
0809a000-082d5000 rwxp 0809a000 00:00 0 [heap]
ad078000-ad16b000 r-xp 00000000 08:11 567158 /opt/openoffice/help/en/scalc.ht
ad16b000-ad18c000 rwxp ad16b000 00:00 0
ad18c000-ad28b000 r-xp 00000000 08:11 567157 /opt/openoffice/help/en/scalc.db
ad28b000-ad2ac000 rwxp ad28b000 00:00 0
ad2ac000-ad2c5000 r-xp 00000000 08:11 570085 /opt/openoffice/program/svtmisc.uno.so.1.1
ad2c5000-ad2c7000 rwxp 00018000 08:11 570085 /opt/openoffice/program/svtmisc.uno.so.1.1
ad2c7000-ad2fa000 r-xp 00000000 08:11 530068 /usr/lib/libxslt.so.1.1.22
ad2fa000-ad2fb000 rwxp 00033000 08:11 530068 /usr/lib/libxslt.so.1.1.22
ad2fb000-ad3fe000 r-xp 00000000 08:11 482790 /usr/lib/libdb-4.5.so
ad3fe000-ad401000 rwxp 00102000 08:11 482790 /usr/lib/libdb-4.5.so
ad401000-ad45f000 r-xp 00000000 08:11 569953 /opt/openoffice/program/libucpchelp1.so.1.1
ad45f000-ad461000 rwxp 0005e000 08:11 569953 /opt/openoffice/program/libucpchelp1.so.1.1
ad461000-ad462000 ---p ad461000 00:00 0
ad462000-adc62000 rwxp ad462000 00:00 0
adc62000-adcad000 r-xp 00000000 08:11 486383 /usr/lib/libgcrypt.so.11.2.3
adcad000-adcaf000 rwxp 0004a000 08:11 486383 /usr/lib/libgcrypt.so.11.2.3
adcaf000-add21000 r-xp 00000000 08:11 520880 /usr/lib/libgnutls.so.13.8.3
add21000-add27000 rwxp 00071000 08:11 520880 /usr/lib/libgnutls.so.13.8.3
add27000-add55000 r-xp 00000000 08:11 521482 /usr/lib/libcups.so.2
add55000-add57000 rwxp 0002d000 08:11 521482 /usr/lib/libcups.so.2
add66000-addb2000 r-xs 00000000 08:11 566240 /usr/share/fonts/TTF/DejaVuSans-ExtraLight.ttf
addb2000-ade82000 rwxp addb2000 00:00 0
ade89000-ade91000 r-xp 00000000 08:11 569864 /opt/openoffice/program/libmcnttype.so.1.1
ade91000-ade92000 rwxp 00007000 08:11 569864 /opt/openoffice/program/libmcnttype.so.1.1
ade92000-ae002000 rwxp ade92000 00:00 0
ae002000-ae07e000 r-xp 00000000 08:11 570262 /opt/openoffice/program/libxstor.so.1.1
ae07e000-ae081000 rwxp 0007b000 08:11 570262 /opt/openoffice/program/libxstor.so.1.1
ae081000-ae091000 rwxp ae081000 00:00 0
ae091000-ae0b0000 r-xp 00000000 08:11 569816 /opt/openoffice/program/fsstorage.uno.so.1.1
ae0b0000-ae0b2000 rwxp 0001e000 08:11 569816 /opt/openoffice/program/fsstorage.uno.so.1.1
ae0b2000-ae0be000 r-xp 00000000 08:11 569978 /opt/openoffice/program/libevtatt.so.1.1
ae0be000-ae0bf000 rwxp 0000b000 08:11 569978 /opt/openoffice/program/libevtatt.so.1.1
ae0bf000-ae0cf000 rwxp ae0bf000 00:00 0
ae0cf000-ae0ec000 r-xp 00000000 08:11 569758 /opt/openoffice/program/reflection.uno.so.1.1
ae0ec000-ae0ee000 rwxp 0001c000 08:11 569758 /opt/openoffice/program/reflection.uno.so.1.1
ae0ee000-ae10d000 r-xp 00000000 08:11 569568 /opt/openoffice/program/introspection.uno.so.1.1
ae10d000-ae10e000 rwxp 0001f000 08:11 569568 /opt/openoffice/program/introspection.uno.so.1.1
ae10e000-ae38a000 r-xp 00000000 08:11 569552 /opt/openoffice/program/libfrm680li.so.1.1
ae38a000-ae3aa000 rwxp 0027b000 08:11 569552 /opt/openoffice/program/libfrm680li.so.1.1
ae3aa000-ae3ac000 rwxp ae3aa000 00:00 0
ae3ac000-ae3fd000 r-xs 00000000 08:11 520072 /usr/share/fonts/TTF/times.ttf
ae3fd000-ae41d000 rwxp ae3fd000 00:00 0
ae41d000-ae4a1000 r-xs 00000000 08:11 566235 /usr/share/fonts/TTF/DejaVuSans-Bold.ttf
ae4a1000-ae4c1000 rwxp ae4a1000 00:00 0
ae4c1000-ae572000 r-xp 00000000 08:11 569559 /opt/openoffice/program/liblocaledata_others.so.1.1
ae572000-ae594000 rwxp 000b1000 08:11 569559 /opt/openoffice/program/liblocaledata_others.so.1.1
ae594000-ae64d000 r-xp 00000000 08:11 569922 /opt/openoffice/program/liblocaledata_euro.so.1.1
ae64d000-ae670000 rwxp 000b8000 08:11 569922 /opt/openoffice/program/liblocaledata_euro.so.1.1
ae670000-ae690000 r-xp 00000000 08:11 570264 /opt/openoffice/program/liblocaledata_es.so.1.1
ae690000-ae694000 rwxp 00020000 08:11 570264 /opt/openoffice/program/liblocaledata_es.so.1.1
ae694000-ae724000 rwxp ae694000 00:00 0
ae724000-ae742000 r-xp 00000000 08:11 570154 /opt/openoffice/program/liblocaledata_en.so.1.1
ae742000-ae747000 rwxp 0001e000 08:11 570154 /opt/openoffice/program/liblocaledata_en.so.1.1
ae747000-ae877000 r-xp 00000000 08:11 566292 /usr/lib/libicui18n.so.36.0
ae877000-ae87d000 rwxp 00130000 08:11 566292 /usr/lib/libicui18n.so.36.0
ae87d000-ae88b000 r-xp 00000000 08:11 520820 /usr/lib/libtasn1.so.3.0.12
ae88b000-ae88c000 rwxp 0000e000 08:11 520820 /usr/lib/libtasn1.so.3.0.12
ae88c000-ae9d9000 r-xp 00000000 08:11 569886 /opt/openoffice/program/i18npool.uno.so.1.1
ae9d9000-ae9e8000 rwxp 0014d000 08:11 569886 /opt/openoffice/program/i18npool.uno.so.1.1
ae9e8000-ae9eb000 rwxp ae9e8000 00:00 0
ae9eb000-aea2f000 r-xs 00000000 08:11 520055 /usr/share/fonts/TTF/arial.ttf
aea2f000-aea3f000 rwxp aea2f000 00:00 0
aea3f000-aeb94000 r-xp 00000000 08:11 569801 /opt/openoffice/program/libdbtools680li.so.1.1
aeb94000-aeb9d000 rwxp 00154000 08:11 569801 /opt/openoffice/program/libdbtools680li.so.1.1
aeb9d000-aeb9e000 rwxp aeb9d000 00:00 0
aeb9e000-af534000 r-xp 00000000 08:11 570048 /opt/openoffice/program/libsc680li.so
af534000-af583000 rwxp 00996000 08:11 570048 /opt/openoffice/program/libsc680li.so
af583000-af598000 rwxp af583000 00:00 0
af598000-af599000 ---p af598000 00:00 0
af599000-afd99000 rwxp af599000 00:00 0
afd99000-afdcb000 r-xp 00000000 08:11 569728 /opt/openoffice/program/libdtransX11680li.so.1.1
afdcb000-afdce000 rwxp 00031000 08:11 569728 /opt/openoffice/program/libdtransX11680li.so.1.1
afdce000-afe5e000 rwxp afdce000 00:00 0
afe5e000-afea9000 r-xp 00000000 08:11 569972 /opt/openoffice/program/libfilterconfig1.so.1.1
afea9000-afeab000 rwxp 0004a000 08:11 569972 /opt/openoffice/program/libfilterconfig1.so.1.1
afeab000-afed9000 r-xp 00000000 08:11 569844 /opt/openoffice/program/libuui680li.so.1.1
afed9000-afedb000 rwxp 0002e000 08:11 569844 /opt/openoffice/program/libuui680li.so.1.1
afedb000-afeea000 r-xp 00000000 08:11 569582 /opt/openoffice/program/libi18nutilgcc3.so.1.1
afeea000-afeeb000 rwxp 0000f000 08:11 569582 /opt/openoffice/program/libi18nutilgcc3.so.1.1
afeeb000-afeec000 rwxp afeeb000 00:00 0
afeec000-aff6f000 r-xp 00000000 08:11 570046 /opt/openoffice/program/liblng680li.so.1.1
aff6f000-aff75000 rwxp 00082000 08:11 570046 /opt/openoffice/program/liblng680li.so.1.1
aff75000-affdf000 r-xp 00000000 08:11 569695 /opt/openoffice/program/libgo680li.so.1.1
affdf000-affe2000 rwxp 00069000 08:11 569695 /opt/openoffice/program/libgo680li.so.1.1
affe2000-b03fe000 r-xp 00000000 08:11 569931 /opt/openoffice/program/libxo680li.so.1.1
b03fe000-b0425000 rwxp 0041b000 08:11 569931 /opt/openoffice/program/libxo680li.so.1.1
b0425000-b0426000 rwxp b0425000 00:00 0
b0426000-b0449000 r-xp 00000000 08:11 569927 /opt/openoffice/program/libavmedia680li.so.1.1
b0449000-b044b000 rwxp 00022000 08:11 56992[

Additional info:
The following was updated when I did the evolution upgrade:
[2007-10-03 10:32] --- MARK --- UPGRADE evolution
[2007-10-03 10:32] upgraded gail (1.18.0-2 -> 1.20.0-1)
[2007-10-03 10:32] upgraded libgnomecanvas (2.14.0-2 -> 2.20.0-1)
[2007-10-03 10:32] upgraded gnome-vfs (2.18.1-2 -> 2.20.0-2)
[2007-10-03 10:32] upgraded libbonobo (2.18.0-2 -> 2.20.0-1)
[2007-10-03 10:32] upgraded libgnome (2.18.0-2 -> 2.20.0-1)
[2007-10-03 10:32] upgraded libbonoboui (2.18.0-2 -> 2.20.0-1)
[2007-10-03 10:32] upgraded atk (1.18.0-2 -> 1.20.0-1)
[2007-10-03 10:32] upgraded gtk2 (2.10.14-3 -> 2.12.0-1)
[2007-10-03 10:32] upgraded gnome-keyring (0.8.1-2 -> 2.20.0-1)
[2007-10-03 10:32] upgraded libgnomeui (2.18.1-2 -> 2.20.0-1)
[2007-10-03 10:32] upgraded gnome-icon-theme (2.18.0-1 -> 2.20.0-1)
[2007-10-03 10:32] upgraded gtkhtml (3.14.3-1 -> 3.16.0-1)
[2007-10-03 10:32] upgraded gconf (2.18.0.1-4 -> 2.20.0-1)
[2007-10-03 10:32] upgraded heimdal (0.8.1-3 -> 1.0.1-2)
[2007-10-03 10:32] ATTENTION DB PACKAGE:
[2007-10-03 10:32] Please consider to run db_upgrade on Berkeley DB databases with a major db version number update.
[2007-10-03 10:32] upgraded db (4.5.20-2 -> 4.6.19-1)
[2007-10-03 10:33] upgraded smbclient (3.0.26a-1 -> 3.0.26a-2)
[2007-10-03 10:33] upgraded evolution-data-server (1.10.3.1-1 -> 1.12.0-2)
[2007-10-03 10:33] upgraded evolution (2.10.3-1 -> 2.12.0-1)

Steps to reproduce:
1. Upgrade evolution from testing.
2. Open a new document in OpenOffice
3. Select File | Print
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Tuesday, 23 October 2007, 17:24 GMT
Reason for closing:  Fixed
Additional comments about closing:  seems to work now for almost all gtk themes
Comment by Howard Johnson (hjohnson) - Thursday, 04 October 2007, 16:23 GMT
I fixed the problem (at least on my machine)... removed gtk2 gtk2 2.12.0-1 and downgraded back to 2.10.14-3. Thus far everything seems to work just fine.
Comment by Andreas Radke (AndyRTR) - Thursday, 04 October 2007, 19:41 GMT
what are your libcups/ghostscript pkgversions?
Comment by Howard Johnson (hjohnson) - Thursday, 04 October 2007, 19:45 GMT
libcups 1.2.12-1
ghostscript 8.15.4-3
Comment by Jan de Groot (JGC) - Thursday, 04 October 2007, 20:08 GMT
Works fine here. What GTK theme engine do you use?
Comment by Howard Johnson (hjohnson) - Thursday, 04 October 2007, 20:19 GMT
I have no idea what theme engine I use... did not specifically install a theme engine.
Comment by Andreas Radke (AndyRTR) - Tuesday, 16 October 2007, 21:07 GMT
how is the state? there were many printing related updates.
Comment by Juanma Hernandez (juanmah) - Wednesday, 17 October 2007, 15:03 GMT
I can't downgrade:

error: failed to prepare transaction (could not satisfy dependencies)
:: thunderbird: requires gtk2>=2.12.0
Comment by Juanma Hernandez (juanmah) - Thursday, 18 October 2007, 06:06 GMT
With gtk2-2.12.1-1 it's the same.
Comment by Andreas Radke (AndyRTR) - Thursday, 18 October 2007, 17:24 GMT
please everybody report your printer model, window manager, choosen gtk/kde look + theme, prefered (OOo/gtk) fpicker and make sure you have latest cups, ghostscript, foomatic and hpijs installed.

does it only crash in OOo writer or also in other parts?

post output given when starting from commandline "soffice". maybe you can also try out the OpenOffice-base-devel pkg from unstable.
Comment by Howard Johnson (hjohnson) - Thursday, 18 October 2007, 18:17 GMT
Gnome 2.18.3
cups 1.2.12-1
Crux theme (although in my testing the theme did not matter... it crashed in all themes)
ghostscript 8.15.4-3
foomatic is not installed
hpijs is not installed
samba 3.0.26a-1

In our environment all printing is done through cups/samba to shared network printers. In our case the type and model of printer does not matter since the print selection dialog box never had a chance to appear.

Also printing in other applications (i.e. Firefox and printing test pages from cups) worked just fine.
Comment by Juanma Hernandez (juanmah) - Friday, 19 October 2007, 10:44 GMT
OOo crashes in writer and also executing soffice.

Not only printing, algo crashes then checking ortography and changing language as normal user.

As root (first time executing soffice) is not crashing, i've to check if as a new user crashes.

libgnomeprint 2.18.2-1
libgnome 2.20.1.1-1
cups 1.3.3-1
ghostscript 8.60-1
foomatic-db 3.0_20071012-1
foomatic-db-hpijs 20071012-1
Comment by Juanma Hernandez (juanmah) - Friday, 19 October 2007, 10:53 GMT
A user first time executing writer also crashes on printing.
Comment by Juanma Hernandez (juanmah) - Friday, 19 October 2007, 11:05 GMT
A NEW user doesn't crash on printing neither checking ortography neither changing language.
gtk_theme: Clearlooks
icon_theme: gnome
Comment by Juanma Hernandez (juanmah) - Friday, 19 October 2007, 11:11 GMT
I've got it.
With gtk_theme: Dogmastik crashes
With gtk_theme: Clearlooks doesn't crash
Comment by Jan de Groot (JGC) - Friday, 19 October 2007, 11:26 GMT
Guess this is a bug in openoffice with certain theme styles. I've seen this with firefox also.
Comment by Moroz Dmitriy (dimaka) - Friday, 19 October 2007, 11:54 GMT
Got the same trouble. OOo freezes and X works slowly. I am using Murrine GTK engine. When I runing it as root or with export desktop=kde OOs works clearly.
Comment by Jan de Groot (JGC) - Friday, 19 October 2007, 11:54 GMT
http://svn.gnome.org/viewvc/ooo-build/trunk/patches/src680/ooo82608.vcl.gtkbadfree.diff?revision=10536&view=markup

that should be the fix. As stated above, it's an invalid free which is triggered by some GTK themes.
Comment by Jan de Groot (JGC) - Friday, 19 October 2007, 17:29 GMT
To workaround the crash, instead of choosing a different theme, you can also set the G_SLICE=always-malloc environment variable in your profile. This instructs the G_SLICE memory allocator to always allocate memory which can be free'd with g_free like firefox and openoffice do when not patched.
Comment by Moroz Dmitriy (dimaka) - Sunday, 21 October 2007, 11:02 GMT
Does new OOo package fix problem with GTK themes?
Comment by Moroz Dmitriy (dimaka) - Sunday, 21 October 2007, 17:20 GMT
I just have installed OOo 2.3.0-4 but it's still crashes when I am using it with desktop=gnome and Murrine GTK engine. =(
Comment by Juanma Hernandez (juanmah) - Monday, 22 October 2007, 06:27 GMT
It works.

gtk_theme: Dogmastik
openoffice-base (2.3.0-3 -> 2.3.0-4)
gnome-desktop (2.20.0-1 -> 2.20.1-1)
gtk-engines (2.12.1-1 -> 2.12.2-1)
gnome-themes (2.20.0-1 -> 2.20.1-1)

Loading...