Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#8153 - noarch packages support

Attached to Project: Pacman
Opened by Roman Kyrylych (Romashka) - Friday, 28 September 2007, 08:06 GMT
Last edited by Roman Kyrylych (Romashka) - Friday, 16 November 2007, 17:40 GMT
Task Type Feature Request
Category General
Status Closed
Assigned To Aaron Griffin (phrakture)
Roman Kyrylych (Romashka)
Dan McGee (toofishes)
Architecture All
Severity Medium
Priority Normal
Reported Version 3.0.6
Due in Version 3.1.0
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Summary and Info:
Introduce noarch packages - packages that are not arch-specific.

Motivation:
There is no need to have exactly same packages (that differ only by arch field in .PKGINFO) for:
* perl/php/python/ruby packages, shell scripts
* fonts, icons, clipart
* man/info/devhelp/html docs
* game data
* any other packages that are not arch-specific (e.g. hal-info, licenses)

Implementation:
1) modify {core,extra,community}pkg to tag CVS files for noarch packages as CURRENT and CURRENT64 at the same time
2) add noarch packages to i686 and x86_64 .db.tar.gz files at the same time (modify all needed scripts)
3) modify makepkg to understand arch=('any') (or 'all', feel free to name it) and make -any.pkg.tar.gz files
4) modify our web backend (we need to do this anyway because of x86_64 support)
5) update respective man pages and packaging guidelines.
No changes to pacman needed (except possibly some changes for -Qi)
This task depends upon

This task blocks these from closing
 FS#8109 - Pacman 3.1 Release Roadmap 
Closed by  Roman Kyrylych (Romashka)
Friday, 16 November 2007, 17:40 GMT
Reason for closing:  Fixed
Additional comments about closing:  in 3.1 git
Comment by Aaron Griffin (phrakture) - Friday, 28 September 2007, 15:45 GMT
Dan, do we want to slate this for 3.1? It doesn't seem all that hard, AND it seems useful.
Comment by Dan McGee (toofishes) - Friday, 28 September 2007, 17:31 GMT
I already made initial changes to pacman so we can install packages named foo.bar if you want, instead of them having to follow the name-ver-arch.ext format like was required before. Do we want to implement architecture verification somewhere in pacman? Thus, an i686 machine can only install packages built for 'i686' and 'noarch' (or 'all', 'none', or whatever the heck we decide on).
Comment by Roman Kyrylych (Romashka) - Saturday, 29 September 2007, 14:43 GMT
Won't such verification break installation of Arch in i686 chroot on x86_64 system? Or it may be worked around by changing pacman config?

The other situation when it breaks something is when x86_64 user uses lib32-* stuff from Unsupported and tries to install some i686-only commercial binary. But that way is unsupported, so users would better repackage such packages with modified PKGBUILDS. :-P
Comment by Aaron Griffin (phrakture) - Wednesday, 31 October 2007, 22:53 GMT
  • Field changed: Percent Complete (0% → 20%)
Thanks to Roman, we now have patches that are part of makepkg.

Next is extrapkg and the db-scripts, I imagine.
Comment by Aaron Griffin (phrakture) - Wednesday, 07 November 2007, 06:54 GMT
Move to internal dev now that the pacman portion is complete?
Comment by Roman Kyrylych (Romashka) - Wednesday, 07 November 2007, 08:45 GMT
agree
Comment by Dan McGee (toofishes) - Wednesday, 07 November 2007, 14:18 GMT
Just open a new one depending on this one. That way we can close this and put it under the 3.1 catcher, and keep the public record.
Comment by Roman Kyrylych (Romashka) - Wednesday, 07 November 2007, 15:35 GMT
 FS#8555  created

Loading...