Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#8137 - upgrading by groups

Attached to Project: Pacman
Opened by Stefan O. (hybrid) - Wednesday, 26 September 2007, 23:25 GMT
Last edited by Xavier (shining) - Tuesday, 13 May 2008, 19:59 GMT
Task Type Feature Request
Category General
Status Closed
Assigned To Aaron Griffin (phrakture)
Dan McGee (toofishes)
Architecture All
Severity Low
Priority Normal
Reported Version 3.0.6
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

I think it would be good if it was possible to be able to choose from the command line which repositories pacman should upgrade. For example if I only want to upgrade core packages, I think it could be handy sometimes to quickly tell pacman something like pacman -Syuw --rep=core. Sure this can be done by editing the pacman.conf, so probably it would be better to utilize the existing --groups switch. Right now it only prints, but I think it'd be useful if eg. pacman -Syu --groups base would update all packages in the group.

Why? Well sometimes I don't want to upgrade everything at the same time and I'd be able to split it up. I was just gone for 6 weeks for example and over 600MB of updates have piled up in that time. So I'd like to be able to update the core first and then once I worked through a couple things do the rest.
This task depends upon

Closed by  Xavier (shining)
Tuesday, 13 May 2008, 19:59 GMT
Reason for closing:  Works for me
Additional comments about closing:  pacman -S group works for me.
If you need something like Nagy's --nonew option, please open a separate feature request.
Comment by Aaron Griffin (phrakture) - Thursday, 27 September 2007, 23:13 GMT
Hmmm, I'm not sure about this.

I like the second idea of reusing --groups, but the first idea about specifying repos, probably not a good idea.

Other opinions?
Comment by Xavier (shining) - Friday, 28 September 2007, 13:50 GMT
Is it a good idea to upgrade core first, without the rest?
Couldn't this break the other packages?
Comment by Roman Kyrylych (Romashka) - Friday, 28 September 2007, 13:56 GMT
IMO both ideas will be useful for very small amount of people, IMO.
IMO it's ok to have pacman.conf editing as a solution for repo-only upgrade and --ignorepkg as a solution for group-only upgrade.
However I don't mind groups-only upgrade feature if it's not hard to implement.
Also, while we're on it, I'd like to remind about this nice FR too:  FS#1592  ;-)
Comment by Aaron Griffin (phrakture) - Tuesday, 09 October 2007, 15:26 GMT
Yeah  FS#1592  is on the 3.1 roadmap.
Comment by Roman Kyrylych (Romashka) - Monday, 22 October 2007, 15:11 GMT Comment by Nagy Gabor (combo) - Thursday, 13 March 2008, 19:01 GMT
also see http://www.archlinux.org/pipermail/pacman-dev/2008-March/011301.html
[In this form the patch won't be accepted, but see the discussion about the feature.]
Comment by Nagy Gabor (combo) - Tuesday, 13 May 2008, 13:41 GMT
Status on this? I like this feature (the group part), but if we don't want to implement it, we should close this as "won't implement".
Comment by Xavier (shining) - Tuesday, 13 May 2008, 14:13 GMT
> +*\--nonew*::
> + Pacman won't install new (not-yet-installed) packages, except if they are
> + needed by others (as dependency). This is mostly used in group
> + operations to restrict pacman to installed packages of the group.
> + For example 'pacman -S base --nonew --needed' will upgrade your
> + base group, but won't add new packages from base.
> +

Actually, this feature request doesn't mention at all the problem of adding new packages.
It was not even mentioned that you could just do 'pacman -S --needed base' to install/upgrade all packages from base.
So actually, this feature is already available.
pacman doesn't support the case of partially installed groups, but that's a corner case, it is not a problem, and it is not what this feature request was about.
Or am I missing something obvious?
If yes, then I would close this as 'wont implement', otherwise as 'already implemented' :)
Comment by Nagy Gabor (combo) - Tuesday, 13 May 2008, 14:30 GMT
Well, the title 'upgrading by packages' and the example given by 'pacman -Syu --groups base' suggested me, that Stefan wants something like --nonew, but maybe I'm wrong.
Comment by Nagy Gabor (combo) - Tuesday, 13 May 2008, 14:31 GMT
s/packages/groups/ (LOL)
Comment by Xavier (shining) - Tuesday, 13 May 2008, 14:38 GMT
Ok so now that you said this, it makes sense to close that bug.
If someone wants, he can open a new and clearer feature request asking for something like --nonew.

Loading...