Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#8109 - Pacman 3.1 Release Roadmap

Attached to Project: Pacman
Opened by Aaron Griffin (phrakture) - Monday, 24 September 2007, 01:25 GMT
Last edited by Dan McGee (toofishes) - Thursday, 10 January 2008, 14:09 GMT
Task Type Feature Request
Category General
Status Closed
Assigned To Aaron Griffin (phrakture)
Xavier (shining)
Dan McGee (toofishes)
Architecture All
Severity Medium
Priority High
Reported Version 3.0.6
Due in Version 3.1.0
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

This task will be used to attach bugs and feature requests to that we will address before the 3.1 release

Please, for the sake of flyspray, set the "due in version" property on the attached bugs as well.

EDIT (Dan):
Please do not attach bugs/feature requests to here that have not been brought up on the pacman-dev ML first, or at least had some discussion in Flyspray. Feature creep is not something we need right now.
This task depends upon
 FS#1592 - IgnoreGroup 
 FS#4182 - Total Download Size 
 FS#5005 - pacman dependency check 
 FS#6057 - impossible to remove package+dependencies, when it is required 
 FS#6389 - Pacman handling of mirrors/repos 
 FS#6404 - pacman -U/-A leaves remote files in current dir 
 FS#6500 - pacman -Ss and regex 
 FS#6667 - Display size of each package in the package list 
 FS#6812 - pacman -Syi ignores the -y 
 FS#6933 - Lines missing in online PKGBUILD man page 
 FS#7117 - Internal pacman error: Segmentation fault 
 FS#7133 - DB scanning doesn't continue when a broken entry is found 
 FS#7147 - -Syuw and -Syup should not ask for pacman upgrade 
 FS#7182 - pacman -Q --changelog works only as root 
 FS#7205 - Global percent 
 FS#7229 - pacman installs packages in wrong order 
 FS#7240 - no /var/cache/pacman/pkg/ & /tmp fallback for pacman is unu 
 FS#7312 - Use asciidoc to generate man pages. 
 FS#7339 - Allow more than one cache dir 
 FS#7343 - pacman -Q options 
 FS#7484 - pacman clobbers directory symlinks 
 FS#7495 - pacman does not check dependencies in all cases 
 FS#7587 - missing 5.8.8 symlink in /usr/lib/perl5 
 FS#7622 - pacman stuck in infinite loop 
 FS#7639 - phantom dep after downgrade with pacman -U 
 FS#7652 - libalpm check for ability to remove file is wrong, pacman runs i 
 FS#7811 - Pacman cannot replace conflicting packages correctly with certai 
 FS#7820 - Pacman failed to upgrade pacman package during distribution upgr 
 FS#8042 - rankmirrors doesn't work with the new global mirrorlist 
 FS#8043 - rankmirrors should optionally read from stdin 
 FS#8054 - "Dynamic" IgnorePkg 
 FS#8061 - Remove uninstalled packages from pacman-cache 
 FS#8081 - Pacman fail in tr_TR locale.. 
 FS#8145 - makepkg : invisible messages on white backgrounds 
 FS#8153 - noarch packages support 
 FS#8156 - pacman does not detect conflict between symlink and files/direct 
 FS#8190 - pacman-optimize doesn't work without diffutils 
 FS#8244 - No hint what package failed after -Syu when integrity check fail 
 FS#8463 - Choosing package to installation 
 FS#8544 - combine package/download text when they are the same 
 FS#8883 - a little error on PKGBUILD's man page 
 FS#8885 - Improper error message when /tmp is full 

Closed by  Dan McGee (toofishes)
Thursday, 10 January 2008, 14:09 GMT
Reason for closing:  Implemented
Additional comments about closing:  3.1.0 is out the door, 3.1.1 here we come
Comment by Dan McGee (toofishes) - Monday, 03 December 2007, 04:25 GMT
So quick rundown on the still open bugs, let me know your opinions:

FS #6933 - will be fixed once we release, so not a blocker.
FS #7182 - should be fixed now with latest push to master?
FS #7587 - I think this is fixed?
FS #7884 - we can push this off as it isn't really a bug, but more a peculiarity.
FS #7944 - hard to reproduce, so hard to fix. We have other bugs similar to this as well.
FS #8155 - I don't think our memory requirements have increased, but much bigger gains will come post-3.1 with dynamic package memory allocation. Punt to 3.2?
FS #8156 - this could use a look.

A few other issues:
* removal of ABS before we release? Split it into its own package so we can play with it separately since it is Arch-specific?
* removal of -A/-add before we release? We marked it as depreciated in 3.0.
* ensure documentation is up to date, including things like the changelog.
Comment by Travis Willard (Cerebral) - Monday, 03 December 2007, 05:16 GMT
> FS #7884 - we can push this off as it isn't really a bug,
> but more a peculiarity.

Agreed.

> FS #7944 - hard to reproduce, so hard to fix. We have other
> bugs similar to this as well.

I don't think it's a show-stopper, however. This could wait for a bugfix release of 3.1

> FS #8155 - I don't think our memory requirements have
> increased, but much bigger gains will come post-3.1
> with dynamic package memory allocation. Punt to 3.2?

Punt.

> * removal of ABS before we release? Split it into
> its own package so we can play with it separately
> since it is Arch-specific?

Might be worth its own package. Generally doesn't belong in the pacman source tree, however, as (since you mentioned) it is an Arch-specific tool. Maybe another project on arch-projects, with a package all its own? I'd get behind that.

> * removal of -A/-add before we release? We marked
> it as depreciated in 3.0.

Hm. I never use it anymore. Get rid of it, I say. -U does everything we need.
Comment by Xavier (shining) - Monday, 03 December 2007, 19:48 GMT
Well, I agree with what Travis said (except that I don't have any idea / opinion about ABS).
The remaining bugs:

> FS #7182 - should be fixed now with latest push to master?

Yes, it's fixed now.

> FS #7587 - I think this is fixed?

I don't know, but it's related to 7484 which is closed, and 7530 which could be closed.
So it can probably be closed.

> FS #8156 - this could use a look.

Yes, it could :)
Comment by Roman Kyrylych (Romashka) - Wednesday, 05 December 2007, 10:48 GMT
 FS#7587  is fixed. If someone still experience the issue reported there - it's because of: http://bugs.archlinux.org/task/8389#comment20684
Comment by Travis Willard (Cerebral) - Saturday, 15 December 2007, 20:10 GMT
pacman -Sp is only allowed for a root user - this breaks checkpkg - see  FS#8940 

Dan's mentioned that he's not sure we wanna fix it. Thoughts?

Loading...