Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#8080 - [util-linux-ng] mounting nfs shares failed

Attached to Project: Arch Linux
Opened by Gerhard Brauer (GerBra) - Friday, 21 September 2007, 16:58 GMT
Last edited by Thomas Bächler (brain0) - Saturday, 22 September 2007, 00:21 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Thomas Bächler (brain0)
Architecture All
Severity High
Priority Normal
Reported Version 2007.08.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


After updating util-linux-2.12-12 to util-linux-ng-2.13-1 mounting nfs shares failed.
mount gives error:
"wrong fs type, bad option, bad superblock on s02:/data"

I have to explicitly install package nfs-utils to could mount nfs shares.
Maybe there is a bug in the package or we must have a dependence in util-linux-ng to nfs-utils.

Steps to reproduce:
Fresh install from 2008.08.1
/etc/rc.d/portmap start
mount -t nfs foo:/bar /bar
That's ok.

pacman -S util-linux-ng
/etc/rc.d/portmap start
mount -t nfs foo:/bar /bar
This task depends upon

Closed by  Thomas Bächler (brain0)
Saturday, 22 September 2007, 00:21 GMT
Reason for closing:  Not a bug
Additional comments about closing:  It is natural to have nfs-utils installed when you use nfs. This is not a bug.

The installer will include nfs-utils in the future, if it doesn't already.
Comment by Jan de Groot (JGC) - Friday, 21 September 2007, 18:43 GMT
Having nfs-utils on your system for NFS is normal behaviour. It's quite silly that every OS handles NFS with a mount helper but older versions of util-linux have a buggy NFS mount utility integrated in the standard mount.
About the dependency: no, won't do that. util-linux doesn't depend on reiserfsprogs and xfsprogs either.
Comment by Gerhard Brauer (GerBra) - Friday, 21 September 2007, 19:46 GMT
i've never noticed about a "buggy mount" with nfs.
For me this new behavior is a step back. I do some installations via PXE-Boot, then mount a nfs share with ISO's and mount them with
loop device to start the install program.

I think a kernel with nfs enabled and mount should gave me the option to mount a nfs share - as it was usual for years.
Comment by Jan de Groot (JGC) - Friday, 21 September 2007, 20:35 GMT
The kernel also contains support for other filesystems like smbfs, cifs and ntfs, but our mount utility doesn't include the code for those filesystems. The reason for a standalone nfs mount binary is quite simple: the integrated NFS support can only handle version 1, 2 and 3, for later versions you need nfs-utils anyways. If all the code is in a standalone NFS mount binary which can handle all versions, why would you have it integrated in a program called "mount"?

For your reference on OpenBSD:
/sbin/mount /sbin/mount_ffs /sbin/mount_ntfs /sbin/mount_xfs
/sbin/mount_ados /sbin/mount_mfs /sbin/mount_portal /sbin/mountd
/sbin/mount_cd9660 /sbin/mount_msdos /sbin/mount_procfs
/sbin/mount_ext2fs /sbin/mount_nfs /sbin/mount_udf

One mount helper for every supported filesystem, mount is only a frontend to those. About having nfs-utils as a dependency for util-linux: NFS is not a basic functionality and is optional. It's included in core as a package and you're free to install or uninstall it.
Comment by Gerhard Brauer (GerBra) - Friday, 21 September 2007, 21:50 GMT
your comments make a sense to me.

Could you explain how this is handled on the further Installation-CD's (or the installer itself) when util-linux-ng reaches those
ISO's? Am i able to mount a NFS share from the installer console before installing something from core/base?
Think on my example with PXE-Installation.

If this works then this "bug" is solved for me.

To explain: i've no problem to install nfs-utils if i know that it's needed.
But i was amazed that before updating nfs mounting worked like a charm, i put nfs mounts in /etc/fstab (/usr, pacmam/pkg,...) and
after next reboot i get stoned from errors ;-)

Maybe it was worth to put a notice to the user when updating to util-linux-ng?