Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#79708 - [nim] PLEASE ENTER SUMMARY

Attached to Project: Arch Linux
Opened by Andrew O'Neill (meanjollies) - Saturday, 16 September 2023, 13:09 GMT
Last edited by Antonio Rojas (arojas) - Saturday, 16 September 2023, 14:35 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Unable to find '/usr/lib/nim/lib/system.nim'

Additional info:
After upgrading from nim 1.6 to 2.0, I'm getting compilation failures related to nim not being able to find '/usr/lib/nim/lib/system.nim'. However, '/usr/lib/nim/system.nim' does exist, so this seems to be a path issue somewhere.

Steps to reproduce:
$ nim c
Error: cannot open '/usr/lib/nim/lib/system.nim'
This task depends upon

Closed by  Antonio Rojas (arojas)
Saturday, 16 September 2023, 14:35 GMT
Reason for closing:  Fixed
Additional comments about closing:  nim 2.0.0-2
Comment by Andrew O'Neill (meanjollies) - Saturday, 16 September 2023, 13:14 GMT
Ugh, sorry for the bad title. I completely forgot to change that when opening this.

Loading...