Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#79647 - openfortivpn can't connect to vpn with 2.5.0 ppp version (work on ppp 2.4.9)

Attached to Project: Arch Linux
Opened by Minux (minux31) - Monday, 11 September 2023, 09:30 GMT
Last edited by Toolybird (Toolybird) - Monday, 11 September 2023, 20:23 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

With 2.5.0-1 ppp version, openfortivpn can't connect to vpn (works great on 2.4.9-3 ppp version)


Additional info:
* package version : openfortivpn 1.20.5-1
* log :
INFO: Connected to gateway.
Two-factor authentication token:
INFO: Authenticated.
INFO: Remote gateway has allocated a VPN.
Warning: couldn't open ppp database /run/pppd/pppd2.tdb
Using interface ppp0
Connect: ppp0 <--> /dev/pts/3
INFO: Got addresses: [xx.xxx.xxx.xx], ns [xxx.xx.xx.xxx, xxx.xx.xx.xx], ns_suffix [xxxxxxxxx.local]
INFO: Negotiation complete.
INFO: Negotiation complete.
Peer refused to agree to his IP address
Connect time 0.1 minutes.
Sent 1101 bytes, received 1081 bytes.
ERROR: Timed out waiting for the ppp interface to be UP.
INFO: Cancelling threads...
INFO: Cleanup, joining threads...
Hangup (SIGHUP)
Modem hangup
Connection terminated.
ERROR: pppd: The link was terminated by the modem hanging up.
INFO: Terminated pppd.
INFO: Closed connection to gateway.
INFO: Logged out.

Steps to reproduce:
Install 2.5.0 ppp version, launch openfortivpn
This task depends upon

Closed by  Toolybird (Toolybird)
Monday, 11 September 2023, 20:23 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#79639 
Comment by Toolybird (Toolybird) - Monday, 11 September 2023, 20:22 GMT
> Warning: couldn't open ppp database /run/pppd/pppd2.tdb

This looks like the same problem in  FS#79639 

Loading...