FS#79579 - Upgrading libtiff to 4.5.1-2 breaks GDM and lightdm

Attached to Project: Arch Linux
Opened by Sam Whited (SamWhited) - Tuesday, 05 September 2023, 16:41 GMT
Last edited by David Runge (dvzrv) - Tuesday, 05 September 2023, 17:08 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No



After upgrading to libtiff 4.5.1-2 from 4.5.1-1 lightdm and gdm both crash on start with the error message:

`/usr/bin/lightdm-gtk-greeter: symbol lookup error: /usr/lib/libtiff.so.6: undefined symbol: jpeg12_write_raw_data, version LIBJPEG_8.0`

Additional info:
* package version(s):

libtiff 4.5.1-2, lightdm 1:1.32.0-4, gdm 44.1-1

* config and/or log files etc.

Please let me know if you need any specific config files and I'll try to get them for you, I am not sure what might be relevant.

* link to upstream bug report, if any

I could not find an upstream report after searching around.

Steps to reproduce:

Install lightdm or gdm, upgrade libtiff.
Downgrading to 4.5.1-1 solved the problem for me and I can boot to my desktop environment again.
This task depends upon

Closed by  David Runge (dvzrv)
Tuesday, 05 September 2023, 17:08 GMT
Reason for closing:  Not a bug
Additional comments about closing:  mozjpeg seems to not be a drop-in replacement for libjpeg-turbo and as it is in the AUR is also not supported.
Please install libpjpeg-turbo
Comment by David Runge (dvzrv) - Tuesday, 05 September 2023, 17:00 GMT
@SamWhited: Thanks for the ticket.

I am not able to reproduce this with gdm at all.
What is your current libjpeg version (e.g. `pacman -Qi libjpeg-turbo`)?
Comment by Sam Whited (SamWhited) - Tuesday, 05 September 2023, 17:01 GMT
$ pacman -Qi libjpeg-turbo
Name : mozjpeg
Version : 4.1.3-1
Description : JPEG image codec with accelerated baseline decoding and superior encoding
Architecture : x86_64
URL : https://github.com/mozilla/mozjpeg
Licenses : BSD
Groups : None
Provides : libjpeg libjpeg.so=8-64 turbojpeg libjpeg-turbo
Depends On : glibc libpng
Optional Deps : None
Required By : chromium djvulibre eom fltk freerdp gdk-pixbuf2 gegl ghostscript gimp gst-plugins-base gtk4 handbrake
imlib2 inkscape jasper jre-openjdk-headless jre11-openjdk-headless libavif libgphoto2 libgxps libjxl
libreoffice-fresh libtiff libvncserver libwebp libwmf libyuv mjpegtools mplayer netpbm podofo poppler
python-pillow qemu-system-x86 qpdf qt5-base qt6-base sane sdl2_image spice texlive-bin tigervnc v4l-utils
webkit2gtk webkit2gtk-4.1 webkitgtk-6.0
Optional For : libheif vlc
Conflicts With : libjpeg mozjpeg-git turbojpeg libjpeg-turbo
Replaces : None
Installed Size : 2.36 MiB
Packager : Unknown Packager
Build Date : Sun 11 Jun 2023 09:06:20 PM EDT
Install Date : Sun 11 Jun 2023 09:08:13 PM EDT
Install Reason : Explicitly installed
Install Script : No
Validated By : None
Comment by David Runge (dvzrv) - Tuesday, 05 September 2023, 17:04 GMT
Also tried lightdm and it does not crash either.

Potentially there is something wrong with your libjpeg-turbo installation.
Comment by loqs (loqs) - Tuesday, 05 September 2023, 17:06 GMT
You have not rebuilt mozjpeg [1] which replaces libjpeg-turbo on your system for libtiff 4.5.1-2 assuming it is compatible.

[1] https://aur.archlinux.org/packages/mozjpeg
Comment by David Runge (dvzrv) - Tuesday, 05 September 2023, 17:07 GMT
https://aur.archlinux.org/packages/mozjpeg is not supported.
Please install libjpeg-turbo (pacman -S libjpeg-turbo).
Comment by Sam Whited (SamWhited) - Tuesday, 05 September 2023, 17:07 GMT
I just updated libtiff again and installed libjpeg-turbo instead of the mozjpeg that I apparently had installed and can confirm that this does fix the problem and it can boot correctly (thank you, I never would have made the jump from libtiff to it having something to do with the jpeg library and didn't even know I had an alternative one installed). I'm not sure where that leaves this issue; maybe it's something that needs to be upstreamed to mozjpeg.