Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#79113 - [opencv-cuda] 4.8.0-2 OpenCVConfig.cmake requires exact cuda version 12.1 but cuda is at 12.2

Attached to Project: Arch Linux
Opened by Justus Spitzm├╝ller (sptzmllr) - Saturday, 15 July 2023, 21:03 GMT
Last edited by Antonio Rojas (arojas) - Sunday, 16 July 2023, 06:33 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Antonio Rojas (arojas)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

The `OpenCVConfig.cmake`-script is looking for `cuda` in the exact version `12.1` but the current version is `12.2`.

Additional info:
* 4.8.0-2
```
CMake Error at /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:230 (message):
Could NOT find CUDA: Found unsuitable version "12.2", but required is exact
version "12.1" (found /opt/cuda)
Call Stack (most recent call first):
/usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:598 (_FPHSA_FAILURE_MESSAGE)
/usr/share/cmake/Modules/FindCUDA.cmake:1268 (find_package_handle_standard_args)
/usr/lib/cmake/opencv4/OpenCVConfig.cmake:86 (find_package)
/usr/lib/cmake/opencv4/OpenCVConfig.cmake:108 (find_host_package)
src/tools/imagery/imagery_opencv/CMakeLists.txt:32 (find_package)


-- Configuring incomplete, errors occurred!
==> ERROR: A failure occurred in build().
Aborting...
```

Steps to reproduce:
Build the AUR package of [saga-gis](https://aur.archlinux.org/packages/saga-gis) with opencv-cuda.

SAGA-GIS uses opencv for the imagery library. With `opencv-cuda` the saga cmake configuration aborts because the OpenCVConfig.cmake script uses the `EXACT`-option to find `cuda`. Currently `cuda` is in version `12.2` but `opencv-cuda` expects version `12.1`.
This task depends upon

Closed by  Antonio Rojas (arojas)
Sunday, 16 July 2023, 06:33 GMT
Reason for closing:  Fixed
Additional comments about closing:  opencv-cuda 4.8.0-3

Loading...