Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#7881 - startx crashed after xf86-video-ati upgrade

Attached to Project: Arch Linux
Opened by Miroslaw Czachor (forest76) - Thursday, 23 August 2007, 18:23 GMT
Last edited by Alexander Baldeck (kth5) - Tuesday, 25 September 2007, 17:59 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Alexander Baldeck (kth5)
Architecture i686
Severity Critical
Priority Normal
Reported Version 2007.08 Don't Panic
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

After xf86-video-ati upgrade to 6.7.191-1 xorg crash and monitor turn off.
Run: startx 2>x.txt give me following error log:

----------------------------- x.txt --------------------------------------
xauth: creating new authority file /home/mirek/.serverauth.4796

_XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6
_XSERVTransOpen: transport open failed for inet6/myhost:0
_XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6

X Window System Version 1.3.0
Release Date: 19 April 2007
X Protocol Version 11, Revision 0, Release 1.3
Build Operating System: UNKNOWN
Current Operating System: Linux myhost 2.6.22-ARCH #1 SMP PREEMPT Wed Aug 22 00:31:50 CEST 2007 i686
Build Date: 10 August 2007
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Thu Aug 23 19:50:39 2007
(==) Using config file: "/etc/xorg.conf"
(II) Module already built-in
(II) Module already built-in
finished output detect: 0
finished output detect: 1
finished all detect
before xf86InitialConfiguration
in RADEONProbeOutputModes
after xf86InitialConfiguration
(II) Module already built-in
init memmap
init common
init crtc1
init pll1
restore memmap
restore common
restore crtc1
restore pll1
finished PLL1

Backtrace:
0: X(xf86SigHandler+0x81) [0x80ddf91]
1: [0xb7f92420]
2: /usr/lib/xorg/modules/drivers//radeon_drv.so(RADEONInitDispBandwidth+0x66) [0xb7be9d26]
3: /usr/lib/xorg/modules/drivers//radeon_drv.so [0xb7beb61c]
4: X(xf86CrtcSetMode+0x24f) [0x80f883f]
5: /usr/lib/xorg/modules/drivers//radeon_drv.so(RADEONScreenInit+0x100b) [0xb7bd8ddb]
6: X(AddScreen+0x1fc) [0x8075dac]
7: X(InitOutput+0x21e) [0x80a75ce]
8: X(main+0x28b) [0x807652b]
9: /lib/libc.so.6(__libc_start_main+0xe0) [0xb7da5f90]
10: X(FontFileCompleteXLFD+0x1ed) [0x8075aa1]

Fatal server error:
Caught signal 11. Server aborting

disable montype: 1
finished PLL1
XIO: fatal IO error 104 (Connection reset by peer) on X server ":0.0"

after 0 requests (0 known processed) with 0 events remaining.


--------------------------------------------------------------------------

In attachment oryginal xorg log from /var/log

Greeting's,
Miroslaw

PS. My graphics card is Radeon DDR (7200), from now I have not any problem
with xf86-video-ati package.
This task depends upon

This task blocks these from closing
 FS#7920 - xorg showstopper 
Closed by  Alexander Baldeck (kth5)
Tuesday, 25 September 2007, 17:59 GMT
Reason for closing:  Fixed
Additional comments about closing:  fix provied upstream, thanks everyone
Comment by kongokris 2 (nut543) - Friday, 24 August 2007, 12:28 GMT
I had to delete all my modelines in xorg.conf aswell as horisynz and vertrefresh or whatever it's called to get this rel to work properly. (We'll it's not actually working 100%, I now get black lines on the sides of my lcd, and can't get the picture to cover the whole screen but that's propably easily fixable if i look into it...)
Comment by greg (moise7864) - Sunday, 26 August 2007, 14:28 GMT
I have the same trouble with i810 driver. I guess this is a bug in another package. (libc???)
Comment by Corrado Primier (bardo) - Monday, 03 September 2007, 11:09 GMT
I have to confirm this. I have an ATI Radeon 9700 mobile (M10/M11) and I get a black screen with the testing driver. I really tried everything with the configuration but nothing helped. It worked with vesa, though, and ATM I'm using the [current] package with no problem whatsoever.
Comment by kongokris 2 (nut543) - Thursday, 06 September 2007, 14:23 GMT
just going to say that i just had to reset my monitor to get rid of "the black lines" so it wasn't really an error in the first place.
Comment by Corrado Primier (bardo) - Thursday, 06 September 2007, 16:17 GMT
I just took some tests, the latest version that works for me is 6.6.193, no luck with later versions. I'm attaching the 6.7.192 log, if needed I can add the ones of 6.6.193 and 6.3.3 (current). I'm not posting my xorg.conf since I'm 99% positive it isn't involved.

Anyway my xorg doesn't crash, I just get a black screen and I have to kill it, so I'm not sure it is the same problem. One thing I noticed to be present in the 6.7.192 log and not in the others (including the one attached to this bug) is two (sometimes three) "(WW) RADEON(0): DDC2/I2C is not properly initialized", I think it could be the cause/a consequence of my problem.
Comment by kongokris 2 (nut543) - Thursday, 06 September 2007, 17:06 GMT
2 things to try:

1. put Option "IgnoreEDID" "True" in monitor section
2. revise the monitor section, it's possible the problem lays there(this is my entry, though vertrefresh and horizsync might be wise to put in there...):
Section "Monitor"
Identifier "Monitor0"
Option "DPMS" "true"
EndSection

you might also want to checkout your screen section or weird ati specific options.

ofcourse if you don't want to check your xorg.conf...

(PS: You could also wait a day or two for the new ati drivers and see if they work..! ;))
Comment by kongokris 2 (nut543) - Thursday, 06 September 2007, 17:09 GMT
btw IgnoreEDID shoould be the same as the noDDC option as 'i've read on the internet' 'IROI' ;) :D
Comment by Corrado Primier (bardo) - Thursday, 06 September 2007, 18:44 GMT
Sadly I already tried IgnoreEDID, NoDDC, DDCMode, ReverseDDC, LVDSProbePLL and others. That's why I'm excluding xorg.conf. The are going to be new fglrx drivers, not ati ones, as far as I know. I'd be happy to be corrected.
Comment by kongokris 2 (nut543) - Thursday, 06 September 2007, 18:53 GMT
umm yeah, that's what i meant. ati drivers = not open source drivers but fglrx ones, i think the term is pretty generic though...

Did you try to remove Load ddc? Another thing to try according to the internet is to also put the option in Device section. besides that i have nooo idea besides searching google or asking in #xorg :P
Comment by kongokris 2 (nut543) - Wednesday, 19 September 2007, 13:46 GMT
also, have you tried the newest xorg +everything in

[xorg]
http://kth5.telekommunisten.net/xorg/i686/

repo?

another thing is to try the newest ati git...
Comment by Corrado Primier (bardo) - Monday, 24 September 2007, 21:01 GMT
Ok, tried the newest Xorg release which is now in testing, including the 6.7.193 driver, and nothing changed. I'm going to check one last time on freedesktop's bugzilla and if don't find anything I'll file a new bug.
Comment by Corrado Primier (bardo) - Tuesday, 25 September 2007, 10:35 GMT
6.7.194 has been released, and it solves the problem. When it is updated the bug can be closed.
Comment by Alexander Baldeck (kth5) - Tuesday, 25 September 2007, 15:34 GMT
6.7.194 just hot testing. Please test:.

Comment by Corrado Primier (bardo) - Tuesday, 25 September 2007, 17:57 GMT
As I said, it works for me, and at the moment I'm the only one who still suffered from the problem, so if no one else has it I think it can be closed.

Loading...