Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#7864 - festival does not install the executables of the utilities provided by speech_tools

Attached to Project: Arch Linux
Opened by Ermanno Scaglione (erm67) - Tuesday, 21 August 2007, 15:48 GMT
Last edited by Allan McRae (Allan) - Saturday, 21 March 2009, 10:11 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version 2007.08 Don't Panic
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

The package for festival installs in /usr/bin only wrappers to the real binaries provided by speech_tools which are supposed to be in the '/usr/main' directory, the real executables are missing.
Recompiling from abs fails because the diff files included changes the definition of FESTIVAL_HOME and EST_HOME to a non-existing path, and the missing binaries are not installed anyway.

My solution:

Since the wrapper scripts are meant to add the correct path for the festival libraries but the PKGBUILD installs them in /usr/lib there is no point in having the scripts so I think the PKGBUILD should install the real binaries to /usr/bin for speech_tools like it does for festival. I modified and tested the package this way and it works. (I made it installed also festival_server, festival_server_control, text2wave and the man pages)
Attached modified diffs and PKGBUILD.

Additional info:
* package version: 1.96beta



Steps to reproduce:
execute one of the utilities provided by speech_tool, siod for example
This task depends upon

Closed by  Allan McRae (Allan)
Saturday, 21 March 2009, 10:11 GMT
Reason for closing:  Fixed
Additional comments about closing:  festival-1.96beta-2

Loading...