Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#78598 - [mesa] 23.1.0-1 AMD issues after update

Attached to Project: Arch Linux
Opened by Mariusz Smołka (Freyon77) - Wednesday, 24 May 2023, 18:45 GMT
Last edited by Toolybird (Toolybird) - Sunday, 28 May 2023, 07:56 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Laurent Carlier (lordheavy)
Felix Yan (felixonmars)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 13
Private No


Gnome is unusable after latest mesa update
Artifacts on screen / gray screen
R7 350 / ati radeon driver
Additional info:
* package version(s) 23.1.0-1
* config and/or log files etc.
* link to upstream bug report, if any

Steps to reproduce:

Update mesa and reboot
This task depends upon

Closed by  Toolybird (Toolybird)
Sunday, 28 May 2023, 07:56 GMT
Reason for closing:  Fixed
Additional comments about closing:  mesa 23.1.1-1. The original Radeon issue is fixed. If anyone not on Radeon is still experiencing problems with 23.1.1-1, please open a new ticket.
Comment by Mariusz Smołka (Freyon77) - Wednesday, 24 May 2023, 18:58 GMT
I have actually logged without isues on AMDGPU kernel driver. It looks like its only RADEON problem. Well in this case i can say a lot of SI GCN 1 cards will not work properly in arch
Comment by Andrew Munkres (amunkres) - Wednesday, 24 May 2023, 21:09 GMT
I am also having a problem running mesa version 23.1.0-1 on AMD graphics hardware, but **not** with the previous version (23.0.3-1).

Immediately after I ran a system-update 23.0.3-1 to 23.1.0-1, I logged out, and Plasma's ctrl+alt+del "logout screen" was glitched in a way that no text showed up... and then, upon returning to the X display manager after logout (the one I'm using is lightdm), it too displayed nothing but gray rectangles with no actual text visible. I then tried a full reboot, but the problem in lightdm was still happening. I then tried typing my password and pressing Return to log in, which resulted in a black screen, though I'm pretty sure that Plasma actually was running (because I switched to a text console and ran `ps axuf` to look for Plasma-related running processes).

So, then I downgraded to version 23.0.3-1 of mesa (and also mesa-vdpau) and used systemctl to restart lightdm, and this time it displayed the login screen correctly. This seems to indicate that a bug introduced in the new version of mesa is the cause of the problem.

The hardware that I was using when I ran into this problem was the Radeon R7 integrated GPU in an A10-7890K APU. In case it helps, here's the "extended renderer info" section of glxinfo's output when running on the old version of mesa:

Extended renderer info (GLX_MESA_query_renderer):
Vendor: AMD (0x1002)
Device: KAVERI (, LLVM 15.0.7, DRM 2.50, 6.3.3-arch1-1) (0x130f)
Version: 23.0.3
Accelerated: yes
Video memory: 1024MB
Unified memory: no
Preferred profile: core (0x1)
Max core profile version: 4.5
Max compat profile version: 4.5
Max GLES1 profile version: 1.1
Max GLES[23] profile version: 3.2
Comment by Marcel Langner (LanMarc77) - Wednesday, 24 May 2023, 21:28 GMT
I hit the same problem today. My system is a very old AMD E1-2100 with integrated Radeon HD Graphics card.
Comment by Toolybird (Toolybird) - Wednesday, 24 May 2023, 21:58 GMT
Dupes  FS#78597   FS#78629 
Comment by Jeremiah Putnam (j-putz) - Thursday, 25 May 2023, 01:53 GMT
Confirmed. AMD A8-6410 APU with AMD Radeon R5 Graphics. Works fine when I regress to 23.0.3-1
Comment by lanthanoid4k (lanthanoid4k) - Thursday, 25 May 2023, 06:04 GMT
Comment by Laurent Carlier (lordheavy) - Thursday, 25 May 2023, 06:14 GMT Comment by Jens G (Thah) - Thursday, 25 May 2023, 06:31 GMT
Confirmed. Bonaire XTX [Radeon R7 260X/360]
Comment by Toolybird (Toolybird) - Thursday, 25 May 2023, 06:57 GMT
Please! Any more empty "me too" posts will be deleted! Unless you have something useful to add, just use the "Add vote" button. Thank you.
Comment by maderios (maderios) - Thursday, 25 May 2023, 12:30 GMT
I got issue too with last mesa mesa 23.1.0-1 and Intel driver i915: opengl doesn't work with enlightenment -> E engine switch to 'software'
Downgrading to previous version 23.0.3-1 solved issue
Comment by Sidney Gerard Ephrim Skinner (sges) - Thursday, 25 May 2023, 16:15 GMT
Just to Confirm Problem on CPU: AMD PRO A8-8650B R7 4C+6G and Graphics (integrated) GPU: AMD ATI Radeon R7 Graphics
Comment by Sidney Gerard Ephrim Skinner (sges) - Thursday, 25 May 2023, 23:41 GMT
Upgrading to mesa 23.1.1-1 also works. Currently mesa 23.1.1-1 is only in the Extra-Testing repo which I did not wish to enable so I manually downloaded it from the Arch Package Archive
Comment by Martin (mahe29) - Friday, 26 May 2023, 15:48 GMT
I had the same issue as described here. I switched to amdgpu kernel driver (as described in si_support=1)
After a reboot i can now run with mesa 23.1 without problems! I had stuck to the radeon kernel driver for too long apparently. Turns out my Radeon 280X works better than ever with the amdgpu driver.
Comment by Marcel Langner (LanMarc77) - Friday, 26 May 2023, 19:19 GMT
@Martin, thank you, switching the kernel module also works for me.
Comment by Jens G (Thah) - Saturday, 27 May 2023, 08:05 GMT
Switched to amdgpu on current linux v6.3.4.arch1-1 and custom vanilla kernel 5.15.113. Both work with my cik (Sea Island) graphics card.

Unless the incomming mesa v23.1.1-1 solves this issue it might be good to add this to the ATI page in the Arch wiki?
Comment by Sidney Gerard Ephrim Skinner (sges) - Saturday, 27 May 2023, 11:36 GMT
In case my wording was not clear. mesa 23.1.1-1 solves the issue. It can be downloaded from the Arch Linux Archive at
Comment by maderios (maderios) - Saturday, 27 May 2023, 16:17 GMT
Upgrading to mesa 23.1.1-1 changes nothing for me (intel i915), i get same issue: opengl doesn't work with enlightenment. Staying with mesa 23.0.3-1 solves problem
Comment by John (graysky) - Saturday, 27 May 2023, 20:33 GMT
Additional context: kodi-gbm is unusable due to video corruption with Radeon GPU when running mesa 23.1.0-1. Downgrading to 23.0.3-1 solves fixes it.
Comment by Onur Basturk (obasturk) - Sunday, 28 May 2023, 05:56 GMT
CPU: AMD A8-7600 APU (Kaveri)
GPU: integrated (GCN2, Sea Islands)
Kernel module: radeon (default)

Upgrading mesa to 23.1.1-1 in the extra fixes the issue.
Comment by Trit' (trit) - Sunday, 28 May 2023, 07:37 GMT
Fixed for my AMD Radeon R7 240 too with 23.1.1. Thanks!