Community Packages

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#78533 - [python-flask-caching] [python-cachelib] incompatible versions

Attached to Project: Community Packages
Opened by Michal Wojdyla (micwoj92) - Tuesday, 16 May 2023, 18:16 GMT
Last edited by Antonio Rojas (arojas) - Tuesday, 16 May 2023, 21:42 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Antonio Rojas (arojas)
Levente Polyak (anthraxx)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No


Description: Due to changes in cachelib, flask-caching sets versions at "cachelib<0.10.0,>=0.9.0" which is incompatible as in repos cachelib is 0.10.2

Additional info:
* package version(s): python-flask-caching 2.0.2-2 python-cachelib 0.10.2-2
* config and/or log files etc: error when trying to run application that requires flask-caching:
Traceback (most recent call last):
File "/usr/lib/python3.11/site-packages/pkg_resources/", line 629, in _build_master
File "/usr/lib/python3.11/site-packages/pkg_resources/", line 966, in require
needed = self.resolve(parse_requirements(requirements))
File "/usr/lib/python3.11/site-packages/pkg_resources/", line 827, in resolve
dist = self._resolve_dist(
File "/usr/lib/python3.11/site-packages/pkg_resources/", line 873, in _resolve_dist
raise VersionConflict(dist, req).with_context(dependent_req)
pkg_resources.ContextualVersionConflict: (cachelib 0.10.2 (/usr/lib/python3.11/site-packages), Requirement.parse('cachelib<0.10.0,>=0.9.0'), {'Flask-Caching'})

* link to upstream bug report, if any

Steps to reproduce:
1. run application that requires flask caching (example pyload-ng)
2. be greeted with error

Alternative way:
1. get python-flask-caching pkgbuild from ask
2. run makepkg
3. error

"==> Starting check()...
running pytest
/usr/lib/python3.11/site-packages/setuptools/command/ _DeprecatedInstaller: setuptools.installer and fetch_build_eggs are deprecated.

Requirements should be satisfied by a PEP 517 installer.
If you are using pip, you can try `pip install --use-pep517`.

ir_d = dist.fetch_build_eggs(dist.install_requires)
WARNING: The wheel package is not available.
/usr/bin/python: No module named pip
error: Command '['/usr/bin/python', '-m', 'pip', '--disable-pip-version-check', 'wheel', '--no-deps', '-w', '/tmp/tmppr1ikwj7', '--quiet', 'cachelib<0.10.0,>=0.9.0']' returned non-zero exit status 1.

This task depends upon

Closed by  Antonio Rojas (arojas)
Tuesday, 16 May 2023, 21:42 GMT
Reason for closing:  Fixed
Additional comments about closing:  python-flask-caching 2.0.2-3