FS#78407 - [gnome-shell] libnma dep needs to be replaced by libnma-gtk4

Attached to Project: Arch Linux
Opened by Dev S (dev) - Thursday, 04 May 2023, 21:39 GMT
Last edited by Jan Alexander Steffens (heftig) - Friday, 05 May 2023, 11:35 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

gnome-shell now needs libnma4. See:

Update to drop GTK3 dependency
https://gitlab.gnome.org/GNOME/gnome-shell/-/commit/656efd33afb25ab66989a5cfe14cca6ce94bb1a4


Additional info:

* package version(s)
44.1-2

* config and/or log files etc.

JS ERROR: Error: Requiring NMA4, version 1.0: Typelib file for namespace 'NMA4', version '1.0' not found
@resource:///org/gnome/shell/misc/modemManager.js:4:34
@resource:///org/gnome/shell/ui/status/network.js:8:22
_init@resource:///org/gnome/shell/ui/panel.js:348:13
ButtonBox@resource:///org/gnome/shell/ui/panelMenu.js:11:1
PanelMenuButton@resource:///org/gnome/shell/ui/panelMenu.js:97:4
QuickSettings@resource:///org/gnome/shell/ui/panel.js:336:1
_ensureIndicator@resource:///org/gnome/shell/ui/panel.js:677:25
_updateBox@resource:///org/gnome/shell/ui/panel.js:688:34
_updatePanel@resource:///org/gnome/shell/ui/panel.js:642:14
_init@resource:///org/gnome/shell/ui/panel.js:466:14
Panel@resource:///org/gnome/shell/ui/panel.js:427:1
_initializeUI@resource:///org/gnome/shell/ui/main.js:250:13
start@resource:///org/gnome/shell/ui/main.js:186:5
@resource:///org/gnome/shell/ui/init.js:6:17


Steps to reproduce:

install gnome-shell (but not also gnome-control-center) and start it
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Friday, 05 May 2023, 11:35 GMT
Reason for closing:  Fixed
Additional comments about closing:  44.1-3

Loading...