FS#78405 - [faust] a header is missing in faust/dsp/dsp.h

Attached to Project: Community Packages
Opened by Simon Archipoff (lligna) - Thursday, 04 May 2023, 19:41 GMT
Last edited by David Runge (dvzrv) - Thursday, 04 May 2023, 21:23 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To David Runge (dvzrv)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Hello, I have a little problem with faust package in arch, an upgrade should be enough to fix it.

Description:
The problem is in community/faust 2.54.9-2

This is fixed upstream in commit :
> commit 2560b69377edf0664a8338b2c75f70032a48f054
> Author: Stephane Letz <letz@grame.fr>
> Date: Wed Mar 22 15:53:44 2023 +0100


Steps to reproduce:
Try to compile this in a cpp file :
#include "/usr/include/faust/dsp/dsp.h"

it gives :

In file included from /tmp/foo.cpp:1:
/usr/include/faust/dsp/dsp.h:247:9: error: 'intptr_t' does not name a type
247 | intptr_t fpsr = 0;
| ^~~~~~~~
/usr/include/faust/dsp/dsp.h:241:1: note: 'intptr_t' is defined in header '<cstdint>'; did you forget to '#include <cstdint>'?
240 | #include <xmmintrin.h>
+++ |+#include <cstdint>
241 | #endif

This task depends upon

Closed by  David Runge (dvzrv)
Thursday, 04 May 2023, 21:23 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed with 2.54.9-3
Comment by David Runge (dvzrv) - Thursday, 04 May 2023, 21:10 GMT
@lligna thanks for the ticket. Will have a look

Loading...