Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#78261 - [openmpi] incompatibility with openpmix 4.2.3

Attached to Project: Arch Linux
Opened by Jakub Klinkovsk√Ĺ (lahwaacz) - Wednesday, 19 April 2023, 13:38 GMT
Last edited by David Runge (dvzrv) - Tuesday, 23 May 2023, 18:26 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To David Runge (dvzrv)
Levente Polyak (anthraxx)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

openmpi 4.1.5 is not compatible with openpmix 4.2.3, which leads to bugs like https://github.com/open-mpi/ompi/issues/10416

There is an unfinished patch at https://github.com/open-mpi/ompi/pull/11472 but it did not lead anywhere for over a month.

The official recommendation seems to be downgrading openpmix or using the version bundled in the openmpi project, see https://github.com/open-mpi/ompi/issues/10416#issuecomment-1514731728
This task depends upon

Closed by  David Runge (dvzrv)
Tuesday, 23 May 2023, 18:26 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed with openmpi 4.1.5-2
Comment by David Runge (dvzrv) - Tuesday, 23 May 2023, 18:03 GMT
@lahwaacz: Thanks for the report and sorry for the long delay.

I have applied the fix from the mentioned PR in 4.1.5-2 in [extra-testing]. Please let me know if this fixes it for you.
Comment by David Runge (dvzrv) - Tuesday, 23 May 2023, 18:25 GMT
(Confirmed working via IRC)

Loading...