FS#78122 - [blueprint-compiler] not working while git version does

Attached to Project: Community Packages
Opened by Paulo Fino (somepaulo) - Wednesday, 05 April 2023, 09:54 GMT
Last edited by Antonio Rojas (arojas) - Thursday, 27 April 2023, 17:04 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No


`blueprint-compiler` from the `Community` repo fails to run batch-compile command with no error or log message. It just throws its regular message as if run with no parameters:

Generating data/resources/blueprints with a custom command
usage: blueprint-compiler [-h] [--version] command ...

positional arguments:
compile Compile blueprint files
Compile many blueprint files at once
port Interactive porting tool
lsp Run the language server (for internal use by IDEs)
help Show this message

optional arguments:
-h, --help show this help message and exit
--version show program's version number and exit

This makes it impossible to build apps that rely on `blueprint-compiler`, like `converter` (https://aur.archlinux.org/packages/converter) or `dialect` (https://aur.archlinux.org/packages/dialect).
Installing `blueprint-compiler-git` from the AUR solves this.
I haven't found any information on this anywhere except a report of the same error on the `wayfarer-git` package in the AUR (https://aur.archlinux.org/packages/wayfarer-git).

Additional info:
* package version(s) - 0.6.0
* config and/or log files etc. - none/default
* link to upstream bug report, if any - none

Steps to reproduce:
1. Make sure `blueprint-compiler` is installed on your system.
2. Try installing `dialect` or `converter` or `wayfarer-git` from the AUR.
3. When the build script comes to the `blueprint-compiler` command you get its default output, as if run with no parameters, followed by a build error. (Running the command from the build script directly in the correct build folder yields the same result).
4. Replace `blueprint-compiler` with `blueprint-compiler-git` from the AUR.
5. Try installing `dialect` or `converter` or `wayfarer-git` from the AUR again.
6. The app builds and installs as expected.
This task depends upon

Closed by  Antonio Rojas (arojas)
Thursday, 27 April 2023, 17:04 GMT
Reason for closing:  Works for me
Additional comments about closing:  No other reports about this, it seems to be some local issue on your system.
Comment by Paulo Fino (somepaulo) - Wednesday, 05 April 2023, 12:18 GMT
Please move to Community Packages. Accidentally posted into Arch Linux.
Comment by Toolybird (Toolybird) - Wednesday, 05 April 2023, 22:31 GMT
Orphaned pkg (i.e. no maintainer). Please see  FS#76538  for additional context. We might be SOL unless someone picks it up.
Comment by Paulo Fino (somepaulo) - Thursday, 06 April 2023, 13:37 GMT
@Toolybird It seems like @arojas closed the  FS#76538  issue as fixed 2 weeks after your comment, and he's still listed as the packager for [blueprint-compiler]. Has he actually abandoned the package?
Does it have to be one of the Arch devs to pick it up or can it be any member of the community?
Comment by Antonio Rojas (arojas) - Thursday, 27 April 2023, 17:01 GMT
Can't reproduce. Both dialect and converter build fine here.