Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#7809 - FTP installation failure

Attached to Project: Arch Linux
Opened by Greg (dolby) - Monday, 13 August 2007, 18:06 GMT
Last edited by Tobias Powalowski (tpowa) - Saturday, 08 September 2007, 21:07 GMT
Task Type Bug Report
Category Installation
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture i686
Severity Critical
Priority Normal
Reported Version 2007.08 Don't Panic
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

The archlinux FTP installation fails due to the fact that im not able to dowmload anything with a decent speed.
packages.txt is 18kb and downloads in ~100 sec if youre lucky. No matter which server i use the speed is pathetic.
If it manages to download pacman (after a long long time) it fails right after when it tries to fetch the packages.

Additional info:

My NIC is an ADMtek NC100 Network Everywhere Fast Ethernet 10/100 and uses the tulip module, I dont use DHCP but define my IP address, gateway, DNS etc. manually, i dont use any proxy stuff and im sure the settings are correct.

Steps to reproduce:

insert Archlinux Don't Panic FTP installation CD, enter shell , execute /arch/setup choose FTP/HTTP installation, Configure Network, Choose NIC, dont use DHCP, enter IP address (i use 192.168.1.2), network mask (default), broadcast (default), gateway (192.168.1.1) and DNS. partition hd's, set mountpoints, select packages, choose server ( i tried more than 10 ). sometimes (rarely) it reaches the point where u are about to select packages right after downloading pacman but fails right after that
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Saturday, 08 September 2007, 21:07 GMT
Reason for closing:  Works for me
Comment by Aaron Griffin (phrakture) - Monday, 13 August 2007, 18:22 GMT
I'd venture a guess this is network module related - tpowa, do we have any patches related to this NIC, or are there any that you know of?
Comment by Tobias Powalowski (tpowa) - Monday, 13 August 2007, 18:49 GMT
i don't think we have a patch regarding network modules, last time with .21 we had some patches but with .22 they were all gone
Comment by Greg (dolby) - Monday, 13 August 2007, 19:15 GMT
what i find even weirder is that with the Duke FTP ISO i could download and install normally but i couldnt see the output of the packages downloading in tty5 and it failed to generate locale. afaik the last one was an issue only on the Linuxtag ISO. & i had installed using a Duke FTP ISO at least 2 times in the same PC in the past without having those problems. anyway thats not too important now but just wanted to share it.
i used 4 different FTP ISO's during the last week and the only one that installed without any problems whatsoever was the 0.8 one. Duke had the above, Linuxtag only the locale failure and Don't Panic what i explained in the bug report..
Comment by Tobias Powalowski (tpowa) - Monday, 13 August 2007, 19:22 GMT
sounds like a kernel bug older isos used .21 kernel
Comment by Roman Kyrylych (Romashka) - Tuesday, 14 August 2007, 11:06 GMT
well, could you install from Duke ISO, then upgrade kernel and after rebooting try to download something. This way we can be sure that this is a bug in .22.
Comment by Greg (dolby) - Tuesday, 14 August 2007, 11:49 GMT
im not 100% sure if thats what u mean Romanska but i have a working Arch installation on that pc...running a 2.6.22 kernel...and it works just fine obiously
Comment by Roman Kyrylych (Romashka) - Tuesday, 14 August 2007, 12:20 GMT
then this is weird that it works good except the installation time... :-/
this is weird too: "sometimes (rarely) it reaches the point where u are about to select packages right after downloading pacman but fails right after that"
Comment by Tobias Powalowski (tpowa) - Saturday, 08 September 2007, 21:06 GMT
im closing this now with works for me difficult to say what went wrong here.

Loading...