Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#78006 - [qt6-tools] crash with SIGSEGV due to LTO/PIE

Attached to Project: Arch Linux
Opened by Jannis L├╝bke (Janrupf) - Sunday, 26 March 2023, 18:10 GMT
Last edited by Antonio Rojas (arojas) - Monday, 27 March 2023, 11:50 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Antonio Rojas (arojas)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
All applications from the qt6-tools package crash with a segmentation fault.

Additional info:
* package version: 6.4.3-1
* Wireshark bug report which has the same issue: https://gitlab.com/wireshark/wireshark/-/issues/17040

This seems to be an issue since Qt5, the Wireshark bug report actually mentions Qt5. I have confirmed that the exact same is true for Qt6.

Steps to reproduce:
* Install qt6-tools
* run `designer6`

Alternative reproduction ways can be found in the wireshark issue report. Compiling a Qt program with -lto -pie -fPIE causes this issue.

The following backtrace is generated when using gdb:

#0 doActivate<false> (sender=0x0, signal_index=9, argv=0x7fffffffc990) at /usr/src/debug/qt6-base/qtbase-everywhere-src-6.4.3/src/corelib/kernel/qobject.cpp:3861
#1 0x00007ffff659db87 in QGuiApplication::screenAdded (this=<optimized out>, _t1=<optimized out>) at /usr/src/debug/qt6-base/build/src/gui/Gui_autogen/include/moc_qguiapplication.cpp:485
#2 0x00007ffff65fc0d3 in QWindowSystemInterface::handleScreenAdded (ps=<optimized out>, isPrimary=<optimized out>)
at /usr/src/debug/qt6-base/qtbase-everywhere-src-6.4.3/src/gui/kernel/qwindowsysteminterface.cpp:762
#3 0x00007ffff27ead66 in QXcbConnection::initializeScreens (this=0x555555617aa0, initialized=<optimized out>)
at /usr/src/debug/qt6-base/qtbase-everywhere-src-6.4.3/src/plugins/platforms/xcb/qxcbconnection_screens.cpp:347
#4 0x00007ffff27dc1d2 in QXcbConnection::QXcbConnection (this=<optimized out>, nativeInterface=<optimized out>, canGrabServer=<optimized out>, defaultVisualId=<optimized out>, displayName=<optimized out>,
this=<optimized out>, nativeInterface=<optimized out>, canGrabServer=<optimized out>, defaultVisualId=<optimized out>, displayName=<optimized out>)
at /usr/src/debug/qt6-base/qtbase-everywhere-src-6.4.3/src/plugins/platforms/xcb/qxcbconnection.cpp:72
#5 0x00007ffff2806008 in QXcbIntegration::QXcbIntegration (this=<optimized out>, parameters=..., argc=<optimized out>, argv=<optimized out>, this=<optimized out>, parameters=..., argc=<optimized out>,
argv=<optimized out>) at /usr/src/debug/qt6-base/build/include/QtCore/../../../qtbase-everywhere-src-6.4.3/src/corelib/tools/qscopedpointer.h:104
#6 0x00007ffff4e8b353 in QXcbIntegrationPlugin::create (this=<optimized out>, system=..., parameters=..., argc=@0x7fffffffd2fc: 1, argv=0x7fffffffd658)
at /usr/src/debug/qt6-base/qtbase-everywhere-src-6.4.3/src/plugins/platforms/xcb/qxcbmain.cpp:22
#7 0x00007ffff6596353 in init_platform (argv=<optimized out>, argc=@0x7fffffffd2fc: 1, platformThemeName=..., platformPluginPath=..., pluginNamesWithArguments=...)
at /usr/src/debug/qt6-base/qtbase-everywhere-src-6.4.3/src/gui/kernel/qguiapplication.cpp:1192
#8 QGuiApplicationPrivate::createPlatformIntegration (this=0x555555604870) at /usr/src/debug/qt6-base/qtbase-everywhere-src-6.4.3/src/gui/kernel/qguiapplication.cpp:1472
#9 0x00007ffff6597a09 in QGuiApplicationPrivate::createEventDispatcher (this=<optimized out>) at /usr/src/debug/qt6-base/qtbase-everywhere-src-6.4.3/src/gui/kernel/qguiapplication.cpp:1489
#10 0x00007ffff5f2fb4c in QCoreApplicationPrivate::init (this=this@entry=0x555555604870) at /usr/src/debug/qt6-base/qtbase-everywhere-src-6.4.3/src/corelib/kernel/qcoreapplication.cpp:814
#11 0x00007ffff6597a91 in QGuiApplicationPrivate::init (this=this@entry=0x555555604870) at /usr/src/debug/qt6-base/qtbase-everywhere-src-6.4.3/src/gui/kernel/qguiapplication.cpp:1513
#12 0x00007ffff6d6c92e in QApplicationPrivate::init (this=0x555555604870) at /usr/src/debug/qt6-base/qtbase-everywhere-src-6.4.3/src/widgets/kernel/qapplication.cpp:462
#13 0x00007ffff6d6ca52 in QApplication::QApplication (this=<optimized out>, argc=<optimized out>, argv=<optimized out>, this=<optimized out>, argc=<optimized out>, argv=<optimized out>)
at /usr/src/debug/qt6-base/qtbase-everywhere-src-6.4.3/src/widgets/kernel/qapplication.cpp:450
#14 0x000055555557566a in QDesigner::QDesigner (argv=<optimized out>, argc=@0x7fffffffd2fc: 1, this=0x7fffffffd480)
at /usr/src/debug/qt6-tools/qttools-everywhere-src-6.4.3/src/designer/src/designer/qdesigner.cpp:56
#15 main (argc=<optimized out>, argv=<optimized out>) at /usr/src/debug/qt6-tools/qttools-everywhere-src-6.4.3/src/designer/src/designer/main.cpp:28

This task depends upon

Closed by  Antonio Rojas (arojas)
Monday, 27 March 2023, 11:50 GMT
Reason for closing:  Fixed
Additional comments about closing:  qt6-tools 6.4.3-2
Comment by Antonio Rojas (arojas) - Monday, 27 March 2023, 11:41 GMT
Looks like a GCC bug. Building with clang works fine.

Loading...