Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#7770 - GRUB: savedefault results in "Error 15: File not found"

Attached to Project: Arch Linux
Opened by Martin Skytte (marteus) - Friday, 10 August 2007, 09:45 GMT
Last edited by Andreas Radke (AndyRTR) - Friday, 24 August 2007, 05:08 GMT
Task Type Bug Report
Category Packages: Current
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture All
Severity Medium
Priority Normal
Reported Version 2007.08 Don't Panic
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
Adding savedefault to boot command in grub results in boot error "file not found". (and hence the boot default is not saved for next boot)

It seems that /boot/grub/default is not created at install and GRUB seems unable to create it.

I have solved this on my box by calling "grub-set-default 0" once.

Additional info:
Old thread about the same issue: http://bbs.archlinux.org/viewtopic.php?id=24323

* package version(s)
* config and/or log files etc.

This config does not work before calling grub-set-default:
# Config file for GRUB - The GNU GRand Unified Bootloader
# /boot/grub/menu.lst

# general configuration:
timeout 5
default saved
color light-blue/black light-cyan/blue

# (0) Arch Linux
title Arch Linux
root (hd0,1)
kernel /boot/vmlinuz26 root=/dev/sda2 ro quiet vga=795
initrd /boot/kernel26.img
savedefault

# (1) Arch Linux
title Arch Linux Fallback
root (hd0,1)
kernel /boot/vmlinuz26 root=/dev/sda2 ro
initrd /boot/kernel26-fallback.img

# (1) Windows
title Windows Vista
rootnoverify (hd0,0)
makeactive
chainloader +1
savedefault
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Friday, 24 August 2007, 05:08 GMT
Reason for closing:  Won't implement
Comment by Jason Carr (jason2) - Wednesday, 22 August 2007, 06:04 GMT
I also have this issue. It looks like the default file in /boot/grub/ needs to exist.
Comment by Andreas Radke (AndyRTR) - Friday, 24 August 2007, 05:07 GMT
it's not a bug. it's the behavior documented here well: http://www.gnu.org/software/grub/manual/html_node/Invoking-grub_002dset_002ddefault.html#Invoking-grub_002dset_002ddefault

"savedefault" is an additional feature. we usually ship packages in the default configuration. because we will also only provide one official kernel pkg in the future there's no need to change the grub pkg. users might do it their own.

Loading...