FS#77462 - [chromium] Incorrect double-click word highlight behavior

Attached to Project: Arch Linux
Opened by Diana (DianaNites) - Saturday, 11 February 2023, 19:55 GMT
Last edited by Evangelos Foutras (foutrelis) - Sunday, 12 February 2023, 07:50 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Evangelos Foutras (foutrelis)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

Chromium exhibits double-click highlight behavior on words containing ".", treating it as part of the word instead of a separator, as compared to every other browser and everywhere else in the system.

For browsers, I specifically checked google-chrome from AUR, firefox, and opera, all of which exhibit the correct and expected behavior.

For system applications, I checked KDE Dolphin, KDE Kate, and GNOME Gedit, all of which have the correct and expected behavior.

This occurs in all text selections, including content on the web, and URLs in the address bar.

This is a significant usability regression for me, having switched to chromium from google-chrome. I use this regularly, and it works correctly literally *everywhere else* I use it, every other browser, every other application.

I believe this is caused by it using the system ICU, which per this comment https://bugs.chromium.org/p/chromium/issues/detail?id=1410331#c19 on a similar but unrelated upstream bug report chromium has patches for this, which are not being used here.

Further digging reveals this commit https://github.com/archlinux/svntogit-packages/commit/a0b214b3bdfbc7ee3d9004a70494a2b9e3da2c80 which suggests this is also a recent regression in Arch specifically.

Additional info:
* package version(s)
Chromium and google-chrome(AUR) 110.0.5481.77-1
Firefox 109.0.1-1
Opera 95.0.4635.37-1

Steps to reproduce:

1. Go to "archlinux.org", or type it in any text box
2. Double click on the word "archlinux"
3. "archlinux.org" is incorrectly selected

Repeat in any other application to observe correct behavior
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Sunday, 12 February 2023, 07:50 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#58161 
Comment by Evangelos Foutras (foutrelis) - Sunday, 12 February 2023, 07:50 GMT
Other than switching to the bundled ICU, there is not obvious (to me) way to fix this.

See https://crbug.com/827794#c6 and  FS#58161 .

Loading...