Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#7743 - Flash plugin hangs afrer GTK2 upgrade

Attached to Project: Arch Linux
Opened by Ondřej Konečný (andrew9888) - Sunday, 05 August 2007, 16:48 GMT
Last edited by Jan de Groot (JGC) - Sunday, 05 August 2007, 22:12 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture i686
Severity Critical
Priority Normal
Reported Version 2007.05 Duke
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:

After upgrade of the GTK2 package to version 2.10.14-1 the flashplugin hangs making the browser impossible to use.
I have tested it in Konqueror and Opera and both browsers hung.

Additional info:

kdebase-3.5.7-1
opera-9.22-1
flashplugin-9.0.48.0-1
gtk2-2.10.14-1

Steps to reproduce:

Visit any site with flash ads.
This task depends upon

Closed by  Jan de Groot (JGC)
Sunday, 05 August 2007, 22:12 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed with gtk2 2.10.14-2.
Comment by Jan de Groot (JGC) - Sunday, 05 August 2007, 19:23 GMT
Please give some information about the used GTK theme, the environment you use it in (KDE or GTK), and if you're using a compositing manager or EXA. I can't reproduce it on my laptop which runs GNOME.
Comment by Darío A. (darzephyr) - Sunday, 05 August 2007, 19:24 GMT
I can confirm this, opera hangs loading a page with a flash animation; then it only show a grey rectangle without any contextual menu. Manually downgrade to gtk2-2.10.13 seems to solve this issue.
Comment by Ondřej Konečný (andrew9888) - Sunday, 05 August 2007, 19:50 GMT
I use KDE with QtCurve theme. The QtCurve theme is set in GTK2, too. (qtcurve-kde3-0.52.3-1, qtcurve-gtk2-0.52.3-1) I don't use any compositing manager, just pure kwin.
Comment by Jan de Groot (JGC) - Sunday, 05 August 2007, 19:59 GMT
Found out the OpenOffice part of this bug is caused by invalid initialisation of GTK in openoffice when operating in KDE UI mode. I think this is also true for flash when running under opera (Opera isn't a GTK browser). I think I found the commit that causes the freeze. When running strace on openoffice when this happens it shows no action, which looks like a deadlock to me. There's a commit that sets some lock/unlock statements in the latest version of GTK, so reverting that one should do it.

Loading...