Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#77313 - Make arduino packages depend on avr-gcc <= 10.1.0 instead of >= 12

Attached to Project: Arch Linux
Opened by Delete this user account, please (User99627) - Sunday, 29 January 2023, 12:30 GMT
Last edited by Toolybird (Toolybird) - Monday, 30 January 2023, 05:00 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

There is a serious, critical regression in AVR-gcc versions 11 and above (see https://gcc.gnu.org/bugzilla/show_bug.cgi?id=105753). Versions up to 10.1.0 are not affected. The regression (randomly) prevents from compiling Arduino sketches but also local AVR-based projects, as the compiler crashes with an internal error, as described in the supplied link.

The bug has been left unfixed for about one year and is a real showstopper. A possible solution would be to cap avr-gcc to version 10.1.0 but it requires packaging that version instead of 12.x.y and updating all packages that depend on it.

Can it be done?

Thanks in advance.
This task depends upon

Closed by  Toolybird (Toolybird)
Monday, 30 January 2023, 05:00 GMT
Reason for closing:  Upstream
Comment by Toolybird (Toolybird) - Monday, 30 January 2023, 05:00 GMT
> Can it be done?

Not going to happen. That's not how Arch works. It's *clearly* an upstream issue and needs to be fixed there.

Loading...