Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#7727 - vi syntax highlighting broken

Attached to Project: Arch Linux
Opened by Tobias Powalowski (tpowa) - Thursday, 02 August 2007, 16:04 GMT
Last edited by Tobias Powalowski (tpowa) - Monday, 20 August 2007, 11:27 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Tobias Kieslich (tobias)
Architecture All
Severity High
Priority Normal
Reported Version 2007.05 Duke
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Since new vi in testing no syntax highlighting is working anymore, using vim solves this.

Additional info:
* package version(s)
* config and/or log files etc.


Steps to reproduce:
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Monday, 20 August 2007, 11:27 GMT
Reason for closing:  Fixed
Comment by solsTiCe (zebul666) - Monday, 13 August 2007, 12:53 GMT
that's not a bug.
if vi binary is supposed to follow the original vi in its behavior. then vi never had syntax highliting and only vim got it.

if you run vim you got syntax highliting.

you will need to make an alias vi='vim' if you are like, liking to type vi instead of vim

Loading...