Community Packages

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#77258 - [element-desktop] crashes with error

Attached to Project: Community Packages
Opened by iamak (iamak) - Wednesday, 25 January 2023, 14:54 GMT
Last edited by Toolybird (Toolybird) - Wednesday, 01 February 2023, 05:36 GMT
Task Type Bug Report
Category Packages
Status Assigned
Assigned To Bruno Pagani (ArchangeGabriel)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 5
Private No


Application crashes after in a few minutes after opening.

Additional info:
package version(s): 1.11.20-1 (latest)
link to upstream bug report: [It was closed because they thought it is a packaging issue.](

Log I got from running `element-desktop > error.log`
/home/<user>/.config/Element exists: yes
/home/<user>/.config/Riot exists: no
No update_base_url is defined: auto update is disabled
Fetching translation json for locale: en_EN
Changing application language to en
Fetching translation json for locale: en
Resetting the UI components after locale change
Resetting the UI components after locale change
Changing application language to en
Fetching translation json for locale: en
Resetting the UI components after locale change
Error getting the event index passphrase out of the secret store [Error: The name org.freedesktop.secrets was not provided by any .service files]

Steps to reproduce:
Open the application and wait for a while.

Things I tried to fix this:
Installed the `keepassxc` package and enabled it's "Secret service integration" which creates a service for `org.freedesktop.secrets`.
This task depends upon

Comment by Toolybird (Toolybird) - Wednesday, 25 January 2023, 21:53 GMT
In a fresh VM I see the same "org.freedesktop.secrets" error upon launch, but the app doesn't crash. That leads me to believe this "secret" thing is a red herring and not the true cause of your crash.

You'll need to provide more details about the "crash". Anything in the journal? Does coredumpctl report anything?
Comment by edwargix (edwargix) - Saturday, 28 January 2023, 19:52 GMT Comment by Tamwyn (Tamwyn) - Monday, 30 January 2023, 13:34 GMT
Having a similar behaviour here with element crashing with a sigtrap a few seconds after starting.

I attached the stacktrace of the associated coredump. If I understood correctly the actual coredump would also contain the encryption keys?
Comment by Toolybird (Toolybird) - Tuesday, 31 January 2023, 05:46 GMT
You'll need to provide a backtrace with debug symbols [1]. Actual coredump files are awkward to use and not necessary anyway.

Comment by Tamwyn (Tamwyn) - Tuesday, 31 January 2023, 14:14 GMT
Alright, sorry about that. This time with the backtrace from gdb.
Comment by Mark (marcool) - Friday, 03 February 2023, 10:24 GMT
Another backtrace here, from a similar crash with SDDM and KDE Plasma on X11:

pacman -Qi element-desktop
Name : element-desktop
Version : 1.11.20-1
Description : Glossy Matrix collaboration client — desktop version.
Architecture : x86_64
Licenses : Apache
Groups : None
Provides : None
Depends On : element-web=1.11.20 electron22 libsecret
Optional Deps : None
Required By : None
Optional For : None
Conflicts With : None
Replaces : riot-desktop
Installed Size : 10,22 MiB
Packager : Bruno Pagani <>
Build Date : sam. 21 janv. 2023 07:54:44
Install Date : mar. 24 janv. 2023 16:02:55
Install Reason : Explicitly installed
Install Script : No
Validated By : Signature

pacman -Qi electron
Name : electron
Version : 22.0.3-1
Description : Build cross platform desktop apps with web technologies
Architecture : x86_64
Licenses : MIT custom
Groups : None
Provides : electron22
Depends On : c-ares gtk3 libevent nss wayland fontconfig woff2 aom brotli libjpeg icu dav1d flac snappy libxml2 ffmpeg libwebp
minizip opus harfbuzz re2 libavif jsoncpp libxslt libpng freetype2
Optional Deps : kde-cli-tools: file deletion support (kioclient5) [installed]
libappindicator-gtk3: StatusNotifierItem support
pipewire: WebRTC desktop sharing under Wayland [installed]
qt5-base: enable Qt5 with --enable-features=AllowQt [installed]
trash-cli: file deletion support (trash-put) [installed]
xdg-utils: open URLs with desktop’s default (xdg-email, xdg-open) [installed]
Required By : element-desktop
Optional For : None
Conflicts With : electron22
Replaces : None
Installed Size : 198,42 MiB
Packager : Bruno Pagani <>
Build Date : jeu. 19 janv. 2023 00:27:47
Install Date : mar. 24 janv. 2023 16:02:55
Install Reason : Installed as a dependency for another package
Install Script : No
Validated By : Signature

pacman -Qi plasma-desktop
Name : plasma-desktop
Version : 5.26.5-1
Description : KDE Plasma Desktop
Architecture : x86_64
Licenses : LGPL
Groups : plasma
Provides : None
Depends On : gawk kdelibs4support polkit-kde-agent kmenuedit systemsettings baloo xdg-user-dirs libibus
Optional Deps : plasma-nm: Network manager applet [installed]
powerdevil: power management, suspend and hibernate support [installed]
kscreen: screen management [installed]
ibus: kimpanel IBUS support
scim: kimpanel SCIM support
kaccounts-integration: OpenDesktop integration plugin [installed]
packagekit-qt5: to install new krunner plugins [installed]
Required By : None
Optional For : None
Conflicts With : None
Replaces : None
Installed Size : 23,02 MiB
Packager : Antonio Rojas <>
Build Date : mar. 03 janv. 2023 21:28:02
Install Date : jeu. 05 janv. 2023 21:59:54
Install Reason : Explicitly installed
Install Script : No
Validated By : Signature

uname -a
Linux t480 6.1.7-arch1-1 #1 SMP PREEMPT_DYNAMIC Wed, 18 Jan 2023 19:54:38 +0000 x86_64 GNU/Linux
Comment by Iyan (iyanmv) - Friday, 03 February 2023, 12:35 GMT
I can reliable always crash the app without waiting by maximizing the window at any point. This started to happen with version element-desktop-1.11.17-1 (exactly same issue with element-desktop-1.11.20-1), but it doesn't crash at all with element-desktop-1.11.15-1.
Comment by Benjamin (iamthemask) - Wednesday, 29 March 2023, 18:00 GMT
I get the same sigtrap crash on element-desktop-1.11.26-1 within seconds of launching. Downgrading to 1.11.20-1 seemed to fix the issue. On 6.2.8-arch1-1, running Sway.

Edit (11 Apr 2023): After a lot of other stuff updating, I tried updating Element again and it worked this time.
Comment by Iyan (iyanmv) - Thursday, 30 March 2023, 21:21 GMT
This seems like a packaging issue. As mentioned upstream by several people, I also cannot reproduce this issue on Debian (also running Wayland) with the official package.
Comment by Tamwyn (Tamwyn) - Friday, 31 March 2023, 00:41 GMT
Under sway/wayland the issue also doesn't occur for me.