FS#77146 - [grub] 2:2.06.r403.g7259d55ff-1 Performance regression

Attached to Project: Arch Linux
Opened by Sandor Fodor (AlexC) - Sunday, 15 January 2023, 18:36 GMT
Last edited by Christian Hesse (eworm) - Tuesday, 17 January 2023, 09:15 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Christian Hesse (eworm)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No



Load times are way longer than it suppose to be:

Startup finished in 14.258s (firmware) + 41.448s (loader) + 3.217s (kernel) + 3.671s (userspace) = 1min 2.595s

Grub just loads the compressed image files very slow compared with older version.

Problem is already solved upstream, I compiled from source:

Startup finished in 16.321s (firmware) + 666ms (loader) + 1.529s (kernel) + 3.225s (userspace) = 21.743s

Arch repository version: 2:2.06.r403.g7259d55ff-1
Upstream git version: 2.06.r415.g1a241e050-1

Also downgraded to r380.g151467888-1 and the load times were normal there as well.
This task depends upon

Closed by  Christian Hesse (eworm)
Tuesday, 17 January 2023, 09:15 GMT
Reason for closing:  Fixed
Additional comments about closing:  grub 2:2.06.r415.g1a241e050-1
Comment by Toolybird (Toolybird) - Sunday, 15 January 2023, 21:15 GMT
Interesting. It's unclear which of the 12 upstream commits would affect load times. There is probably something else going on here. When you "compiled from source" did you use standard Arch PKGBUILD and build in a clean chroot?
Comment by Sandor Fodor (AlexC) - Sunday, 15 January 2023, 21:18 GMT
I did just installed grub-git from the AUR with paru, nothing else added. And also grub-install and grub-mkconfig to actually upgrade.
Comment by Toolybird (Toolybird) - Sunday, 15 January 2023, 21:45 GMT
> grub-git from the AUR

Ok, there are quite a few differences between that one and the official PKGBUILD so your assertion that "Problem is already solved upstream" is possibly not accurate. Hopefully the PM has some insight into what might possibly be causing this.
Comment by Sandor Fodor (AlexC) - Sunday, 15 January 2023, 21:53 GMT
Okay, but as I said, when I downgraded to r380 from the Arch repos, it was working fine as well. Maybe this is a very edge case, but over on IRC the guys suggested to go for a bug report if possible.
Comment by Christian Hesse (eworm) - Monday, 16 January 2023, 13:27 GMT
Please try grub 2:2.06.r415.g1a241e050-1 from testing to verify...
Comment by Sandor Fodor (AlexC) - Monday, 16 January 2023, 20:22 GMT
Seems to be okay I should say, way better than before. Purged grub-git, installed grub from the testing repo, and installed with grub-install and grub-mkconfig:

Startup finished in 9.820s (firmware) + 5.276s (loader) + 2.208s (kernel) + 3.054s (userspace) = 20.359s

Here, assuming I have early KMS nvidia modules in the initramfs, taking a little longer, but way better.

╭─alexc@sasuke ~
╰─$ sudo pacman -Qs grub
local/grub 2:2.06.r415.g1a241e050-1