Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#7714 - rc.sysinit: 3 tries for non-root encrypted partitions before giving up

Attached to Project: Arch Linux
Opened by Jonathan Frazier (wide-eye) - Monday, 30 July 2007, 19:26 GMT
Last edited by Thomas Bächler (brain0) - Sunday, 21 October 2007, 09:11 GMT
Task Type Feature Request
Category System
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas Bächler (brain0)
Architecture All
Severity Low
Priority Normal
Reported Version 2007.05 Duke
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
current setup will fail and likely panic during fsck after just one failed attempt to enter a password for an encrypted mount with "ASK" in /etc/cryptab. included is a patch that allows 3 tries to type in the correct password before giving up.

Additional info:
current/initscripts 0.8-12


Steps to reproduce:
This task depends upon

Closed by  Thomas Bächler (brain0)
Sunday, 21 October 2007, 09:11 GMT
Reason for closing:  Fixed
Additional comments about closing:  Using cryptsetup to ask for the passphrase works, if done properly.

There is a fix in initscripts-git, which will be in testing soon.

You can even specify the number of retries to cryptsetup using the fourth column of crypttab.
Comment by Jonathan Frazier (wide-eye) - Monday, 30 July 2007, 19:29 GMT
reproduce: setup a /home dir with luks encryption, add it to crypttab with ASK for the key. fail to enter the correct password during boot.
Comment by Petar Bogdanovic (pebo) - Friday, 31 August 2007, 01:09 GMT
This PR seems to be a duplicate of  FS#7267 :

http://bugs.archlinux.org/task/7267
Comment by Tobias Powalowski (tpowa) - Thursday, 18 October 2007, 07:48 GMT
thomas is the patch attached safe?

Loading...