Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#77029 - [devtools] Installation of bash 5.2.0-1 breaks devtools scripts

Attached to Project: Arch Linux
Opened by Alexander Haeussler (eminor) - Saturday, 07 January 2023, 07:44 GMT
Last edited by Antonio Rojas (arojas) - Saturday, 07 January 2023, 08:06 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

I built bash 5.2.0-1 in a clean chroot and installed it. After that I tried to build other packages, but the build scripts were failing. I'm guessing it has something to do with the extglob option, because in the devtools scripts extglob is enabled right before the mapfile command, but when I tried a similar mapfile command in a terminal I got the same error only when extglob was disabled.

I tried devtools 20221012-2 and 20230105 and both fail with the error:

/usr/bin/arch-nspawn: line 153: syntax error near unexpected token `('
/usr/bin/arch-nspawn: line 153: ` mapfile -t packages < <(printf "%s\n" "$dir"/"${targetname}"-"${targetver}"-*"${targetarch}".pkg.tar?(.!(sig|*.*)))'
/usr/bin/makechrootpkg: line 153: syntax error near unexpected token `('
/usr/bin/makechrootpkg: line 153: ` mapfile -t packages < <(printf "%s\n" "$dir"/"${targetname}"-"${targetver}"-*"${targetarch}".pkg.tar?(.!(sig|*.*)))'

Additional info:
* package versions: bash 5.2.0-1, devtools 20221012-2 and 20230105
This task depends upon

Closed by  Antonio Rojas (arojas)
Saturday, 07 January 2023, 08:06 GMT
Reason for closing:  Not a bug
Additional comments about closing:  This bug tracker is for Arch packages and Arch doesn't ship bash 5.2 yet. Please report issues for upstream projects in their respective gitlab pages.

Loading...