Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#76934 - [linux] amdgpu - External displays connected through Thinkpad USB-C Dock not detected

Attached to Project: Arch Linux
Opened by A. Sarkar (asarkar) - Sunday, 25 December 2022, 18:30 GMT
Last edited by Jan Alexander Steffens (heftig) - Friday, 13 January 2023, 08:43 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 12
Private No

Details

Description:

External displays connected via DisplayPort to a Thinkpad USB-C Dock are not detected.

xrandr reports they are disconnected even when the laptop is plugged in.

Other peripherals connected to the dock (keyboard and mouse) are successfully detected.

I confirmed that another laptop running Ubuntu (Intel graphics) could connect to the dock and the external displays.

Additional info:

journalctl shows the following error (repeated several times) after pluggin in the dock:

[drm:dc_link_allocate_mst_payload [amdgpu]] *ERROR* Failure: pbn_per_slot==0 not allowed. Cannot continue, returning DC_UNSUPPORTED_VALUE.

Hardware:

Thinkpad X13 (AMD Ryzen 5 PRO 5650U with Radeon Graphics)
Thinkpad Universal USB-C Dock

Packages:

linux 6.1.1.arch1-1
xf86-video-amdgpu 22.0.0-1


Steps to reproduce:

Plug in the laptop to the dock
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Friday, 13 January 2023, 08:43 GMT
Reason for closing:  Fixed
Additional comments about closing:  6.1.5.arch2-1
Comment by Toolybird (Toolybird) - Monday, 26 December 2022, 00:28 GMT Comment by Emre Erenoglu (erenoglu) - Monday, 26 December 2022, 09:16 GMT
I confirm. Since the kernel upgrade, my two displays attached to my docking station (usb-c) are not functioning. My gpu is run by amdgpu.
They are detected in Gnome Displays and enabled, and the system things they are working (ie the primary display is on one of the external screens), but the monitors are switching to standby mode as they dont detect a signal.
Comment by mixin (mixin) - Monday, 26 December 2022, 10:36 GMT
Same for me. I have a HDMI to DVI adapter and one of the external display didn't work after update to kernel 6.1.1-arch1-1. I rolled it back to 6.0.12-arch1-1 and worked as expected.
In the log you'd usually see a kernel stack trace this this:

Dec 25 11:33:47 matebook kernel: ------------[ cut here ]------------
Dec 25 11:33:47 matebook kernel: WARNING: CPU: 13 PID: 156 at drivers/gpu/drm/amd/amdgpu/../display/dc/core/dc_link.c:3533 update_mst_stream_alloc_table+0x150/0x160 [amdgpu]
Dec 25 11:33:47 matebook kernel: Modules linked in: snd_rn_pci_acp3x vfat snd_hwdep irqbypass snd_acp_config snd_pcm pcc_cpufreq(-) fat hid_multitouch(+) cfg80211(+) crct10dif_pclmul fjes(-) crc32_pclmul snd_so>
Dec 25 11:33:47 matebook kernel: CPU: 13 PID: 156 Comm: kworker/13:1 Not tainted 6.1.1-arch1-1 #1 9bd09188b430be630e611f984454e4f3c489be77
Dec 25 11:33:47 matebook kernel: Hardware name: HUAWEI CREM-WXX9/CREM-WXX9-PCB-B1, BIOS 2.23 01/19/2022
Dec 25 11:33:47 matebook kernel: Workqueue: events_long drm_dp_mst_link_probe_work [drm_display_helper]
Dec 25 11:33:47 matebook kernel: RIP: 0010:update_mst_stream_alloc_table+0x150/0x160 [amdgpu]
Dec 25 11:33:47 matebook kernel: Code: 00 00 75 2d 48 81 c4 98 00 00 00 5b 5d 41 5c c3 cc cc cc cc 41 0f b7 40 04 4d 89 19 49 89 59 08 66 41 89 41 10 e9 71 ff ff ff <0f> 0b e9 fe fe ff ff e8 24 b6 00 f6 0f 1f 4>
Dec 25 11:33:47 matebook kernel: RSP: 0018:ffffa5564071f680 EFLAGS: 00010202
Dec 25 11:33:47 matebook kernel: RAX: 0000000000000002 RBX: 0000000000000000 RCX: 0000000000000000
Dec 25 11:33:47 matebook kernel: RDX: 0000000000000000 RSI: ffffa5564071f680 RDI: ffffa5564071f710
Dec 25 11:33:47 matebook kernel: RBP: ffff92bfc4400aa0 R08: ffffa5564071f740 R09: ffffa5564071f488
Dec 25 11:33:47 matebook kernel: R10: ffff92bfcbf66000 R11: ffff92bfc9d14300 R12: 0000000000000002
Dec 25 11:33:47 matebook kernel: R13: ffff92bfc61fe800 R14: ffffffffc0b7d4c0 R15: 0000000000000000
Dec 25 11:33:47 matebook kernel: FS: 0000000000000000(0000) GS:ffff92c2ce140000(0000) knlGS:0000000000000000
Dec 25 11:33:47 matebook kernel: CS: 0010 DS: 0000 ES: 0000 CR0: 0000000080050033
Dec 25 11:33:47 matebook kernel: CR2: 00007f4cd8bd4000 CR3: 0000000104270000 CR4: 0000000000750ee0
Dec 25 11:33:47 matebook kernel: PKRU: 55555554
Dec 25 11:33:47 matebook kernel: Call Trace:
Dec 25 11:33:47 matebook kernel: <TASK>
Dec 25 11:33:47 matebook kernel: dc_link_allocate_mst_payload+0x99/0x2a0 [amdgpu 895e2b3772442c7d04dbf61a65c8a3690bb074b6]
Dec 25 11:33:47 matebook kernel: core_link_enable_stream+0x7d0/0x980 [amdgpu 895e2b3772442c7d04dbf61a65c8a3690bb074b6]
Dec 25 11:33:47 matebook kernel: ? optc1_set_drr+0x13a/0x1e0 [amdgpu 895e2b3772442c7d04dbf61a65c8a3690bb074b6]
Dec 25 11:33:47 matebook kernel: dce110_apply_ctx_to_hw+0x67b/0x720 [amdgpu 895e2b3772442c7d04dbf61a65c8a3690bb074b6]
Dec 25 11:33:47 matebook kernel: ? __free_pages_ok+0x2a7/0x530
Dec 25 11:33:47 matebook kernel: ? dcn10_wait_for_mpcc_disconnect+0x3d/0x150 [amdgpu 895e2b3772442c7d04dbf61a65c8a3690bb074b6]
Dec 25 11:33:47 matebook kernel: dc_commit_state_no_check+0x38c/0xc70 [amdgpu 895e2b3772442c7d04dbf61a65c8a3690bb074b6]
Dec 25 11:33:47 matebook kernel: dc_commit_state+0x96/0x110 [amdgpu 895e2b3772442c7d04dbf61a65c8a3690bb074b6]
Dec 25 11:33:47 matebook kernel: amdgpu_dm_atomic_commit_tail+0x4a4/0x2ae0 [amdgpu 895e2b3772442c7d04dbf61a65c8a3690bb074b6]
Dec 25 11:33:47 matebook kernel: ? dcn21_fast_validate_bw+0x3c2/0x490 [amdgpu 895e2b3772442c7d04dbf61a65c8a3690bb074b6]
Dec 25 11:33:47 matebook kernel: ? dcn21_validate_bandwidth_fp+0x115/0x6e0 [amdgpu 895e2b3772442c7d04dbf61a65c8a3690bb074b6]
Dec 25 11:33:47 matebook kernel: ? resource_build_scaling_params+0x908/0xeb0 [amdgpu 895e2b3772442c7d04dbf61a65c8a3690bb074b6]

Issue has been closed in favour of https://gitlab.freedesktop.org/drm/amd/-/issues/2171, which has been worked on since 28th Sep.
Comment by David (ogghi) - Thursday, 29 December 2022, 07:54 GMT
OK, same for me. Just downgraded to 6.0.9, all works fine.
How can I stay updated if there is a fix? :D
Happy holidays people!
Comment by mixin (mixin) - Thursday, 29 December 2022, 08:00 GMT
Hi David,
I've just subscribed to the notifications for https://gitlab.freedesktop.org/drm/amd/-/issues/2171. I'll post a comment here when anything gets merged. I've also put a thumbs up to the issue so it gets more attention (according to the README in https://gitlab.freedesktop.org/drm/amd).
Enjoy your holidays as well :)
Comment by David (ogghi) - Thursday, 29 December 2022, 08:11 GMT
Hi mixin, I am registering there and also subscribing to the topic :)
Thanks!
Comment by besendorf (besendorf) - Tuesday, 03 January 2023, 12:07 GMT
Thanks for reporting. Im replying to also get notifications.
Comment by Stephan Wienczny (bugbuster) - Wednesday, 04 January 2023, 10:55 GMT
Also affects me. Im replying to also get notifications.

Comment by px (gofree) - Wednesday, 04 January 2023, 16:52 GMT
also for notficiations
Comment by A. Sarkar (asarkar) - Thursday, 05 January 2023, 23:42 GMT
This appears to be fixed in linux 6.1.3-arch1-1.
Comment by Mario Oenning (moson) - Friday, 06 January 2023, 12:14 GMT
> This appears to be fixed in linux 6.1.3-arch1-1.

Nah. Not yet fixed.
Comment by Arthur (Arthur_W) - Monday, 09 January 2023, 08:21 GMT
also for notifications
Comment by Toolybird (Toolybird) - Monday, 09 January 2023, 08:28 GMT
FFS, just *add* yourself to the notifications list! Any more "empty" comments here will result in *all* being deleted. First and final warning.
Comment by Arthur (Arthur_W) - Monday, 09 January 2023, 10:46 GMT
also for notifications
Comment by Mario Oenning (moson) - Thursday, 12 January 2023, 21:03 GMT Comment by Jan Alexander Steffens (heftig) - Friday, 13 January 2023, 00:54 GMT
Patch added to 6.1.5.arch2-1
Comment by Mario Oenning (moson) - Friday, 13 January 2023, 07:44 GMT
@heftig: thanks Jan. Can confirm MST is working properly with 6.1.5.arch2-1.

Loading...