Community Packages

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#76898 - [racket-minimal] should not install the dummy `docindex.sqlite'

Attached to Project: Community Packages
Opened by usao (usao) - Wednesday, 21 December 2022, 10:03 GMT
Last edited by George Rawlinson (rawlinsong) - Friday, 23 December 2022, 07:37 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Kyle Keen (keenerd)
George Rawlinson (rawlinsong)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No



Additional info:
* package version(s)
* config and/or log files etc.
* link to upstream bug report, if any

Steps to reproduce:
This task depends upon

Closed by  George Rawlinson (rawlinsong)
Friday, 23 December 2022, 07:37 GMT
Reason for closing:  Fixed
Additional comments about closing:  8.7-2
Comment by usao (usao) - Wednesday, 21 December 2022, 10:07 GMT
Sorry that I accidentally submitted the request without the description. The dummy `docindex.sqlite' causes the setup of `drracket-tool-doc' to deadlock, and possibly other operations that try to connect to the dummy database. To reproduce, run `raco pkg install drracket-tool-doc'. Removing the dummy database fixes the bug.
Comment by Toolybird (Toolybird) - Wednesday, 21 December 2022, 20:58 GMT
I just tried to repro in a fresh VM and it seems to work fine. I ran the command as a regular user and a whole pile of stuff got downloaded and installed under $HOME with no error. Have you looked at  FS#60413 ?
Comment by usao (usao) - Thursday, 22 December 2022, 07:17 GMT

1. As I understand,  FS#60413  is about the main distribution, not the minimal distribution. Since only the main distribution comes with `racket-index', only it needs to install the `docindex.sqlite' file (which should be a _generated_ database);

2. No, the setup still deadlocks for me in a new container. It's specifically the _setup_ that deadlocks, not the downloading or installation of the package, because the rendering of the Scribble file tries to access the dummy database;

3. An alternative way to reproduce the deadlock is to manually invoke `show-content' (from the `drracket/check-syntax' module in the `drracket-tool-text-lib' package). Below is the result I receive along with the deadlock:

> (require drracket/check-syntax)
> (show-content
(build-path (current-directory) "dummy-file.rkt")
(open-input-string "#f")))
; virtual-statement: no such table: documented
; error code: 1
; [,bt for context]

which is, again, fixed by removing the dummy database.
Comment by usao (usao) - Thursday, 22 December 2022, 07:18 GMT
(Duplicated reply)