Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#76708 - [nvidia] 525.60.11-1 not working

Attached to Project: Arch Linux
Opened by Lexi (Laxyy) - Thursday, 01 December 2022, 10:22 GMT
Last edited by Toolybird (Toolybird) - Thursday, 01 December 2022, 19:44 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:


Additional info:
* package version(s)
* config and/or log files etc.
* link to upstream bug report, if any

Steps to reproduce:
This task depends upon

Closed by  Toolybird (Toolybird)
Thursday, 01 December 2022, 19:44 GMT
Reason for closing:  Not a bug
Additional comments about closing:  See comments
Comment by Lexi (Laxyy) - Thursday, 01 December 2022, 10:40 GMT
Ok, accidentally send without finishing... :(
So upgrading to 525.60.11-1 my GUI not working (x11 & wayland)

$ vulkaninfo --summary
ERROR: [Loader Message] Code 0 : loader_scanned_icd_add: Could not get 'vkCreateInstance' via 'vk_icdGetInstanceProcAddr' for ICD libGLX_nvidia.so.0
ERROR: [Loader Message] Code 0 : vkCreateInstance: Found no drivers!
Cannot create Vulkan instance.
This problem is often caused by a faulty installation of the Vulkan driver or attempting to use a GPU that does not support Vulkan.
ERROR at /build/vulkan-tools/src/Vulkan-Tools-1.3.226/vulkaninfo/vulkaninfo.h:672:vkCreateInstance failed with ERROR_INCOMPATIBLE_DRIVER

$ nvidia-smi
Failed to initialize NVML: Driver/library version mismatch
Comment by Lexi (Laxyy) - Thursday, 01 December 2022, 10:51 GMT
When I look in dmesg, I see this:
[ 810.747151] NVRM: API mismatch: the client has the version 525.60.11, but
NVRM: this kernel module has the version 520.56.06. Please
NVRM: make sure that this kernel module and all NVIDIA driver
NVRM: components have the same version.

If I check `modinfo nvidia` it says 525.60.11 in version.
Is it nvidia side problem?
Comment by cmm11 (cmm11) - Thursday, 01 December 2022, 12:36 GMT
Ran into this issue this morning after my daily -Syu. Wayland/Xorg wouldn't autostart after login nor manually.
My install is
Kernel - 6.0.10-arch2-1
Plasma - 5.26.4
Wayland - wayland 1.21.0-1
Nvidia Driver - nvidia-open-dkms
Graphics Card - Nvidia 3060Ti

I downgraded:
[ALPM] downgraded nvidia-utils (525.60.11-1 -> 520.56.06-2)
[ALPM] downgraded nvidia-open-dkms (525.60.11-1 -> 520.56.06-11)
and things are working again.
Comment by Doug Newgard (Scimmia) - Thursday, 01 December 2022, 14:07 GMT
The error means that you are still using the old modules. Make sure to reboot, and if you have the modules in your initramfs, make sure to rebuild it.
Comment by Lexi (Laxyy) - Thursday, 01 December 2022, 14:19 GMT
Thanks. I updated the initramfs (mkinitcpio -P linux) and it works now.
Comment by cmm11 (cmm11) - Thursday, 01 December 2022, 15:25 GMT
Can also confirm the issue was fixed by generating the initramfs again.
I forgot to update/change my pacman hook for the nvidia-open-dkms driver.

Loading...