Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#76695 - [xfce4-screenshooter] is capturing always the same content

Attached to Project: Arch Linux
Opened by Thomas Jäger (xunil64) - Tuesday, 29 November 2022, 08:01 GMT
Last edited by Toolybird (Toolybird) - Thursday, 22 December 2022, 20:35 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: xfce4-screenshooter is capturing always the same content, so only possible to use once


Additional info:
* package version(s)
local/xfce4-screenshooter 1.10.0-1 (xfce4-goodies)

* config and/or log files etc.
* link to upstream bug report, if any

Steps to reproduce:

Start xfce4-screenshooter, take a screenshot (rectangle), show preview (for example using image viewer), close this preview, close screenshooter
Open xfce4-screenshooter again, take another screenshot (different region etc.), preview or saving the second screenshot will be the same as the first one


This task depends upon

Closed by  Toolybird (Toolybird)
Thursday, 22 December 2022, 20:35 GMT
Reason for closing:  Fixed
Additional comments about closing:  xfce4-screenshooter 1.10.1-1
Comment by Thomas Jäger (xunil64) - Tuesday, 29 November 2022, 08:22 GMT Comment by nordine-philippe abdessemed (npa) - Tuesday, 29 November 2022, 13:04 GMT
Hi same problem for me.
Xfce4-screenshoter is not usable.
Comment by Toolybird (Toolybird) - Tuesday, 29 November 2022, 21:14 GMT
Cannot repro in a fresh VM. Upstream link suggests gnome-screenshot also affected, and that issue possibly exists at a deeper level (xorg, gdk, video driver, etc)
Comment by Toolybird (Toolybird) - Thursday, 01 December 2022, 02:57 GMT
Still cannot repro, even with gnome-screenshot, even with different drivers (nouveau vs nvidia). Unless someone can determine how to reliably repro and provide the *exact* steps then I'm afraid nothing will happen..
Comment by Thomas Jäger (xunil64) - Thursday, 01 December 2022, 07:48 GMT
i can still reproduce the error. Only thing i see in the logs (journalctl -f) when taking the screenshot:

Dec 01 08:44:53 arch panel-29-screen[3535]: Content added to the action area of a dialog using header bars
Dec 01 08:44:53 arch panel-29-screen[3535]: Content added to the action area of a dialog using header bars
Dec 01 08:44:53 arch panel-29-screen[3535]: Content added to the action area of a dialog using header bars
Dec 01 08:44:53 arch panel-29-screen[3535]: Content added to the action area of a dialog using header bars

nothing in other logs
Comment by Thomas Jäger (xunil64) - Friday, 16 December 2022, 10:45 GMT
With the new xfce 4.18 i cannot reproduce the issue at least currently its working
Comment by nordine-philippe abdessemed (npa) - Friday, 16 December 2022, 21:24 GMT
The issue is still here after some tests.
Comment by Toolybird (Toolybird) - Sunday, 18 December 2022, 02:04 GMT
In linked upstream ticket, xfce dev has found Intel graphics as a possible factor [1]

[1] https://gitlab.xfce.org/apps/xfce4-screenshooter/-/issues/89#note_61714

Loading...